1 |
brianr |
1.1 |
# $Id: smeserver-hylafax.spec,v 1.4 2016/05/05 04:03:55 unnilennium Exp $ |
2 |
|
|
# Authority: dungog |
3 |
|
|
# Name: Stephen Noble |
4 |
|
|
|
5 |
|
|
%define name smeserver-hylafax |
6 |
|
|
%define version 0.9 |
7 |
|
|
%define release 9 |
8 |
|
|
Summary: Set up hylafax for sending and receiving facsimiles. |
9 |
|
|
Name: %{name} |
10 |
|
|
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: GNU GPL version 2 |
13 |
|
|
URL: http://www.hylafax.org/ |
14 |
|
|
Group: SMEserver/addon |
15 |
|
|
Source: %{name}-%{version}.tar.gz |
16 |
|
|
Patch1: smeserver-hylafax-0.9-6.symlink.patch |
17 |
|
|
Patch2: smeserver-hylafax-0.9.sme9.patch |
18 |
|
|
BuildRoot: /var/tmp/%{name}-%{version} |
19 |
|
|
BuildArchitectures: noarch |
20 |
|
|
BuildRequires: e-smith-devtools >= 1.13.1-03 |
21 |
|
|
Requires: e-smith-release >= 7.1 |
22 |
|
|
Requires: hylafax >= 4.3 |
23 |
|
|
AutoReqProv: no |
24 |
|
|
|
25 |
|
|
%description |
26 |
|
|
HylaFAX is an enterprise-class system for sending and receiving facsimiles |
27 |
|
|
|
28 |
|
|
%changelog |
29 |
|
|
* Wed May 04 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.9-9.sme |
30 |
|
|
- fix permission problem on xferfaxlog [SME: 7828] |
31 |
|
|
- r9: avoid xferfaxlog from being replaced on update |
32 |
|
|
|
33 |
|
|
* Tue May 03 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.9-7.sme |
34 |
|
|
- fix hylafax does not start on SME9 [SME: 9485] |
35 |
|
|
- thank to bunkobugsy for reporting and providing the solution |
36 |
|
|
|
37 |
|
|
* Wed Sep 12 2007 John H. Bennett III <bennettj@johnbennettservices.com> 0.9-6 |
38 |
|
|
- Patch to move the files that were being copied to |
39 |
|
|
/etc/hylafax/etx to var/spool/hylafax/etc/ so that |
40 |
|
|
a yum install will install all RPM's without any errors |
41 |
|
|
- Modify spec file to change directory where the permissions |
42 |
|
|
are applied to for mailfax |
43 |
|
|
|
44 |
|
|
* Thu Jul 05 2007 Stephen Noble <support@dungog.net> |
45 |
|
|
- Build on lordsfam |
46 |
|
|
|
47 |
|
|
* Mon Jun 11 2007 Stephen Noble <support@dungog.net> 0.9-5 |
48 |
|
|
- mimetype/application/pdf fixed [SME: 3000] |
49 |
|
|
- FaxNotify fixed [SME: 3000] |
50 |
|
|
- if (status eq disabled) hylafax is removed from inittab |
51 |
|
|
|
52 |
|
|
* Wed Feb 28 2007 Stephen Noble <support@dungog.net> 0.9-4 |
53 |
|
|
- rename to /var/spool/hylafax/mimetype/image/tiff |
54 |
|
|
- touch /var/spool/hylafax/etc/xferfaxlog |
55 |
|
|
|
56 |
|
|
* Wed Feb 14 2007 Stephen Noble <support@dungog.net> 0.9-3 |
57 |
|
|
- FaxSender user added |
58 |
|
|
|
59 |
|
|
* Sun Feb 11 2007 Stephen Noble <support@dungog.net> 0.9-2 |
60 |
|
|
- FaxNotify added, virtualdomains altered |
61 |
|
|
|
62 |
|
|
* Sat Feb 10 2007 Stephen Noble <support@dungog.net> 0.9-1 |
63 |
|
|
- initial release |
64 |
|
|
|
65 |
|
|
%prep |
66 |
|
|
%setup |
67 |
|
|
|
68 |
|
|
%patch1 -p1 |
69 |
|
|
%patch2 -p1 |
70 |
|
|
|
71 |
|
|
|
72 |
|
|
%build |
73 |
|
|
perl createlinks |
74 |
|
|
|
75 |
|
|
mkdir -p root/etc/e-smith/db/configuration/defaults/hylafax |
76 |
|
|
echo "service" > root/etc/e-smith/db/configuration/defaults/hylafax/type |
77 |
|
|
echo "enabled" > root/etc/e-smith/db/configuration/defaults/hylafax/status |
78 |
|
|
echo "ttyS0" > root/etc/e-smith/db/configuration/defaults/hylafax/port |
79 |
|
|
/bin/touch root/var/spool/hylafax/etc/xferfaxlog |
80 |
|
|
|
81 |
|
|
%install |
82 |
|
|
rm -rf $RPM_BUILD_ROOT |
83 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
84 |
|
|
rm -f %{name}-%{version}-filelist |
85 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
86 |
|
|
--file '/var/spool/hylafax/mimetype/application/pdf' 'attr(0755,root,root)' \ |
87 |
|
|
--file '/var/spool/hylafax/mimetype/application/ps' 'attr(0755,root,root)' \ |
88 |
|
|
--file '/var/spool/hylafax/mimetype/image/tiff' 'attr(0755,root,root)' \ |
89 |
|
|
--file '/var/spool/hylafax/etc/mailfax' 'attr(0755,root,root)' \ |
90 |
|
|
--file '/var/spool/hylafax/etc/xferfaxlog' 'config(noreplace) %attr(0755,uucp,uucp)' \ |
91 |
|
|
> %{name}-%{version}-filelist |
92 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
93 |
|
|
|
94 |
|
|
%clean |
95 |
|
|
cd .. |
96 |
|
|
rm -rf %{name}-%{version} |
97 |
|
|
|
98 |
|
|
%pre |
99 |
|
|
%preun |
100 |
|
|
%post |
101 |
|
|
# remarq as this should not be here |
102 |
|
|
#/sbin/e-smith/expand-template /etc/hylafax/hyla.conf |
103 |
|
|
#/sbin/e-smith/expand-template /etc/init/ttyS0.conf |
104 |
|
|
#/bin/rm -f /etc/cron.daily/hylafax |
105 |
|
|
#/bin/touch /var/spool/hylafax/etc/xferfaxlog |
106 |
|
|
#echo "see http://wiki.contribs.org/HylaFax" |
107 |
|
|
|
108 |
|
|
%postun |
109 |
|
|
/sbin/e-smith/expand-template /etc/inittab |
110 |
|
|
/sbin/init q |
111 |
|
|
|
112 |
|
|
%files -f %{name}-%{version}-filelist |
113 |
|
|
%defattr(-,root,root) |