/[smecontribs]/rpms/smeserver-hylafax/contribs10/smeserver-hylafax.spec
ViewVC logotype

Annotation of /rpms/smeserver-hylafax/contribs10/smeserver-hylafax.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.4 - (hide annotations) (download)
Thu Oct 14 12:24:11 2021 UTC (2 years, 7 months ago) by brianr
Branch: MAIN
CVS Tags: smeserver-hylafax-0_9-12_el7_sme
Changes since 1.3: +7 -2 lines
* Wed Oct 13 2021 Brian Read <brianr@bjsystems.co.uk> 0.9-12.sme
- Add restart event without conf expand as faxsetup writes to it [SME: 11269]

1 brianr 1.4 # $Id: smeserver-hylafax.spec,v 1.3 2021/10/12 08:47:52 brianr Exp $
2 brianr 1.1 # Authority: dungog
3     # Name: Stephen Noble
4    
5     %define name smeserver-hylafax
6     %define version 0.9
7 brianr 1.4 %define release 12
8 brianr 1.1 Summary: Set up hylafax for sending and receiving facsimiles.
9     Name: %{name}
10     Version: %{version}
11     Release: %{release}%{?dist}
12     License: GNU GPL version 2
13     URL: http://www.hylafax.org/
14     Group: SMEserver/addon
15     Source: %{name}-%{version}.tar.gz
16     Patch1: smeserver-hylafax-0.9-6.symlink.patch
17     Patch2: smeserver-hylafax-0.9.sme9.patch
18 brianr 1.2 Patch3: smeserver-hylafax-0.9-Take-out-initd-calls-in-createlinks-file.patch
19 brianr 1.3 Patch4: smeserver-hylafax-0.9-Add-Update-event-to-createlinks.patch
20 brianr 1.4 Patch5: smeserver-hylafax-0.9-Add-restart-event-without-conf-expand.patch
21 brianr 1.3
22 brianr 1.1 BuildRoot: /var/tmp/%{name}-%{version}
23     BuildArchitectures: noarch
24     BuildRequires: e-smith-devtools >= 1.13.1-03
25     Requires: e-smith-release >= 7.1
26     Requires: hylafax >= 4.3
27     AutoReqProv: no
28    
29     %description
30     HylaFAX is an enterprise-class system for sending and receiving facsimiles
31    
32     %changelog
33 brianr 1.4 * Wed Oct 13 2021 Brian Read <brianr@bjsystems.co.uk> 0.9-12.sme
34     - Add restart event without conf expand as faxsetup writes to it [SME: 11269]
35    
36 brianr 1.3 * Mon Oct 11 2021 Brian Read <brianr@bjsystems.co.uk> 0.9-11.sme
37     - Add-Update-event-to-createlinks.patch [SME: 11269]
38    
39 brianr 1.2 * Fri Dec 18 2020 Brian Read <brianr@bjsystems.co.uk> 0.9-10.sme
40     - Initial import to SME10 [SME:11269 ]
41     - Take-out-initd-calls-in-createlinks-file
42    
43 brianr 1.1 * Wed May 04 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.9-9.sme
44     - fix permission problem on xferfaxlog [SME: 7828]
45     - r9: avoid xferfaxlog from being replaced on update
46    
47     * Tue May 03 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.9-7.sme
48     - fix hylafax does not start on SME9 [SME: 9485]
49     - thank to bunkobugsy for reporting and providing the solution
50    
51     * Wed Sep 12 2007 John H. Bennett III <bennettj@johnbennettservices.com> 0.9-6
52     - Patch to move the files that were being copied to
53     /etc/hylafax/etx to var/spool/hylafax/etc/ so that
54     a yum install will install all RPM's without any errors
55     - Modify spec file to change directory where the permissions
56     are applied to for mailfax
57    
58     * Thu Jul 05 2007 Stephen Noble <support@dungog.net>
59     - Build on lordsfam
60    
61     * Mon Jun 11 2007 Stephen Noble <support@dungog.net> 0.9-5
62     - mimetype/application/pdf fixed [SME: 3000]
63     - FaxNotify fixed [SME: 3000]
64     - if (status eq disabled) hylafax is removed from inittab
65    
66     * Wed Feb 28 2007 Stephen Noble <support@dungog.net> 0.9-4
67     - rename to /var/spool/hylafax/mimetype/image/tiff
68     - touch /var/spool/hylafax/etc/xferfaxlog
69    
70     * Wed Feb 14 2007 Stephen Noble <support@dungog.net> 0.9-3
71     - FaxSender user added
72    
73     * Sun Feb 11 2007 Stephen Noble <support@dungog.net> 0.9-2
74     - FaxNotify added, virtualdomains altered
75    
76     * Sat Feb 10 2007 Stephen Noble <support@dungog.net> 0.9-1
77     - initial release
78    
79     %prep
80     %setup
81    
82     %patch1 -p1
83     %patch2 -p1
84 brianr 1.2 %patch3 -p1
85 brianr 1.3 %patch4 -p1
86 brianr 1.4 %patch5 -p1
87 brianr 1.1
88    
89     %build
90     perl createlinks
91    
92     mkdir -p root/etc/e-smith/db/configuration/defaults/hylafax
93     echo "service" > root/etc/e-smith/db/configuration/defaults/hylafax/type
94     echo "enabled" > root/etc/e-smith/db/configuration/defaults/hylafax/status
95     echo "ttyS0" > root/etc/e-smith/db/configuration/defaults/hylafax/port
96 brianr 1.2 #/bin/touch root/var/spool/hylafax/etc/xferfaxlog
97 brianr 1.1
98     %install
99     rm -rf $RPM_BUILD_ROOT
100     (cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
101     rm -f %{name}-%{version}-filelist
102     /sbin/e-smith/genfilelist $RPM_BUILD_ROOT \
103     --file '/var/spool/hylafax/mimetype/application/pdf' 'attr(0755,root,root)' \
104     --file '/var/spool/hylafax/mimetype/application/ps' 'attr(0755,root,root)' \
105     --file '/var/spool/hylafax/mimetype/image/tiff' 'attr(0755,root,root)' \
106     --file '/var/spool/hylafax/etc/mailfax' 'attr(0755,root,root)' \
107 brianr 1.2 --ignoredir '/var/spool/hylafax' \
108     --ignoredir '/var/spool/hylafax/etc' \
109 brianr 1.1 > %{name}-%{version}-filelist
110     echo "%doc COPYING" >> %{name}-%{version}-filelist
111    
112     %clean
113     cd ..
114     rm -rf %{name}-%{version}
115    
116     %pre
117     %preun
118     %post
119     # remarq as this should not be here
120     #/sbin/e-smith/expand-template /etc/hylafax/hyla.conf
121     #/sbin/e-smith/expand-template /etc/init/ttyS0.conf
122     #/bin/rm -f /etc/cron.daily/hylafax
123     #/bin/touch /var/spool/hylafax/etc/xferfaxlog
124 brianr 1.3 echo "*****************************************"
125     echo "* See http://wiki.contribs.org/HylaFax *"
126     echo "* Remember to run /usr/sbin/faxsetup *"
127     echo "*****************************************"
128 brianr 1.1
129     %postun
130 brianr 1.3 #/sbin/e-smith/expand-template /etc/inittab
131     #/sbin/init q
132 brianr 1.1
133     %files -f %{name}-%{version}-filelist
134     %defattr(-,root,root)

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed