1 |
# $Id: smeserver-hylafax.spec,v 1.6 2021/10/15 11:37:54 brianr Exp $ |
2 |
# Authority: dungog |
3 |
# Name: Stephen Noble |
4 |
|
5 |
%define name smeserver-hylafax |
6 |
%define version 0.9 |
7 |
%define release 15 |
8 |
Summary: Set up hylafax for sending and receiving facsimiles. |
9 |
Name: %{name} |
10 |
Version: %{version} |
11 |
Release: %{release}%{?dist} |
12 |
License: GNU GPL version 2 |
13 |
URL: http://www.hylafax.org/ |
14 |
Group: SMEserver/addon |
15 |
Source: %{name}-%{version}.tar.gz |
16 |
Patch1: smeserver-hylafax-0.9-6.symlink.patch |
17 |
Patch2: smeserver-hylafax-0.9.sme9.patch |
18 |
Patch3: smeserver-hylafax-0.9-Take-out-initd-calls-in-createlinks-file.patch |
19 |
Patch4: smeserver-hylafax-0.9-Add-Update-event-to-createlinks.patch |
20 |
#Patch5: smeserver-hylafax-0.9-Add-restart-event-without-conf-expand.patch - reverse out Release 12 |
21 |
Patch5: smeserver-hylafax-0.9-Add-mailfax-change-from-wiki-and-faxsetup-conf-additions.patch |
22 |
Patch6: smeserver-hylafax-0.9-Add-FaxDispatch-config.patch |
23 |
|
24 |
BuildRoot: /var/tmp/%{name}-%{version} |
25 |
BuildArchitectures: noarch |
26 |
BuildRequires: e-smith-devtools >= 1.13.1-03 |
27 |
Requires: e-smith-release >= 7.1 |
28 |
Requires: hylafax >= 4.3 |
29 |
AutoReqProv: no |
30 |
|
31 |
%description |
32 |
HylaFAX is an enterprise-class system for sending and receiving facsimiles |
33 |
|
34 |
%changelog |
35 |
* Tue Nov 02 2021 Brian Read <brianr@bjsystems.co.uk> 0.9-15.sme |
36 |
- Add FaxDispatch confif file [SME: 11269] |
37 |
|
38 |
* Fri Oct 15 2021 Brian Read <brianr@bjsystems.co.uk> 0.9-14.sme |
39 |
- Add conf fragment for faxsetup fonts [SME: 11269] |
40 |
- Edit in Mailfax changes from wiki |
41 |
|
42 |
|
43 |
* Fri Oct 15 2021 Brian Read <brianr@bjsystems.co.uk> 0.9-13.sme |
44 |
- Reverse out release 12 changes. [SME: 11269] |
45 |
|
46 |
* Wed Oct 13 2021 Brian Read <brianr@bjsystems.co.uk> 0.9-12.sme |
47 |
- Add restart event without conf expand as faxsetup writes to it [SME: 11269] |
48 |
|
49 |
* Mon Oct 11 2021 Brian Read <brianr@bjsystems.co.uk> 0.9-11.sme |
50 |
- Add-Update-event-to-createlinks.patch [SME: 11269] |
51 |
|
52 |
* Fri Dec 18 2020 Brian Read <brianr@bjsystems.co.uk> 0.9-10.sme |
53 |
- Initial import to SME10 [SME:11269 ] |
54 |
- Take-out-initd-calls-in-createlinks-file |
55 |
|
56 |
* Wed May 04 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.9-9.sme |
57 |
- fix permission problem on xferfaxlog [SME: 7828] |
58 |
- r9: avoid xferfaxlog from being replaced on update |
59 |
|
60 |
* Tue May 03 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.9-7.sme |
61 |
- fix hylafax does not start on SME9 [SME: 9485] |
62 |
- thank to bunkobugsy for reporting and providing the solution |
63 |
|
64 |
* Wed Sep 12 2007 John H. Bennett III <bennettj@johnbennettservices.com> 0.9-6 |
65 |
- Patch to move the files that were being copied to |
66 |
/etc/hylafax/etx to var/spool/hylafax/etc/ so that |
67 |
a yum install will install all RPM's without any errors |
68 |
- Modify spec file to change directory where the permissions |
69 |
are applied to for mailfax |
70 |
|
71 |
* Thu Jul 05 2007 Stephen Noble <support@dungog.net> |
72 |
- Build on lordsfam |
73 |
|
74 |
* Mon Jun 11 2007 Stephen Noble <support@dungog.net> 0.9-5 |
75 |
- mimetype/application/pdf fixed [SME: 3000] |
76 |
- FaxNotify fixed [SME: 3000] |
77 |
- if (status eq disabled) hylafax is removed from inittab |
78 |
|
79 |
* Wed Feb 28 2007 Stephen Noble <support@dungog.net> 0.9-4 |
80 |
- rename to /var/spool/hylafax/mimetype/image/tiff |
81 |
- touch /var/spool/hylafax/etc/xferfaxlog |
82 |
|
83 |
* Wed Feb 14 2007 Stephen Noble <support@dungog.net> 0.9-3 |
84 |
- FaxSender user added |
85 |
|
86 |
* Sun Feb 11 2007 Stephen Noble <support@dungog.net> 0.9-2 |
87 |
- FaxNotify added, virtualdomains altered |
88 |
|
89 |
* Sat Feb 10 2007 Stephen Noble <support@dungog.net> 0.9-1 |
90 |
- initial release |
91 |
|
92 |
%prep |
93 |
%setup |
94 |
|
95 |
%patch1 -p1 |
96 |
%patch2 -p1 |
97 |
%patch3 -p1 |
98 |
%patch4 -p1 |
99 |
#%patch5 -p1 - Reverse out release 12 changes. |
100 |
%patch5 -p1 |
101 |
%patch6 -p1 |
102 |
|
103 |
|
104 |
%build |
105 |
perl createlinks |
106 |
|
107 |
mkdir -p root/etc/e-smith/db/configuration/defaults/hylafax |
108 |
echo "service" > root/etc/e-smith/db/configuration/defaults/hylafax/type |
109 |
echo "enabled" > root/etc/e-smith/db/configuration/defaults/hylafax/status |
110 |
echo "ttyS0" > root/etc/e-smith/db/configuration/defaults/hylafax/port |
111 |
#/bin/touch root/var/spool/hylafax/etc/xferfaxlog |
112 |
|
113 |
%install |
114 |
rm -rf $RPM_BUILD_ROOT |
115 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
116 |
rm -f %{name}-%{version}-filelist |
117 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
118 |
--file '/var/spool/hylafax/mimetype/application/pdf' 'attr(0755,root,root)' \ |
119 |
--file '/var/spool/hylafax/mimetype/application/ps' 'attr(0755,root,root)' \ |
120 |
--file '/var/spool/hylafax/mimetype/image/tiff' 'attr(0755,root,root)' \ |
121 |
--file '/var/spool/hylafax/etc/mailfax' 'attr(0755,root,root)' \ |
122 |
--ignoredir '/var/spool/hylafax' \ |
123 |
--ignoredir '/var/spool/hylafax/etc' \ |
124 |
> %{name}-%{version}-filelist |
125 |
echo "%doc COPYING" >> %{name}-%{version}-filelist |
126 |
|
127 |
%clean |
128 |
cd .. |
129 |
rm -rf %{name}-%{version} |
130 |
|
131 |
%pre |
132 |
%preun |
133 |
%post |
134 |
# remarq as this should not be here |
135 |
#/sbin/e-smith/expand-template /etc/hylafax/hyla.conf |
136 |
#/sbin/e-smith/expand-template /etc/init/ttyS0.conf |
137 |
#/bin/rm -f /etc/cron.daily/hylafax |
138 |
#/bin/touch /var/spool/hylafax/etc/xferfaxlog |
139 |
echo "*****************************************" |
140 |
echo "* See http://wiki.contribs.org/HylaFax *" |
141 |
echo "* Remember to run /usr/sbin/faxsetup *" |
142 |
echo "*****************************************" |
143 |
|
144 |
%postun |
145 |
#/sbin/e-smith/expand-template /etc/inittab |
146 |
#/sbin/init q |
147 |
|
148 |
%files -f %{name}-%{version}-filelist |
149 |
%defattr(-,root,root) |