1 |
slords |
1.1 |
Summary: Set up hylafax for sending and receiving facsimiles. |
2 |
|
|
%define name smeserver-hylafax |
3 |
|
|
Name: %{name} |
4 |
|
|
%define version 0.9 |
5 |
|
|
%define release 4 |
6 |
|
|
Version: %{version} |
7 |
slords |
1.2 |
Release: %{release}%{?dist} |
8 |
slords |
1.1 |
Vendor: http://www.hylafax.org/ |
9 |
|
|
License: GPL |
10 |
|
|
URL: http://www.hylafax.org/ |
11 |
|
|
Group: Mitel/addon |
12 |
|
|
Source: %{name}-%{version}.tar.gz |
13 |
|
|
BuildRoot: /var/tmp/%{name}-%{version} |
14 |
|
|
BuildArchitectures: noarch |
15 |
|
|
Requires: e-smith-release >= 7.1 |
16 |
|
|
Requires: hylafax >= 4.3 |
17 |
slords |
1.4 |
BuildRequires: e-smith-devtools |
18 |
slords |
1.1 |
AutoReqProv: no |
19 |
|
|
|
20 |
|
|
%description |
21 |
|
|
HylaFAX is an enterprise-class system for sending and receiving facsimiles |
22 |
|
|
|
23 |
|
|
%changelog |
24 |
|
|
* Wed Feb 28 2007 Stephen Noble <stephen@dungog.net> 0.9-4 |
25 |
|
|
- rename to /var/spool/hylafax/mimetype/image/tiff |
26 |
|
|
- touch /var/spool/hylafax/etc/xferfaxlog |
27 |
|
|
|
28 |
|
|
* Wed Feb 14 2007 Stephen Noble <stephen@dungog.net> 0.9-3 |
29 |
|
|
- FaxSender user added |
30 |
|
|
|
31 |
|
|
* Sun Feb 11 2007 Stephen Noble <stephen@dungog.net> 0.9-2 |
32 |
|
|
- FaxNotify added, virtualdomains altered |
33 |
|
|
|
34 |
|
|
* Sat Feb 10 2007 Stephen Noble <stephen@dungog.net> 0.9-1 |
35 |
|
|
- initial release |
36 |
|
|
|
37 |
|
|
%prep |
38 |
|
|
%setup |
39 |
|
|
|
40 |
|
|
%build |
41 |
|
|
perl createlinks |
42 |
|
|
|
43 |
|
|
mkdir -p root/etc/e-smith/db/configuration/defaults/hylafax |
44 |
|
|
echo "service" > root/etc/e-smith/db/configuration/defaults/hylafax/type |
45 |
|
|
echo "enabled" > root/etc/e-smith/db/configuration/defaults/hylafax/status |
46 |
|
|
echo "ttyS0" > root/etc/e-smith/db/configuration/defaults/hylafax/port |
47 |
|
|
|
48 |
|
|
%install |
49 |
|
|
rm -rf $RPM_BUILD_ROOT |
50 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
51 |
|
|
rm -f %{name}-%{version}-filelist |
52 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
53 |
|
|
--file '/var/spool/hylafax/mimetype/application/pdf' 'attr(0755,root,root)' \ |
54 |
|
|
--file '/var/spool/hylafax/mimetype/application/ps' 'attr(0755,root,root)' \ |
55 |
|
|
--file '/var/spool/hylafax/mimetype/image/tiff' 'attr(0755,root,root)' \ |
56 |
|
|
--file '/etc/hylafax/etc/mailfax' 'attr(0755,root,root)' \ |
57 |
|
|
> %{name}-%{version}-filelist |
58 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
59 |
|
|
|
60 |
|
|
%clean |
61 |
|
|
cd .. |
62 |
|
|
rm -rf %{name}-%{version} |
63 |
|
|
|
64 |
|
|
%pre |
65 |
|
|
%preun |
66 |
|
|
%post |
67 |
|
|
/sbin/e-smith/expand-template /etc/hylafax/hyla.conf |
68 |
|
|
/sbin/e-smith/expand-template /etc/inittab |
69 |
|
|
/bin/rm -f /etc/cron.daily/hylafax |
70 |
|
|
/bin/touch /var/spool/hylafax/etc/xferfaxlog |
71 |
|
|
echo "see http://wiki.contribs.org/HylaFax" |
72 |
|
|
|
73 |
|
|
%postun |
74 |
|
|
/sbin/e-smith/expand-template /etc/inittab |
75 |
|
|
/sbin/init q |
76 |
|
|
|
77 |
|
|
%files -f %{name}-%{version}-filelist |
78 |
|
|
%defattr(-,root,root) |