1 |
slords |
1.1 |
%define name smeserver-hylafax |
2 |
|
|
%define version 0.9 |
3 |
|
|
%define release 6 |
4 |
|
|
Summary: Set up hylafax for sending and receiving facsimiles. |
5 |
|
|
Name: %{name} |
6 |
|
|
Version: %{version} |
7 |
|
|
Release: %{release}%{?dist} |
8 |
|
|
License: GNU GPL version 2 |
9 |
|
|
URL: http://www.hylafax.org/ |
10 |
|
|
Group: SMEserver/addon |
11 |
|
|
Source: %{name}-%{version}.tar.gz |
12 |
|
|
Patch1: smeserver-hylafax-0.9-6.symlink.patch |
13 |
|
|
BuildRoot: /var/tmp/%{name}-%{version} |
14 |
|
|
BuildArchitectures: noarch |
15 |
|
|
BuildRequires: e-smith-devtools >= 1.13.1-03 |
16 |
|
|
Requires: e-smith-release >= 7.1 |
17 |
|
|
Requires: hylafax >= 4.3 |
18 |
|
|
AutoReqProv: no |
19 |
|
|
|
20 |
|
|
%description |
21 |
|
|
HylaFAX is an enterprise-class system for sending and receiving facsimiles |
22 |
|
|
|
23 |
|
|
%changelog |
24 |
|
|
* Wed Sep 12 2007 John H. Bennett III <bennettj@johnbennettservices.com> 0.9-6 |
25 |
|
|
- Patch to move the files that were being copied to |
26 |
|
|
/etc/hylafax/etx to var/spool/hylafax/etc/ so that |
27 |
|
|
a yum install will install all RPM's without any errors |
28 |
|
|
- Modify spec file to change directory where the permissions |
29 |
|
|
are applied to for mailfax |
30 |
|
|
|
31 |
|
|
* Thu Jul 05 2007 Stephen Noble <support@dungog.net> |
32 |
|
|
- Build on lordsfam |
33 |
|
|
|
34 |
|
|
* Mon Jun 11 2007 Stephen Noble <support@dungog.net> 0.9-5 |
35 |
|
|
- mimetype/application/pdf fixed [SME: 3000] |
36 |
|
|
- FaxNotify fixed [SME: 3000] |
37 |
|
|
- if (status eq disabled) hylafax is removed from inittab |
38 |
|
|
|
39 |
|
|
* Wed Feb 28 2007 Stephen Noble <support@dungog.net> 0.9-4 |
40 |
|
|
- rename to /var/spool/hylafax/mimetype/image/tiff |
41 |
|
|
- touch /var/spool/hylafax/etc/xferfaxlog |
42 |
|
|
|
43 |
|
|
* Wed Feb 14 2007 Stephen Noble <support@dungog.net> 0.9-3 |
44 |
|
|
- FaxSender user added |
45 |
|
|
|
46 |
|
|
* Sun Feb 11 2007 Stephen Noble <support@dungog.net> 0.9-2 |
47 |
|
|
- FaxNotify added, virtualdomains altered |
48 |
|
|
|
49 |
|
|
* Sat Feb 10 2007 Stephen Noble <support@dungog.net> 0.9-1 |
50 |
|
|
- initial release |
51 |
|
|
|
52 |
|
|
%prep |
53 |
|
|
%setup |
54 |
|
|
|
55 |
|
|
%patch1 -p1 |
56 |
|
|
|
57 |
|
|
%build |
58 |
|
|
perl createlinks |
59 |
|
|
|
60 |
|
|
mkdir -p root/etc/e-smith/db/configuration/defaults/hylafax |
61 |
|
|
echo "service" > root/etc/e-smith/db/configuration/defaults/hylafax/type |
62 |
|
|
echo "enabled" > root/etc/e-smith/db/configuration/defaults/hylafax/status |
63 |
|
|
echo "ttyS0" > root/etc/e-smith/db/configuration/defaults/hylafax/port |
64 |
|
|
|
65 |
|
|
%install |
66 |
|
|
rm -rf $RPM_BUILD_ROOT |
67 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
68 |
|
|
rm -f %{name}-%{version}-filelist |
69 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
70 |
|
|
--file '/var/spool/hylafax/mimetype/application/pdf' 'attr(0755,root,root)' \ |
71 |
|
|
--file '/var/spool/hylafax/mimetype/application/ps' 'attr(0755,root,root)' \ |
72 |
|
|
--file '/var/spool/hylafax/mimetype/image/tiff' 'attr(0755,root,root)' \ |
73 |
|
|
--file '/var/spool/hylafax/etc/mailfax' 'attr(0755,root,root)' \ |
74 |
|
|
> %{name}-%{version}-filelist |
75 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
76 |
|
|
|
77 |
|
|
%clean |
78 |
|
|
cd .. |
79 |
|
|
rm -rf %{name}-%{version} |
80 |
|
|
|
81 |
|
|
%pre |
82 |
|
|
%preun |
83 |
|
|
%post |
84 |
|
|
/sbin/e-smith/expand-template /etc/hylafax/hyla.conf |
85 |
|
|
/sbin/e-smith/expand-template /etc/inittab |
86 |
|
|
/bin/rm -f /etc/cron.daily/hylafax |
87 |
|
|
/bin/touch /var/spool/hylafax/etc/xferfaxlog |
88 |
|
|
echo "see http://wiki.contribs.org/HylaFax" |
89 |
|
|
|
90 |
|
|
%postun |
91 |
|
|
/sbin/e-smith/expand-template /etc/inittab |
92 |
|
|
/sbin/init q |
93 |
|
|
|
94 |
|
|
%files -f %{name}-%{version}-filelist |
95 |
|
|
%defattr(-,root,root) |