1 |
# $Id: smeserver-hylafax.spec,v 1.4 2008/11/25 16:20:24 slords Exp $ |
2 |
# Authority: dungog |
3 |
# Name: Stephen Noble |
4 |
|
5 |
%define name smeserver-hylafax |
6 |
%define version 0.9 |
7 |
%define release 6 |
8 |
Summary: Set up hylafax for sending and receiving facsimiles. |
9 |
Name: %{name} |
10 |
Version: %{version} |
11 |
Release: %{release}%{?dist} |
12 |
License: GNU GPL version 2 |
13 |
URL: http://www.hylafax.org/ |
14 |
Group: SMEserver/addon |
15 |
Source: %{name}-%{version}.tar.gz |
16 |
Patch1: smeserver-hylafax-0.9-6.symlink.patch |
17 |
BuildRoot: /var/tmp/%{name}-%{version} |
18 |
BuildArchitectures: noarch |
19 |
BuildRequires: e-smith-devtools >= 1.13.1-03 |
20 |
Requires: e-smith-release >= 7.1 |
21 |
Requires: hylafax >= 4.3 |
22 |
AutoReqProv: no |
23 |
|
24 |
%description |
25 |
HylaFAX is an enterprise-class system for sending and receiving facsimiles |
26 |
|
27 |
%changelog |
28 |
* Wed Sep 12 2007 John H. Bennett III <bennettj@johnbennettservices.com> 0.9-6 |
29 |
- Patch to move the files that were being copied to |
30 |
/etc/hylafax/etx to var/spool/hylafax/etc/ so that |
31 |
a yum install will install all RPM's without any errors |
32 |
- Modify spec file to change directory where the permissions |
33 |
are applied to for mailfax |
34 |
|
35 |
* Thu Jul 05 2007 Stephen Noble <support@dungog.net> |
36 |
- Build on lordsfam |
37 |
|
38 |
* Mon Jun 11 2007 Stephen Noble <support@dungog.net> 0.9-5 |
39 |
- mimetype/application/pdf fixed [SME: 3000] |
40 |
- FaxNotify fixed [SME: 3000] |
41 |
- if (status eq disabled) hylafax is removed from inittab |
42 |
|
43 |
* Wed Feb 28 2007 Stephen Noble <support@dungog.net> 0.9-4 |
44 |
- rename to /var/spool/hylafax/mimetype/image/tiff |
45 |
- touch /var/spool/hylafax/etc/xferfaxlog |
46 |
|
47 |
* Wed Feb 14 2007 Stephen Noble <support@dungog.net> 0.9-3 |
48 |
- FaxSender user added |
49 |
|
50 |
* Sun Feb 11 2007 Stephen Noble <support@dungog.net> 0.9-2 |
51 |
- FaxNotify added, virtualdomains altered |
52 |
|
53 |
* Sat Feb 10 2007 Stephen Noble <support@dungog.net> 0.9-1 |
54 |
- initial release |
55 |
|
56 |
%prep |
57 |
%setup |
58 |
|
59 |
%patch1 -p1 |
60 |
|
61 |
%build |
62 |
perl createlinks |
63 |
|
64 |
mkdir -p root/etc/e-smith/db/configuration/defaults/hylafax |
65 |
echo "service" > root/etc/e-smith/db/configuration/defaults/hylafax/type |
66 |
echo "enabled" > root/etc/e-smith/db/configuration/defaults/hylafax/status |
67 |
echo "ttyS0" > root/etc/e-smith/db/configuration/defaults/hylafax/port |
68 |
|
69 |
%install |
70 |
rm -rf $RPM_BUILD_ROOT |
71 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
72 |
rm -f %{name}-%{version}-filelist |
73 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
74 |
--file '/var/spool/hylafax/mimetype/application/pdf' 'attr(0755,root,root)' \ |
75 |
--file '/var/spool/hylafax/mimetype/application/ps' 'attr(0755,root,root)' \ |
76 |
--file '/var/spool/hylafax/mimetype/image/tiff' 'attr(0755,root,root)' \ |
77 |
--file '/var/spool/hylafax/etc/mailfax' 'attr(0755,root,root)' \ |
78 |
> %{name}-%{version}-filelist |
79 |
echo "%doc COPYING" >> %{name}-%{version}-filelist |
80 |
|
81 |
%clean |
82 |
cd .. |
83 |
rm -rf %{name}-%{version} |
84 |
|
85 |
%pre |
86 |
%preun |
87 |
%post |
88 |
/sbin/e-smith/expand-template /etc/hylafax/hyla.conf |
89 |
/sbin/e-smith/expand-template /etc/inittab |
90 |
/bin/rm -f /etc/cron.daily/hylafax |
91 |
/bin/touch /var/spool/hylafax/etc/xferfaxlog |
92 |
echo "see http://wiki.contribs.org/HylaFax" |
93 |
|
94 |
%postun |
95 |
/sbin/e-smith/expand-template /etc/inittab |
96 |
/sbin/init q |
97 |
|
98 |
%files -f %{name}-%{version}-filelist |
99 |
%defattr(-,root,root) |