1 |
slords |
1.1 |
Summary: Isoqlog on SME |
2 |
|
|
%define name smeserver-isoqlog |
3 |
|
|
Name: %{name} |
4 |
|
|
%define version 2.2.1 |
5 |
|
|
%define release 1.1 |
6 |
|
|
Version: %{version} |
7 |
|
|
Release: %{release}%{?dist} |
8 |
|
|
License: GPL |
9 |
|
|
Group: Administration |
10 |
|
|
Source: %{name}-%{version}.tar.gz |
11 |
|
|
Packager: Peter Schubert <psc@@s-a-c-o.de> |
12 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-buildroot |
13 |
|
|
BuildArchitectures: noarch |
14 |
|
|
Requires: e-smith-release => 7.5 |
15 |
|
|
Requires: isoqlog => 2.2.1 |
16 |
|
|
AutoReqProv: no |
17 |
|
|
|
18 |
|
|
%changelog |
19 |
|
|
* Thu Aug 16 2012 JP Pialasse <test@pialasse.com> 2.2.1-1-1.sme |
20 |
|
|
- removing isoqlog files from the rpm |
21 |
|
|
- moving to a SME config only |
22 |
|
|
- adding dependency to isoqlog binaries rpm |
23 |
|
|
|
24 |
|
|
* Mon Feb 17 2003 Peter Schubert <psc@s-a-c-o.de> |
25 |
|
|
- some fixes in the "post" section of the SPEC |
26 |
|
|
|
27 |
|
|
* Fri Feb 14 2003 Peter Schubert <psc@s-a-c-o.de> |
28 |
|
|
- initial release |
29 |
|
|
|
30 |
|
|
%description |
31 |
|
|
Installs Isoqlog on SME Server. |
32 |
|
|
|
33 |
|
|
%prep |
34 |
|
|
|
35 |
|
|
%setup |
36 |
|
|
|
37 |
|
|
%build |
38 |
|
|
perl createlinks |
39 |
|
|
|
40 |
|
|
%install |
41 |
|
|
rm -rf $RPM_BUILD_ROOT |
42 |
|
|
#(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
43 |
|
|
#rm -f %{name}-%{version}-filelist |
44 |
|
|
#/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
45 |
|
|
#echo "%doc COPYING" >> %{name}-%{version}-filelist |
46 |
|
|
|
47 |
|
|
%{__mkdir_p} $RPM_BUILD_ROOT/var/service/httpd-isoqlog/supervise |
48 |
|
|
%{__mkdir_p} $RPM_BUILD_ROOT/var/service/httpd-isoqlog/log/supervise |
49 |
|
|
%{__mkdir_p} $RPM_BUILD_ROOT/var/log/httpd-isoqlog |
50 |
|
|
%{__mkdir_p} $RPM_BUILD_ROOT/var/lib/php/isoqlog-session |
51 |
|
|
|
52 |
|
|
|
53 |
|
|
(cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
54 |
|
|
/bin/rm -f %{name}-%{version}-filelist |
55 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
56 |
|
|
--dir /var/service/httpd-isoqlog 'attr(01755,root,root)' \ |
57 |
|
|
--file /var/service/httpd-isoqlog/run 'attr(0700,root,root)' \ |
58 |
|
|
--dir /var/service/httpd-isoqlog/supervise 'attr(0700,root,root)' \ |
59 |
|
|
--dir /var/service/httpd-isoqlog/log 'attr(0755,root,root)' \ |
60 |
|
|
--file /var/service/httpd-isoqlog/log/run 'attr(0755,root,root)' \ |
61 |
|
|
--dir /var/service/httpd-isoqlog/log/supervise 'attr(0700,root,root)' \ |
62 |
|
|
--dir /var/log/httpd-isoqlog 'attr(0750,smelog,smelog)' \ |
63 |
|
|
--dir /var/lib/php/isoqlog-session 'attr(0770,root,isoqlog)' \ |
64 |
|
|
> %{name}-%{version}-filelist |
65 |
|
|
|
66 |
|
|
%clean |
67 |
|
|
rm -rf $RPM_BUILD_ROOT |
68 |
|
|
|
69 |
|
|
%pre |
70 |
|
|
/sbin/e-smith/create-system-user isoqlog 545 'Isoqlog User' /var/lib/qmailtools/isoqlog/htdocs/ /bin/false >& /dev/null || : |
71 |
|
|
|
72 |
|
|
%preun |
73 |
|
|
# Disable services, and stop them |
74 |
|
|
if [ $1 = 0 ]; then # Uninstall only, not upgrade |
75 |
|
|
db configuration setprop httpd-isoqlog status disabled >& /dev/null || : |
76 |
|
|
/sbin/e-smith/signal-event isoqlog-conf |
77 |
|
|
sv d /service/httpd-isoqlog |
78 |
|
|
fi |
79 |
|
|
|
80 |
|
|
true |
81 |
|
|
|
82 |
|
|
%post |
83 |
|
|
/sbin/e-smith/signal-event isoqlog-conf |
84 |
|
|
/usr/bin/isoqlog -f /etc/isoqlog.conf 1>/dev/null 2>/dev/null |
85 |
|
|
|
86 |
|
|
%postun |
87 |
|
|
rm -f /etc/httpd/conf.d/isoqlog.conf |
88 |
|
|
/etc/rc.d/init.d/httpd-e-smith restart |
89 |
|
|
|
90 |
|
|
|
91 |
|
|
%files -f %{name}-%{version}-filelist |
92 |
|
|
%defattr(-,root,root) |
93 |
|
|
|