1 |
slords |
1.1 |
Summary: Isoqlog on SME |
2 |
|
|
%define name smeserver-isoqlog |
3 |
|
|
Name: %{name} |
4 |
|
|
%define version 2.2.1 |
5 |
unnilennium |
1.2 |
%define release 1.2 |
6 |
slords |
1.1 |
Version: %{version} |
7 |
|
|
Release: %{release}%{?dist} |
8 |
|
|
License: GPL |
9 |
|
|
Group: Administration |
10 |
|
|
Source: %{name}-%{version}.tar.gz |
11 |
|
|
Packager: Peter Schubert <psc@@s-a-c-o.de> |
12 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-buildroot |
13 |
|
|
BuildArchitectures: noarch |
14 |
|
|
Requires: e-smith-release => 7.5 |
15 |
|
|
Requires: isoqlog => 2.2.1 |
16 |
unnilennium |
1.2 |
BuildRequires: e-smith-devtools |
17 |
|
|
|
18 |
slords |
1.1 |
AutoReqProv: no |
19 |
|
|
|
20 |
|
|
%changelog |
21 |
unnilennium |
1.2 |
* Wed Aug 30 2012 JP Pialasse <test@pialasse.com> 2.2.1-1.2.sme |
22 |
|
|
- fix BuildRequires |
23 |
|
|
|
24 |
slords |
1.1 |
* Thu Aug 16 2012 JP Pialasse <test@pialasse.com> 2.2.1-1-1.sme |
25 |
|
|
- removing isoqlog files from the rpm |
26 |
|
|
- moving to a SME config only |
27 |
|
|
- adding dependency to isoqlog binaries rpm |
28 |
|
|
|
29 |
|
|
* Mon Feb 17 2003 Peter Schubert <psc@s-a-c-o.de> |
30 |
|
|
- some fixes in the "post" section of the SPEC |
31 |
|
|
|
32 |
|
|
* Fri Feb 14 2003 Peter Schubert <psc@s-a-c-o.de> |
33 |
|
|
- initial release |
34 |
|
|
|
35 |
|
|
%description |
36 |
|
|
Installs Isoqlog on SME Server. |
37 |
|
|
|
38 |
|
|
%prep |
39 |
|
|
|
40 |
|
|
%setup |
41 |
|
|
|
42 |
|
|
%build |
43 |
|
|
perl createlinks |
44 |
|
|
|
45 |
|
|
%install |
46 |
|
|
rm -rf $RPM_BUILD_ROOT |
47 |
|
|
#(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
48 |
|
|
#rm -f %{name}-%{version}-filelist |
49 |
|
|
#/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
50 |
|
|
#echo "%doc COPYING" >> %{name}-%{version}-filelist |
51 |
|
|
|
52 |
|
|
%{__mkdir_p} $RPM_BUILD_ROOT/var/service/httpd-isoqlog/supervise |
53 |
|
|
%{__mkdir_p} $RPM_BUILD_ROOT/var/service/httpd-isoqlog/log/supervise |
54 |
|
|
%{__mkdir_p} $RPM_BUILD_ROOT/var/log/httpd-isoqlog |
55 |
|
|
%{__mkdir_p} $RPM_BUILD_ROOT/var/lib/php/isoqlog-session |
56 |
|
|
|
57 |
|
|
|
58 |
|
|
(cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
59 |
|
|
/bin/rm -f %{name}-%{version}-filelist |
60 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
61 |
|
|
--dir /var/service/httpd-isoqlog 'attr(01755,root,root)' \ |
62 |
|
|
--file /var/service/httpd-isoqlog/run 'attr(0700,root,root)' \ |
63 |
|
|
--dir /var/service/httpd-isoqlog/supervise 'attr(0700,root,root)' \ |
64 |
|
|
--dir /var/service/httpd-isoqlog/log 'attr(0755,root,root)' \ |
65 |
|
|
--file /var/service/httpd-isoqlog/log/run 'attr(0755,root,root)' \ |
66 |
|
|
--dir /var/service/httpd-isoqlog/log/supervise 'attr(0700,root,root)' \ |
67 |
|
|
--dir /var/log/httpd-isoqlog 'attr(0750,smelog,smelog)' \ |
68 |
|
|
--dir /var/lib/php/isoqlog-session 'attr(0770,root,isoqlog)' \ |
69 |
|
|
> %{name}-%{version}-filelist |
70 |
|
|
|
71 |
|
|
%clean |
72 |
|
|
rm -rf $RPM_BUILD_ROOT |
73 |
|
|
|
74 |
|
|
%pre |
75 |
|
|
/sbin/e-smith/create-system-user isoqlog 545 'Isoqlog User' /var/lib/qmailtools/isoqlog/htdocs/ /bin/false >& /dev/null || : |
76 |
|
|
|
77 |
|
|
%preun |
78 |
|
|
# Disable services, and stop them |
79 |
|
|
if [ $1 = 0 ]; then # Uninstall only, not upgrade |
80 |
|
|
db configuration setprop httpd-isoqlog status disabled >& /dev/null || : |
81 |
|
|
/sbin/e-smith/signal-event isoqlog-conf |
82 |
|
|
sv d /service/httpd-isoqlog |
83 |
|
|
fi |
84 |
|
|
|
85 |
|
|
true |
86 |
|
|
|
87 |
|
|
%post |
88 |
|
|
/sbin/e-smith/signal-event isoqlog-conf |
89 |
|
|
/usr/bin/isoqlog -f /etc/isoqlog.conf 1>/dev/null 2>/dev/null |
90 |
|
|
|
91 |
|
|
%postun |
92 |
|
|
rm -f /etc/httpd/conf.d/isoqlog.conf |
93 |
|
|
/etc/rc.d/init.d/httpd-e-smith restart |
94 |
|
|
|
95 |
|
|
|
96 |
|
|
%files -f %{name}-%{version}-filelist |
97 |
|
|
%defattr(-,root,root) |
98 |
|
|
|