1 |
slords |
1.1 |
Summary: SME Server specific Jeta configuration and templates. |
2 |
|
|
%define name smeserver-jeta |
3 |
|
|
Name: %{name} |
4 |
|
|
%define version 1.0 |
5 |
|
|
%define release 1 |
6 |
|
|
Version: %{version} |
7 |
|
|
Release: %{release}%{?dist} |
8 |
|
|
License: GPL |
9 |
|
|
Group: Networking/Daemons |
10 |
|
|
Source: %{name}-%{version}.tar.gz |
11 |
|
|
#Patch1: |
12 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
13 |
|
|
BuildArchitectures: noarch |
14 |
|
|
Requires: imp-h3 >= 4.0 |
15 |
|
|
Requires: e-smith-base >= 4.15.1 |
16 |
|
|
Requires: e-smith-apache >= 1.1.0-18 |
17 |
|
|
Requires: e-smith-lib >= 1.15.1-16 |
18 |
|
|
Requires: jeta-h3 >= 1.0 |
19 |
|
|
BuildRequires: e-smith-devtools >= 1.13.1-03 |
20 |
|
|
AutoReqProv: no |
21 |
|
|
|
22 |
|
|
%changelog |
23 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
24 |
|
|
- Clean up spec so package can be built by koji/plague |
25 |
|
|
|
26 |
|
|
* Wed Apr 4 2007 John H. Bennett III <bennettj@johnbennettservices.com> 1.0-1 |
27 |
|
|
- Initial build |
28 |
|
|
- Added the ability to enable or disable jetag menu icon from showing up on the |
29 |
|
|
main webmail screen. To enable config set jeta service MenuArray disabled|enabled |
30 |
|
|
|
31 |
|
|
%description |
32 |
|
|
This package adds necessary templates and configuration items |
33 |
|
|
so that Jeta will work properly with SME Server |
34 |
|
|
|
35 |
|
|
%prep |
36 |
|
|
%setup |
37 |
|
|
|
38 |
|
|
#%patch1 -p1 |
39 |
|
|
|
40 |
|
|
%build |
41 |
|
|
|
42 |
|
|
perl createlinks |
43 |
|
|
|
44 |
|
|
%install |
45 |
|
|
rm -rf $RPM_BUILD_ROOT |
46 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
47 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
48 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
49 |
|
|
|
50 |
|
|
%clean |
51 |
|
|
rm -rf $RPM_BUILD_ROOT |
52 |
|
|
|
53 |
|
|
%pre |
54 |
|
|
|
55 |
|
|
%preun |
56 |
|
|
|
57 |
|
|
%post |
58 |
|
|
|
59 |
|
|
%postun |
60 |
|
|
|
61 |
|
|
%files -f %{name}-%{version}-filelist |
62 |
|
|
%defattr(-,root,root) |