1 |
# $Id: smeserver-jeta.spec,v 1.1 2010/07/08 15:01:05 slords Exp $ |
2 |
# Authority: mrjhb3 |
3 |
# Name: John H. Bennett III |
4 |
|
5 |
Summary: SME Server specific Jeta configuration and templates. |
6 |
%define name smeserver-jeta |
7 |
Name: %{name} |
8 |
%define version 1.1 |
9 |
%define release 1 |
10 |
Version: %{version} |
11 |
Release: %{release}%{?dist} |
12 |
License: GPL |
13 |
Group: Networking/Daemons |
14 |
Source: %{name}-%{version}.tar.gz |
15 |
#REM contribs9 Patch1: smeserver-jeta.remove_templates-custom.patch |
16 |
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
17 |
BuildArchitectures: noarch |
18 |
Requires: imp-h3 >= 4.0 |
19 |
Requires: e-smith-base >= 4.15.1 |
20 |
Requires: e-smith-apache >= 1.1.0-18 |
21 |
Requires: e-smith-lib >= 1.15.1-16 |
22 |
Requires: jeta-h3 >= 1.0 |
23 |
BuildRequires: e-smith-devtools >= 1.13.1-03 |
24 |
AutoReqProv: no |
25 |
|
26 |
%changelog |
27 |
* Mon Jun 16 2014 JP Pialasse <tests@pialasse.com> 1.1-1.sme |
28 |
- initial import to SME9 contribs |
29 |
|
30 |
* Sat Apr 19 2008 John H. Bennett III <bennettj@johnbennettservices.com> 1.0-2 |
31 |
- Patch to move jeta specific horde registry.php from templates-custom to templates. |
32 |
- Changed imp-h3 requires to require imp 4.2 or better so the template move doesn't |
33 |
break any previous versions. |
34 |
|
35 |
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
36 |
- Clean up spec so package can be built by koji/plague |
37 |
|
38 |
* Wed Apr 4 2007 John H. Bennett III <bennettj@johnbennettservices.com> 1.0-1 |
39 |
- Initial build |
40 |
- Added the ability to enable or disable jeta menu icon from showing up on the |
41 |
main webmail screen. To enable config set jeta service MenuArray disabled|enabled |
42 |
|
43 |
%description |
44 |
This package adds necessary templates and configuration items |
45 |
so that Jeta will work properly with SME Server |
46 |
|
47 |
%prep |
48 |
%setup |
49 |
|
50 |
#REM contribs9 %patch1 -p1 |
51 |
|
52 |
%build |
53 |
|
54 |
perl createlinks |
55 |
|
56 |
%install |
57 |
rm -rf $RPM_BUILD_ROOT |
58 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
59 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
60 |
echo "%doc COPYING" >> %{name}-%{version}-filelist |
61 |
|
62 |
%clean |
63 |
rm -rf $RPM_BUILD_ROOT |
64 |
|
65 |
%pre |
66 |
|
67 |
%preun |
68 |
|
69 |
%post |
70 |
|
71 |
%postun |
72 |
|
73 |
%files -f %{name}-%{version}-filelist |
74 |
%defattr(-,root,root) |