1 |
slords |
1.2 |
# $Id$ |
2 |
|
|
# Authority: dungog |
3 |
|
|
# Name: Stephen Noble |
4 |
|
|
|
5 |
slords |
1.1 |
Summary: smserver rpm to setup jinzora jukebox |
6 |
|
|
%define name smeserver-jinzora |
7 |
|
|
Name: %{name} |
8 |
|
|
%define version 0.9 |
9 |
|
|
%define release 7 |
10 |
|
|
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: GPL |
13 |
|
|
URL: http://www.dungog.net/sme |
14 |
|
|
Group: SMEserver/addon |
15 |
|
|
Source: %{name}-%{version}.tar.gz |
16 |
|
|
BuildArchitectures: noarch |
17 |
|
|
BuildRoot: /var/tmp/%{name}-%{version} |
18 |
|
|
Requires: e-smith-release >= 7.0 |
19 |
|
|
Requires: jinzora |
20 |
|
|
BuildRequires: e-smith-devtools |
21 |
|
|
AutoReqProv: no |
22 |
|
|
|
23 |
|
|
%description |
24 |
|
|
smserver rpm to setup jinzora jukebox |
25 |
|
|
|
26 |
|
|
%changelog |
27 |
|
|
* Fri Apr 6 2007 Stephen Noble <stephen@dungog.net> |
28 |
|
|
- revert mysql password creation |
29 |
|
|
- [0.9-7] |
30 |
|
|
|
31 |
|
|
* Sun Feb 4 2007 Stephen Noble <support@dungog.net> |
32 |
|
|
- remove phpinfo |
33 |
|
|
- simplify mysql password creation |
34 |
|
|
- don't alias / in httpd for nul values in URL |
35 |
|
|
- [0.9-6] |
36 |
|
|
|
37 |
|
|
* Mon Dec 11 2006 Stephen Noble <support@dungog.net> |
38 |
|
|
- rpm %post events reordered, to enable clean install |
39 |
|
|
- [0.9-5] |
40 |
|
|
|
41 |
|
|
* Thu Nov 9 2006 Stephen Noble <support@dungog.net> |
42 |
|
|
- http PublicAccess setting added |
43 |
|
|
- [0.9-4] |
44 |
|
|
|
45 |
|
|
* Tue May 2 2006 Stephen Noble <support@dungog.net> |
46 |
|
|
- :/tmp added to open_basedir |
47 |
|
|
- php settings in httpd increased |
48 |
|
|
- todo, still get timed out and error syncing to mpeg errors |
49 |
|
|
- possible cause of httpd slowing down requiring |
50 |
|
|
- /etc/rc.d/init.d/httpd-e-smith restart |
51 |
|
|
- [0.9-3] |
52 |
|
|
|
53 |
|
|
* Tue May 2 2006 Stephen Noble <support@dungog.net> |
54 |
|
|
- permissions script removed |
55 |
|
|
- actions moved to post from webapp-upgrade |
56 |
|
|
- [0.9-2] |
57 |
|
|
|
58 |
|
|
* Sun Apr 16 2006 Stephen Noble <support@dungog.net> |
59 |
|
|
- initial release |
60 |
|
|
- [0.9-1] |
61 |
|
|
|
62 |
|
|
%prep |
63 |
|
|
%setup |
64 |
|
|
|
65 |
|
|
%build |
66 |
|
|
perl createlinks |
67 |
|
|
mkdir -p root/etc/e-smith/db/accounts/defaults/jinzora |
68 |
|
|
echo "reserved" > root/etc/e-smith/db/accounts/defaults/jinzora/type |
69 |
|
|
|
70 |
|
|
mkdir -p root/etc/e-smith/db/configuration/defaults/jinzora |
71 |
|
|
echo "Jinzora Jukebox" > root/etc/e-smith/db/configuration/defaults/jinzora/Name |
72 |
|
|
echo "local" > root/etc/e-smith/db/configuration/defaults/jinzora/PublicAccess |
73 |
|
|
|
74 |
|
|
%install |
75 |
|
|
rm -rf $RPM_BUILD_ROOT |
76 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
77 |
|
|
rm -f %{name}-%{version}-filelist |
78 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
79 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
80 |
|
|
|
81 |
|
|
%clean |
82 |
|
|
cd .. |
83 |
|
|
rm -rf %{name}-%{version} |
84 |
|
|
|
85 |
|
|
%pre |
86 |
|
|
|
87 |
|
|
%preun |
88 |
|
|
|
89 |
|
|
%post |
90 |
|
|
/etc/e-smith/events/actions/initialize-default-databases |
91 |
|
|
/sbin/e-smith/expand-template /etc/e-smith/sql/init/80jinzora.sql |
92 |
|
|
/etc/rc.d/init.d/mysql.init start |
93 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
94 |
|
|
/usr/local/bin/svc -h /service/httpd-e-smith |
95 |
|
|
|
96 |
|
|
echo "" |
97 |
|
|
echo "see www.dungog.net/sme/webapp.php" |
98 |
|
|
echo "current settings 'config show jinzora'..." |
99 |
|
|
/sbin/e-smith/config show jinzora |
100 |
|
|
|
101 |
|
|
%postun |
102 |
|
|
#uninstall |
103 |
|
|
if [ $1 = 0 ] ; then |
104 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
105 |
|
|
/usr/local/bin/svc -h /service/httpd-e-smith |
106 |
|
|
fi |
107 |
|
|
|
108 |
|
|
%files -f %{name}-%{version}-filelist |
109 |
|
|
%defattr(-,root,root) |
110 |
|
|
|