/[smecontribs]/rpms/smeserver-lazy_admin_tools/contribs8/smeserver-lazy_admin_tools.spec
ViewVC logotype

Annotation of /rpms/smeserver-lazy_admin_tools/contribs8/smeserver-lazy_admin_tools.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.13 - (hide annotations) (download)
Wed Jun 26 23:02:43 2013 UTC (10 years, 11 months ago) by unnilennium
Branch: MAIN
Changes since 1.12: +15 -17 lines
* Wed Jun 26 2013  JP PIALASSE tests@pialasse.com  1.1.-1.sme
- fix manual [SME: 7702]

1 unnilennium 1.13 # $Id: smeserver-lazy_admin_tools.spec,v 1.12 2013/06/25 22:06:58 unnilennium Exp $
2 slords 1.1 # Authority: unnilennium
3     # Name: Jean-Philippe Pialasse
4    
5     Summary: Lazy Admin's Tools is a set of scripts to automate admin tasks
6     %define name smeserver-lazy_admin_tools
7 unnilennium 1.13 %define version 1.1
8     %define release 1%{?dist}
9 slords 1.1 Name: %{name}
10     Version: %{version}
11     Release: %{release}
12     Source: %{name}-%{version}.tgz
13     License: GPL
14     Group: Networking/Tools
15     BuildRoot: /var/tmp/%{name}-%{version}-buildroot
16     BuildArchitectures: noarch
17     Requires: e-smith-base
18     Requires: SMEServer >= 8.0
19     Obsoletes: e-smith-lazy_admin_tools
20 slords 1.2 BuildRequires: e-smith-devtools >= 1.13.1-03
21 slords 1.1
22     %description
23     The Lazy Administrator's Tools is a set of scripts designed to automate
24     batch tasks and jobs for E-Smith/SME servers.
25     * lat-user : add/delete users
26     * lat-group : add/delete groups
27     * lat pseudonyms : add/delete e-mail pseudonyms for individual users
28     * lat-ibays : add/delete ibays
29     * lat-quota : set the disk quota for individual users
30     * lat-domains : add domainnames the server
31     * lat-hosts : add hostnames to the server
32     * lat-procmail : activate or deactivate procmail for individual users
33     * lat-pptp : activate or deactivate pptp access for individual users
34     * lat-dump : create input files for the above lat-tools, based on the
35     configuration files of the SME servers.
36 unnilennium 1.6 * lat-shadow : add users' encrypted password in /etc/shadow file
37    
38 slords 1.1 See man lat-tools for general help on the usage of the toolkit, or run the
39     command with the --help switch to get specific help.
40    
41     %changelog
42 unnilennium 1.13 * Wed Jun 26 2013 JP PIALASSE tests@pialasse.com 1.1.-1.sme
43     - fix manual [SME: 7702]
44    
45 unnilennium 1.12 * Tue Jun 25 2013 JP PIALASSE tests@pialasse.com 1.0-9.sme
46 unnilennium 1.10 - updated patch4 and applied this time
47 unnilennium 1.11 - patch5 to correct lat-user -n option errors
48 unnilennium 1.12 - patch6 to update manual
49     - also to check for mailsorting contrib in procmail lat
50 unnilennium 1.10
51 unnilennium 1.8 * Mon Jun 24 2013 JP PIALASSE tests@pialasse.com 1.0-6.sme
52     - fixed Can't enable procmail [SME: 7139]
53     - fixed Error during creation of pptp access with lazy admin tools [SME: 7695]
54     - patch4
55 unnilennium 1.7 * Mon May 13 2013 JP PIALASSE tests@pialasse.com 1.0-5.sme
56     - fixed lat-procmail [SME: 7139]
57     - fixed removing user with home dir not in /home/e-smith/files/users/ [SME: 7162]
58     - create basic SME pseudonyms using option -n for nicknames [SME: 7284]
59     - patch3
60 unnilennium 1.6 * Sat Feb 02 2013 JP PIALASSE tests@pialasse.com 1.0-4.sme
61     - fixed empty Gid property creation on user update bug [SME: 7192]
62     - added lat-shadow binary [SME: 7137]
63     - patch1 and patch2
64 unnilennium 1.5 * Sat Feb 02 2013 JP PIALASSE tests@pialasse.com 1.0-3.sme
65     - fixed warning on empty group creation/update bug [SME: 7202]
66     - fixed uid changed on user update bug [SME: 7196]
67     - fixed warning on user creation/update bug [SME: 7192]
68 unnilennium 1.6 - patch0
69 unnilennium 1.3 * Sat Feb 02 2013 JP PIALASSE tests@pialasse.com 1.0-2.sme
70     - binary are not executable [SME: 7138]
71 slords 1.1 * Sat May 26 2012 JP PIALASSE tests@pialasse.com 1.0-1.sme
72     - Initial version
73    
74     %prep
75     %setup
76 unnilennium 1.13 #%patch0 -p1
77     #%patch1 -p1
78     #%patch2 -p1
79     #%patch3 -p1
80     #%patch4 -p1
81     #%patch5 -p1
82     #%patch6 -p1
83 slords 1.1
84     %build
85    
86 unnilennium 1.13 perl createman
87    
88 slords 1.1 %install
89     rm -rf $RPM_BUILD_ROOT
90     (cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
91     rm -f e-smith-%{version}-filelist
92 unnilennium 1.3 /sbin/e-smith/genfilelist $RPM_BUILD_ROOT \
93     --file '/usr/sbin/lat-domains' 'attr(755,root,root)' \
94     --file '/usr/sbin/lat-dump' 'attr(755,root,root)' \
95     --file /usr/sbin/lat-groups 'attr(755,root,root)' \
96     --file /usr/sbin/lat-hosts 'attr(755,root,root)' \
97     --file /usr/sbin/lat-ibays 'attr(755,root,root)' \
98     --file /usr/sbin/lat-pptp 'attr(755,root,root)' \
99     --file /usr/sbin/lat-procmail 'attr(755,root,root)' \
100     --file /usr/sbin/lat-pseudonyms 'attr(755,root,root)' \
101     --file /usr/sbin/lat-quota 'attr(755,root,root)' \
102     --file /usr/sbin/lat-restore 'attr(755,root,root)' \
103     --file /usr/sbin/lat-users 'attr(755,root,root)' \
104 unnilennium 1.6 --file /usr/sbin/lat-shadow 'attr(755,root,root)' \
105 unnilennium 1.3 > %{name}-%{version}-filelist
106    
107    
108 slords 1.1
109     %clean
110     rm -rf $RPM_BUILD_ROOT
111    
112     %files -f %{name}-%{version}-filelist
113     %defattr(-,root,root)
114    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed