1 |
unnilennium |
1.3 |
# $Id: smeserver-lazy_admin_tools.spec,v 1.2 2012/05/26 23:14:24 slords Exp $ |
2 |
slords |
1.1 |
# Authority: unnilennium |
3 |
|
|
# Name: Jean-Philippe Pialasse |
4 |
|
|
|
5 |
|
|
Summary: Lazy Admin's Tools is a set of scripts to automate admin tasks |
6 |
|
|
%define name smeserver-lazy_admin_tools |
7 |
|
|
%define version 1.0 |
8 |
|
|
%define release 1%{?dist} |
9 |
|
|
Name: %{name} |
10 |
|
|
Version: %{version} |
11 |
|
|
Release: %{release} |
12 |
|
|
Source: %{name}-%{version}.tgz |
13 |
|
|
License: GPL |
14 |
|
|
Group: Networking/Tools |
15 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-buildroot |
16 |
|
|
BuildArchitectures: noarch |
17 |
|
|
Requires: e-smith-base |
18 |
|
|
Requires: SMEServer >= 8.0 |
19 |
|
|
Obsoletes: e-smith-lazy_admin_tools |
20 |
slords |
1.2 |
BuildRequires: e-smith-devtools >= 1.13.1-03 |
21 |
slords |
1.1 |
|
22 |
|
|
%description |
23 |
|
|
The Lazy Administrator's Tools is a set of scripts designed to automate |
24 |
|
|
batch tasks and jobs for E-Smith/SME servers. |
25 |
|
|
* lat-user : add/delete users |
26 |
|
|
* lat-group : add/delete groups |
27 |
|
|
* lat pseudonyms : add/delete e-mail pseudonyms for individual users |
28 |
|
|
* lat-ibays : add/delete ibays |
29 |
|
|
* lat-quota : set the disk quota for individual users |
30 |
|
|
* lat-domains : add domainnames the server |
31 |
|
|
* lat-hosts : add hostnames to the server |
32 |
|
|
* lat-procmail : activate or deactivate procmail for individual users |
33 |
|
|
* lat-pptp : activate or deactivate pptp access for individual users |
34 |
|
|
* lat-dump : create input files for the above lat-tools, based on the |
35 |
|
|
configuration files of the SME servers. |
36 |
|
|
|
37 |
|
|
See man lat-tools for general help on the usage of the toolkit, or run the |
38 |
|
|
command with the --help switch to get specific help. |
39 |
|
|
|
40 |
|
|
%changelog |
41 |
unnilennium |
1.3 |
* Sat Feb 02 2013 JP PIALASSE tests@pialasse.com 1.0-2.sme |
42 |
|
|
- binary are not executable [SME: 7138] |
43 |
slords |
1.1 |
* Sat May 26 2012 JP PIALASSE tests@pialasse.com 1.0-1.sme |
44 |
|
|
- Initial version |
45 |
|
|
|
46 |
|
|
%prep |
47 |
|
|
%setup |
48 |
|
|
|
49 |
|
|
%build |
50 |
|
|
|
51 |
|
|
%install |
52 |
|
|
rm -rf $RPM_BUILD_ROOT |
53 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
54 |
|
|
rm -f e-smith-%{version}-filelist |
55 |
unnilennium |
1.3 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
56 |
|
|
--file '/usr/sbin/lat-domains' 'attr(755,root,root)' \ |
57 |
|
|
--file '/usr/sbin/lat-dump' 'attr(755,root,root)' \ |
58 |
|
|
--file /usr/sbin/lat-groups 'attr(755,root,root)' \ |
59 |
|
|
--file /usr/sbin/lat-hosts 'attr(755,root,root)' \ |
60 |
|
|
--file /usr/sbin/lat-ibays 'attr(755,root,root)' \ |
61 |
|
|
--file /usr/sbin/lat-pptp 'attr(755,root,root)' \ |
62 |
|
|
--file /usr/sbin/lat-procmail 'attr(755,root,root)' \ |
63 |
|
|
--file /usr/sbin/lat-pseudonyms 'attr(755,root,root)' \ |
64 |
|
|
--file /usr/sbin/lat-quota 'attr(755,root,root)' \ |
65 |
|
|
--file /usr/sbin/lat-restore 'attr(755,root,root)' \ |
66 |
|
|
--file /usr/sbin/lat-users 'attr(755,root,root)' \ |
67 |
|
|
> %{name}-%{version}-filelist |
68 |
|
|
|
69 |
|
|
|
70 |
slords |
1.1 |
|
71 |
|
|
%clean |
72 |
|
|
rm -rf $RPM_BUILD_ROOT |
73 |
|
|
|
74 |
|
|
%files -f %{name}-%{version}-filelist |
75 |
|
|
%defattr(-,root,root) |
76 |
|
|
|