1 |
unnilennium |
1.5 |
# $Id: smeserver-lazy_admin_tools.spec,v 1.4 2013/02/02 19:27:13 unnilennium Exp $ |
2 |
slords |
1.1 |
# Authority: unnilennium |
3 |
|
|
# Name: Jean-Philippe Pialasse |
4 |
|
|
|
5 |
|
|
Summary: Lazy Admin's Tools is a set of scripts to automate admin tasks |
6 |
|
|
%define name smeserver-lazy_admin_tools |
7 |
|
|
%define version 1.0 |
8 |
unnilennium |
1.5 |
%define release 3%{?dist} |
9 |
slords |
1.1 |
Name: %{name} |
10 |
|
|
Version: %{version} |
11 |
|
|
Release: %{release} |
12 |
|
|
Source: %{name}-%{version}.tgz |
13 |
|
|
License: GPL |
14 |
|
|
Group: Networking/Tools |
15 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-buildroot |
16 |
|
|
BuildArchitectures: noarch |
17 |
|
|
Requires: e-smith-base |
18 |
|
|
Requires: SMEServer >= 8.0 |
19 |
|
|
Obsoletes: e-smith-lazy_admin_tools |
20 |
slords |
1.2 |
BuildRequires: e-smith-devtools >= 1.13.1-03 |
21 |
unnilennium |
1.5 |
Patch0: smeserver-lazy_admin_tools-1.0-patch0.patch |
22 |
slords |
1.1 |
|
23 |
unnilennium |
1.5 |
|
24 |
slords |
1.1 |
%description |
25 |
|
|
The Lazy Administrator's Tools is a set of scripts designed to automate |
26 |
|
|
batch tasks and jobs for E-Smith/SME servers. |
27 |
|
|
* lat-user : add/delete users |
28 |
|
|
* lat-group : add/delete groups |
29 |
|
|
* lat pseudonyms : add/delete e-mail pseudonyms for individual users |
30 |
|
|
* lat-ibays : add/delete ibays |
31 |
|
|
* lat-quota : set the disk quota for individual users |
32 |
|
|
* lat-domains : add domainnames the server |
33 |
|
|
* lat-hosts : add hostnames to the server |
34 |
|
|
* lat-procmail : activate or deactivate procmail for individual users |
35 |
|
|
* lat-pptp : activate or deactivate pptp access for individual users |
36 |
|
|
* lat-dump : create input files for the above lat-tools, based on the |
37 |
|
|
configuration files of the SME servers. |
38 |
|
|
|
39 |
|
|
See man lat-tools for general help on the usage of the toolkit, or run the |
40 |
|
|
command with the --help switch to get specific help. |
41 |
|
|
|
42 |
|
|
%changelog |
43 |
unnilennium |
1.5 |
* Sat Feb 02 2013 JP PIALASSE tests@pialasse.com 1.0-3.sme |
44 |
|
|
- fixed warning on empty group creation/update bug [SME: 7202] |
45 |
|
|
- fixed uid changed on user update bug [SME: 7196] |
46 |
|
|
- fixed warning on user creation/update bug [SME: 7192] |
47 |
unnilennium |
1.3 |
* Sat Feb 02 2013 JP PIALASSE tests@pialasse.com 1.0-2.sme |
48 |
|
|
- binary are not executable [SME: 7138] |
49 |
slords |
1.1 |
* Sat May 26 2012 JP PIALASSE tests@pialasse.com 1.0-1.sme |
50 |
|
|
- Initial version |
51 |
|
|
|
52 |
|
|
%prep |
53 |
|
|
%setup |
54 |
unnilennium |
1.5 |
%patch0 -p1 |
55 |
slords |
1.1 |
|
56 |
|
|
%build |
57 |
|
|
|
58 |
|
|
%install |
59 |
|
|
rm -rf $RPM_BUILD_ROOT |
60 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
61 |
|
|
rm -f e-smith-%{version}-filelist |
62 |
unnilennium |
1.3 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
63 |
|
|
--file '/usr/sbin/lat-domains' 'attr(755,root,root)' \ |
64 |
|
|
--file '/usr/sbin/lat-dump' 'attr(755,root,root)' \ |
65 |
|
|
--file /usr/sbin/lat-groups 'attr(755,root,root)' \ |
66 |
|
|
--file /usr/sbin/lat-hosts 'attr(755,root,root)' \ |
67 |
|
|
--file /usr/sbin/lat-ibays 'attr(755,root,root)' \ |
68 |
|
|
--file /usr/sbin/lat-pptp 'attr(755,root,root)' \ |
69 |
|
|
--file /usr/sbin/lat-procmail 'attr(755,root,root)' \ |
70 |
|
|
--file /usr/sbin/lat-pseudonyms 'attr(755,root,root)' \ |
71 |
|
|
--file /usr/sbin/lat-quota 'attr(755,root,root)' \ |
72 |
|
|
--file /usr/sbin/lat-restore 'attr(755,root,root)' \ |
73 |
|
|
--file /usr/sbin/lat-users 'attr(755,root,root)' \ |
74 |
|
|
> %{name}-%{version}-filelist |
75 |
|
|
|
76 |
|
|
|
77 |
slords |
1.1 |
|
78 |
|
|
%clean |
79 |
|
|
rm -rf $RPM_BUILD_ROOT |
80 |
|
|
|
81 |
|
|
%files -f %{name}-%{version}-filelist |
82 |
|
|
%defattr(-,root,root) |
83 |
|
|
|