/[smecontribs]/rpms/smeserver-learn/contribs8/smeserver-learn.spec
ViewVC logotype

Annotation of /rpms/smeserver-learn/contribs8/smeserver-learn.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.10 - (hide annotations) (download)
Wed Mar 16 15:34:06 2016 UTC (8 years, 2 months ago) by unnilennium
Branch: MAIN
Changes since 1.9: +5 -2 lines
* Wed Mar 16 2016 JP Pialasse <tests@pialasse.com> 1.0-10.sme
- fix encoding problem when removing or adding tags [SME: 9282]
- fix moving file not working MOVE patch [SME: 9314]

1 unnilennium 1.1 # $Id: smeserver-learn.spec,v 1.0 2016/03/07 13:40:22 unnilennium Exp $
2     # Authority: unnilennium
3     # Name: Jean-Philippe Pialasse.
4     %define name smeserver-learn
5     %define version 1.0
6 unnilennium 1.10 %define release 10
7 unnilennium 1.1
8     Summary: SME Server Mails Learning script
9     Name: %{name}
10     Version: %{version}
11     Release: %{release}%{?dist}
12     License: GPL
13     Group: Networking/Daemons
14     Source: %{name}-%{version}.tar.gz
15 unnilennium 1.3 Patch0: smeserver-learn-1.0-event.patch
16 unnilennium 1.4 Patch1: smeserver-learn-1.0-SME9283.patch
17 unnilennium 1.7 Patch2: smeserver-learn-1.0-SME9284.patch
18     Patch3: smeserver-learn-1.0-SME6862.patch
19 unnilennium 1.8 Patch4: smeserver-learn-1.0-admin.patch
20 unnilennium 1.9 Patch5: smeserver-learn-1.0-SME9282.patch
21 unnilennium 1.10 Patch6: smeserver-learn-1.0-MOVE.patch
22 unnilennium 1.1 Packager: JP Pialasse <tests@pialasse.com>
23     BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot
24     BuildArchitectures: noarch
25     Requires: perl-Email-Simple
26 unnilennium 1.2 BuildRequires: e-smith-devtools >= 1.13.1-03
27 unnilennium 1.1
28     %description
29     Scripts which allows users to interact with spamassassin rules simply
30     by droping mail in special folders of their mailbox (working only with imap)
31     - Learn mail as spam
32     - Learn mail as ham
33     - Whitelist the sender so his mails won't be taged as spam again
34    
35     %changelog
36 unnilennium 1.10 * Wed Mar 16 2016 JP Pialasse <tests@pialasse.com> 1.0-10.sme
37 unnilennium 1.9 - fix encoding problem when removing or adding tags [SME: 9282]
38 unnilennium 1.10 - fix moving file not working MOVE patch [SME: 9314]
39 unnilennium 1.9
40 unnilennium 1.8 * Tue Mar 15 2016 JP Pialasse <tests@pialasse.com> 1.0-8.sme
41     - NFR: check admin Maildir [SME: 9279]
42     - NFR: restrict utilization to some users [SME: 9280]
43    
44 unnilennium 1.7 * Wed Mar 09 2016 JP Pialasse <tests@pialasse.com> 1.0-7.sme
45     - fix find not restrictive enough when learning also new [SME: 6862]
46    
47 unnilennium 1.6 * Tue Mar 08 2016 JP Pialasse <tests@pialasse.com> 1.0-6.sme
48 unnilennium 1.1 - new version SME8 and SME9
49     - fix wrong default db key DeleteAfterLearn [SME: 7083]
50     - added inspection of temp and new subdir [SME: 6862]
51     - moved default db keys as file outside of spec
52     - new db properties: (LearnAsHam,LearnInWL)RemoveSPAMTag, (*)LeanNew,(*)Uniq,(LearnAsSpam)SpamLinks
53     - new account db property for user: SpamLinks
54     - import to buildsys [SME: 4423]
55     - use sa-learn per dir and not per message [SME: 1701]
56     - merge enhancements [SME: 4423] [SME: 1701]
57     - NFR: create links
58     - NFR: filter out SPAM tag from HAM and InWL mails
59     - NFR: added auto create folders if multiple folder disabled
60     - NFR: create db key for multiple folder to inspect
61     - enhanced move to junkmail or inbox
62     - moving job from crontab to /etc/cron.d/Learn
63 unnilennium 1.4 - fixed typo in event email-update (r3)
64     - fixed wrong file permission on /etc/cron.d/Lean [SME: 9283] (r4)
65 unnilennium 1.5 - fixed messy output [SME: 9284] (r5)
66 unnilennium 1.6 - fixed replaced cron file on update [SME: 9286](r6)
67 unnilennium 1.1
68     * Wed Jun 25 2008 Emmmanuel JOORIS <joorise@dot-world.net> 0.0.1-3
69     - add dependencies to spec file
70    
71     * Mon Jun 23 2008 Daniel B. <daniel@firewall-services.com> 0.0.1-2
72     - add spaces after the tags
73    
74     * Wed Jun 18 2008 Daniel B. <daniel@firewall-services.com> 0.0.1-1
75     - full path for Learn script in crontab templates
76     - rename to smeserver-learn
77     - Fix default tag for Ham mail to [HAM]
78     - Lean.pl will be executed daily by default
79    
80     * Wed Jun 11 2008 Emmanuel JOORIS <joorise@dot-world.net>
81     - 0.0.1-0
82     - Original version
83    
84     %prep
85     %setup
86 unnilennium 1.3 %patch0 -p1
87 unnilennium 1.4 %patch1 -p1
88 unnilennium 1.5 %patch2 -p1
89 unnilennium 1.7 %patch3 -p1
90 unnilennium 1.8 %patch4 -p1
91 unnilennium 1.9 %patch5 -p1
92 unnilennium 1.10 %patch6 -p1
93 unnilennium 1.1
94     %build
95     perl createlinks
96    
97     %install
98     rm -rf $RPM_BUILD_ROOT
99     (cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
100     rm -f %{name}-%{version}-filelist
101 unnilennium 1.6 /sbin/e-smith/genfilelist $RPM_BUILD_ROOT |\
102     sed -e "s@^$RPM_BUILD_ROOT@@g" \
103     -e "s@^%attr(0644,root,root) /etc/cron.d/Learn@%attr(0644,root,root)%config(noreplace) /etc/cron.d/Learn@"\
104     > %{name}-%{version}-filelist
105 unnilennium 1.1
106     %clean
107 unnilennium 1.6 #rm -rf $RPM_BUILD_ROOT
108 unnilennium 1.1
109     %post
110    
111     %postun
112    
113     %files -f %{name}-%{version}-filelist
114     %defattr(-,root,root)
115    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed