1 |
slords |
1.1 |
Summary: Lets users configure procmail or maildrop rules. |
2 |
|
|
%define name smeserver-mailsorting |
3 |
|
|
Name: %{name} |
4 |
|
|
%define version 1.2 |
5 |
|
|
%define release 5 |
6 |
|
|
Version: %{version} |
7 |
slords |
1.3 |
Release: %{release}%{?dist} |
8 |
slords |
1.2 |
License: GPL |
9 |
slords |
1.1 |
URL: http://www.dungog.net/sme |
10 |
|
|
Group: SMEserver/addon |
11 |
|
|
Source: %{name}-%{version}.tar.gz |
12 |
|
|
BuildArchitectures: noarch |
13 |
|
|
BuildRoot: /var/tmp/%{name}-%{version} |
14 |
|
|
Requires: e-smith-release >= 7.0, |
15 |
|
|
#Requires: smeserver-userpanel |
16 |
|
|
Requires: perl-Unicode-IMAPUtf7 |
17 |
slords |
1.5 |
BuildRequires: e-smith-devtools |
18 |
slords |
1.1 |
AutoReqProv: no |
19 |
|
|
|
20 |
|
|
%description |
21 |
|
|
SME Server enhancement to enable procmail or maildrop filtering for users. |
22 |
|
|
Optionally provides user panels where users can create mail rules for themselves |
23 |
|
|
|
24 |
|
|
%changelog |
25 |
|
|
* Sat Mar 17 2007 Stephen Noble <stephen@dungog.net> |
26 |
|
|
- retry mail in .qmail [sme 2733] |
27 |
|
|
- [1.2-5] |
28 |
|
|
|
29 |
|
|
* Wed Feb 28 2007 Stephen Noble <stephen@dungog.net> |
30 |
|
|
- remove Requires: smeserver-userpanel |
31 |
|
|
- [1.2-4] |
32 |
|
|
|
33 |
|
|
* Tue Jan 9 2007 Stephen Noble <support@dungog.net> |
34 |
|
|
- remove .* after TO_ macro [sme 2264] |
35 |
|
|
- Existing mail folders search improved [sme 2265] |
36 |
|
|
- [1.2-3] |
37 |
|
|
|
38 |
|
|
* Mon Oct 30 2006 Stephen Noble <support@dungog.net> |
39 |
|
|
- improved german support, thanks Dietmar |
40 |
|
|
- Unicode-IMAPUtf7 support [sme 1446] |
41 |
|
|
- [1.2-2] |
42 |
|
|
|
43 |
|
|
* Sat Oct 21 2006 Stephen Noble <support@dungog.net> |
44 |
|
|
- FormMagick version |
45 |
|
|
- [1.2-1] |
46 |
|
|
|
47 |
|
|
* Thu Aug 24 2006 Stephen Noble <support@dungog.net> |
48 |
|
|
- remove strict check on mailrule criterion [sme 1643] |
49 |
|
|
- fix log rotation |
50 |
|
|
- maildrop matching improved, [sme 1642] |
51 |
|
|
- allow for spaces in folder names for maildrop [sme 1640] |
52 |
|
|
- [0.9-6] |
53 |
|
|
|
54 |
|
|
* Sat May 6 2006 Stephen Noble <support@dungog.net> |
55 |
|
|
- default shell for maildrop set to /bin/bash |
56 |
|
|
- [contribs 1378] thanks mweinber neddix.de |
57 |
|
|
- [0.9-5] |
58 |
|
|
|
59 |
|
|
* Wed Apr 6 2006 Stephen Noble <support@dungog.net> |
60 |
|
|
- delete duplicates |
61 |
|
|
- globally enabled for procmail, works ok |
62 |
|
|
- per user for maildrop, worked ok for user A, but started deleting mail for user B |
63 |
|
|
- [0.9-4] |
64 |
|
|
|
65 |
|
|
* Thu Mar 9 2006 Stephen Noble <support@dungog.net> |
66 |
|
|
- remove preun actions |
67 |
|
|
- [0.9-3] |
68 |
|
|
|
69 |
|
|
* Thu Mar 9 2006 Stephen Noble <support@dungog.net> |
70 |
|
|
- Requires: smeserver-userpanel |
71 |
|
|
- bypass admin's .qmail |
72 |
|
|
- [0.9-2] |
73 |
|
|
|
74 |
|
|
* Sun Sep 25 2005 Stephen Noble <support@dungog.net> |
75 |
|
|
- initial release |
76 |
|
|
- [0.9-1] |
77 |
|
|
|
78 |
|
|
%prep |
79 |
|
|
%setup |
80 |
|
|
|
81 |
|
|
%build |
82 |
|
|
perl createlinks |
83 |
|
|
|
84 |
|
|
LEXICONS1=$(find root/etc/e-smith/locale/ -type f ) |
85 |
|
|
LEXICONS2=$(find root/etc/e-smith/web/functions/ -type f ) |
86 |
|
|
for lexicon in $LEXICONS1 $LEXICONS2 |
87 |
|
|
do |
88 |
|
|
/sbin/e-smith/validate-lexicon $lexicon |
89 |
|
|
done |
90 |
|
|
|
91 |
|
|
%install |
92 |
|
|
rm -rf $RPM_BUILD_ROOT |
93 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
94 |
|
|
rm -f %{name}-%{version}-filelist |
95 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
96 |
|
|
--file '/etc/cron.weekly/mailsorting' 'attr(0755,root,root)' \ |
97 |
|
|
> %{name}-%{version}-filelist |
98 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
99 |
|
|
|
100 |
|
|
%clean |
101 |
|
|
cd .. |
102 |
|
|
rm -rf %{name}-%{version} |
103 |
|
|
|
104 |
|
|
%pre |
105 |
|
|
%preun |
106 |
|
|
|
107 |
|
|
%post |
108 |
|
|
#new installs |
109 |
|
|
if [ $1 = 1 ] ; then |
110 |
|
|
/bin/touch /home/e-smith/db/processmail |
111 |
|
|
|
112 |
|
|
echo ' ' |
113 |
|
|
echo 'to enable for all users' |
114 |
|
|
echo 'for Procmail' |
115 |
|
|
echo "config setprop qmail FilterType procmail" |
116 |
|
|
echo 'or for maildrop' |
117 |
|
|
echo "config setprop qmail FilterType maildrop" |
118 |
|
|
echo 'then' |
119 |
|
|
echo 'signal-event mailsorting-conf' |
120 |
|
|
echo ' ' |
121 |
|
|
|
122 |
|
|
fi |
123 |
|
|
|
124 |
|
|
#upgrades (and new installs) |
125 |
|
|
/etc/e-smith/events/actions/navigation-conf 2>/dev/null |
126 |
|
|
/sbin/e-smith/signal-event mailsorting-conf |
127 |
|
|
|
128 |
|
|
#if [ -d /etc/e-smith/events/conf-userpanel ] ; then |
129 |
|
|
# /sbin/e-smith/signal-event conf-userpanel |
130 |
|
|
#fi |
131 |
|
|
|
132 |
|
|
%postun |
133 |
|
|
#uninstall |
134 |
|
|
if [ $1 = 0 ] ; then |
135 |
|
|
|
136 |
|
|
DBS=`find /home/e-smith/db/navigation -type f -name "navigation.*"` |
137 |
|
|
for db in $DBS ; do |
138 |
|
|
/sbin/e-smith/db $db delete userpanel-mailsort 2>/dev/null |
139 |
|
|
done |
140 |
|
|
|
141 |
|
|
echo '' |
142 |
|
|
echo 'to disable procmail or maildrop' |
143 |
|
|
echo 'config delprop qmail FilterType' |
144 |
|
|
echo 'signal-event email-update' |
145 |
|
|
echo '' |
146 |
|
|
|
147 |
|
|
fi |
148 |
|
|
|
149 |
|
|
%files -f %{name}-%{version}-filelist |
150 |
|
|
%defattr(-,root,root) |