1 |
brianr |
1.1 |
%define version 1.0 |
2 |
jcrisp |
1.10 |
%define release 9 |
3 |
brianr |
1.1 |
Summary: Set up a migration helper script for SME Server. |
4 |
|
|
Name: smeserver-migratehelper |
5 |
|
|
Version: %{version} |
6 |
|
|
Release: %{release}%{?dist} |
7 |
|
|
License: GNU GPL version 2 |
8 |
|
|
URL: http://www.contribs.org |
9 |
|
|
Group: SMEserver/addon |
10 |
jpp |
1.2 |
#Source: %{name}-%{version}.tar.gz |
11 |
|
|
Source: migratehelper.sh |
12 |
brianr |
1.1 |
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
13 |
|
|
BuildArchitectures: noarch |
14 |
|
|
BuildRequires: e-smith-devtools >= 1.13.1-03 |
15 |
|
|
Requires: e-smith-release >= 8.0 |
16 |
|
|
AutoReqProv: no |
17 |
|
|
|
18 |
|
|
%description |
19 |
jpp |
1.2 |
rpm backup all contribs data and bare essential to have a working system and then rsync data while the new system is up |
20 |
brianr |
1.1 |
|
21 |
|
|
%changelog |
22 |
jcrisp |
1.10 |
* Sun Nov 14 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 1.0-9.sme |
23 |
|
|
- Fix JPs typo |
24 |
|
|
|
25 |
jcrisp |
1.9 |
* Sun Nov 14 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 1.0-8.sme |
26 |
|
|
- fix mangled fail2ban conf backup lines |
27 |
|
|
|
28 |
jcrisp |
1.8 |
* Sun Nov 14 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 1.0-7.sme |
29 |
|
|
- remove debug line left by mistake |
30 |
|
|
|
31 |
jcrisp |
1.7 |
* Fri Oct 29 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 1.0-6.sme |
32 |
|
|
- add check/create for a /mnt/backup dir |
33 |
|
|
- Fix typos |
34 |
|
|
- Fix bash syntax errors via the IDE plugin |
35 |
|
|
- Add some switches for help, test, no confirm |
36 |
|
|
|
37 |
jpp |
1.6 |
* Thu Oct 21 2021 Jean-Philippe Pialasse <tests@pialasse.com> 1.0-5.sme |
38 |
|
|
- fix missing samba domain user [SME: 11706] |
39 |
|
|
- fix missing user cron jobs [SME: 11664] |
40 |
|
|
|
41 |
jpp |
1.5 |
* Tue Jun 01 2021 Jean-Philippe Pialasse <tests@pialasse.com> 1.0-4.sme |
42 |
|
|
- fix fail2ban listing [SME: 11576] |
43 |
|
|
|
44 |
jpp |
1.4 |
* Sun Apr 25 2021 Jean-Philippe Pialasse <tests@pialasse.com> 1.0-3.sme |
45 |
|
|
- reduce noise for tar [SME: 11576] |
46 |
|
|
|
47 |
jpp |
1.3 |
* Thu Apr 01 2021 Jean-Philippe Pialasse <tests@pialasse.com> 1.0-2.sme |
48 |
|
|
- add backup of spamassassin admin config |
49 |
|
|
- add search for non rpm owned folder in /usr/local |
50 |
|
|
|
51 |
brianr |
1.1 |
* Sat Jan 05 2019 Jean-Philipe Pialasse <tests@pialasse.com> 1.0-1.sme |
52 |
jpp |
1.2 |
- initial release [SME: 11275] |
53 |
|
|
- TODO use SME 10 includes / excludes |
54 |
brianr |
1.1 |
|
55 |
|
|
%prep |
56 |
jpp |
1.2 |
#%setup |
57 |
|
|
pwd >&2 |
58 |
|
|
ls >&2 |
59 |
|
|
mkdir -p %{name}-%{version}-%{release}/root/usr/bin |
60 |
|
|
cp %{SOURCE0} %{name}-%{version}-%{release}/root/usr/bin |
61 |
|
|
cd %{name}-%{version}-%{release} |
62 |
brianr |
1.1 |
|
63 |
|
|
%build |
64 |
jpp |
1.2 |
#perl createlinks |
65 |
brianr |
1.1 |
|
66 |
|
|
%install |
67 |
jpp |
1.2 |
|
68 |
brianr |
1.1 |
rm -rf $RPM_BUILD_ROOT |
69 |
jpp |
1.2 |
(cd %{name}-%{version}-%{release}/root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
70 |
brianr |
1.1 |
rm -f %{name}-%{version}-filelist |
71 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
72 |
|
|
> %{name}-%{version}-filelist |
73 |
|
|
|
74 |
|
|
%clean |
75 |
|
|
rm -rf $RPM_BUILD_ROOT |
76 |
|
|
|
77 |
|
|
%post |
78 |
|
|
|
79 |
|
|
%postun |
80 |
|
|
|
81 |
|
|
%files -f %{name}-%{version}-filelist |
82 |
|
|
%defattr(-,root,root) |