1 |
%define version 1.0 |
2 |
%define release 10 |
3 |
Summary: Set up a migration helper script for SME Server. |
4 |
Name: smeserver-migratehelper |
5 |
Version: %{version} |
6 |
Release: %{release}%{?dist} |
7 |
License: GNU GPL version 2 |
8 |
URL: http://www.contribs.org |
9 |
Group: SMEserver/addon |
10 |
#Source: %{name}-%{version}.tar.gz |
11 |
Source: migratehelper.sh |
12 |
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
13 |
BuildArchitectures: noarch |
14 |
BuildRequires: e-smith-devtools >= 1.13.1-03 |
15 |
Requires: e-smith-release >= 8.0 |
16 |
AutoReqProv: no |
17 |
|
18 |
%description |
19 |
rpm backup all contribs data and bare essential to have a working system and then rsync data while the new system is up |
20 |
|
21 |
%changelog |
22 |
* Thu Dec 02 2021 Jean-Philippe Pialasse <tests@pialasse.com> 1.0-10.sme |
23 |
- remove non existing standard path /home/e-smith/home |
24 |
|
25 |
* Sun Nov 14 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 1.0-9.sme |
26 |
- Fix JPs typo |
27 |
|
28 |
* Sun Nov 14 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 1.0-8.sme |
29 |
- fix mangled fail2ban conf backup lines |
30 |
|
31 |
* Sun Nov 14 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 1.0-7.sme |
32 |
- remove debug line left by mistake |
33 |
|
34 |
* Fri Oct 29 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 1.0-6.sme |
35 |
- add check/create for a /mnt/backup dir |
36 |
- Fix typos |
37 |
- Fix bash syntax errors via the IDE plugin |
38 |
- Add some switches for help, test, no confirm |
39 |
|
40 |
* Thu Oct 21 2021 Jean-Philippe Pialasse <tests@pialasse.com> 1.0-5.sme |
41 |
- fix missing samba domain user [SME: 11706] |
42 |
- fix missing user cron jobs [SME: 11664] |
43 |
|
44 |
* Tue Jun 01 2021 Jean-Philippe Pialasse <tests@pialasse.com> 1.0-4.sme |
45 |
- fix fail2ban listing [SME: 11576] |
46 |
|
47 |
* Sun Apr 25 2021 Jean-Philippe Pialasse <tests@pialasse.com> 1.0-3.sme |
48 |
- reduce noise for tar [SME: 11576] |
49 |
|
50 |
* Thu Apr 01 2021 Jean-Philippe Pialasse <tests@pialasse.com> 1.0-2.sme |
51 |
- add backup of spamassassin admin config |
52 |
- add search for non rpm owned folder in /usr/local |
53 |
|
54 |
* Sat Jan 05 2019 Jean-Philipe Pialasse <tests@pialasse.com> 1.0-1.sme |
55 |
- initial release [SME: 11275] |
56 |
- TODO use SME 10 includes / excludes |
57 |
|
58 |
%prep |
59 |
#%setup |
60 |
pwd >&2 |
61 |
ls >&2 |
62 |
mkdir -p %{name}-%{version}-%{release}/root/usr/bin |
63 |
cp %{SOURCE0} %{name}-%{version}-%{release}/root/usr/bin |
64 |
cd %{name}-%{version}-%{release} |
65 |
|
66 |
%build |
67 |
#perl createlinks |
68 |
|
69 |
%install |
70 |
|
71 |
rm -rf $RPM_BUILD_ROOT |
72 |
(cd %{name}-%{version}-%{release}/root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
73 |
rm -f %{name}-%{version}-filelist |
74 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
75 |
> %{name}-%{version}-filelist |
76 |
|
77 |
%clean |
78 |
rm -rf $RPM_BUILD_ROOT |
79 |
|
80 |
%post |
81 |
|
82 |
%postun |
83 |
|
84 |
%files -f %{name}-%{version}-filelist |
85 |
%defattr(-,root,root) |