1 |
jpp |
1.4 |
# $Id: smeserver-mod_python.spec,v 1.3 2021/04/02 21:43:16 jpp Exp $ |
2 |
brianr |
1.1 |
# Authority: marcohess |
3 |
|
|
# Name: Marco Hess |
4 |
|
|
|
5 |
|
|
%define name smeserver-mod_python |
6 |
|
|
%define version 0.3 |
7 |
jpp |
1.3 |
%define release 5 |
8 |
brianr |
1.1 |
|
9 |
|
|
Summary: SME Server mod_python implementation |
10 |
|
|
Name: %{name} |
11 |
|
|
Version: %{version} |
12 |
|
|
Release: %{release}%{?dist} |
13 |
|
|
License: GPL |
14 |
|
|
Group: Applications/Internet |
15 |
|
|
Source: %{name}-%{version}.tar.gz |
16 |
jpp |
1.3 |
Patch0: smeserver-mod_python-0.3-bz11273.patch |
17 |
|
|
|
18 |
brianr |
1.1 |
BuildArch: noarch |
19 |
|
|
BuildRequires: e-smith-devtools |
20 |
|
|
Requires: smeserver-release >= 9 |
21 |
|
|
Requires: httpd >= 2 |
22 |
|
|
Requires: mod_python |
23 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
24 |
|
|
|
25 |
|
|
%description |
26 |
|
|
Implementation of mod_python for SME Server 9. |
27 |
|
|
|
28 |
|
|
%changelog |
29 |
jpp |
1.3 |
* Fri Apr 02 2021 Jean-Philippe Pialasse <tests@pialasse.com> 0.3-5.sme |
30 |
|
|
- add update event [SME: 11273] |
31 |
|
|
|
32 |
brianr |
1.2 |
* Sat Dec 19 2020 Brian Read <brianr@bjsystems.co.uk> 0.3-4.sme |
33 |
|
|
- Initial import into SME10 tree [SME: 11273] |
34 |
|
|
|
35 |
brianr |
1.1 |
* Wed Sep 23 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 0.3-3.sme |
36 |
|
|
- Initial release to contribs9 |
37 |
|
|
|
38 |
|
|
* Sat Jun 01 2013 JP Pialasse <tests@pialasse.com} 0.1-2.sme |
39 |
|
|
- import to sme8 |
40 |
|
|
|
41 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
42 |
|
|
- Clean up spec so package can be built by koji/plague |
43 |
|
|
|
44 |
|
|
* Mon Mar 26 2007 Marco Hess <marco.hess@through-ip.com> |
45 |
|
|
- 0.1-0 |
46 |
|
|
- Original version adopted from smeserver-mod_dav |
47 |
|
|
|
48 |
|
|
%prep |
49 |
|
|
%setup |
50 |
jpp |
1.3 |
%patch0 -p1 |
51 |
brianr |
1.1 |
|
52 |
|
|
%build |
53 |
jpp |
1.3 |
perl createlinks |
54 |
brianr |
1.1 |
DEFAULTS=root/etc/e-smith/db/configuration/defaults/modPython |
55 |
|
|
mkdir -p $DEFAULTS |
56 |
|
|
echo "service" > $DEFAULTS/type |
57 |
|
|
echo "enabled" > $DEFAULTS/status |
58 |
|
|
|
59 |
|
|
%install |
60 |
|
|
rm -rf $RPM_BUILD_ROOT |
61 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
62 |
|
|
rm -f %{name}-%{version}-filelist |
63 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
64 |
|
|
|
65 |
|
|
%clean |
66 |
|
|
rm -rf $RPM_BUILD_ROOT |
67 |
|
|
|
68 |
|
|
%post |
69 |
|
|
|
70 |
|
|
%postun |
71 |
|
|
|
72 |
|
|
%files -f %{name}-%{version}-filelist |
73 |
|
|
%defattr(-,root,root) |