1 |
slords |
1.4 |
# $Id: smeserver-mod_python.spec,v 1.3 2008/04/02 15:03:58 slords Exp $ |
2 |
slords |
1.3 |
# Authority: marcohess |
3 |
|
|
# Name: Marco Hess |
4 |
|
|
|
5 |
slords |
1.1 |
%define name smeserver-mod_python |
6 |
|
|
%define version 0.1 |
7 |
slords |
1.2 |
%define release 1 |
8 |
slords |
1.1 |
|
9 |
|
|
Summary: SME Server mod_python implementation |
10 |
|
|
Name: %{name} |
11 |
|
|
Version: %{version} |
12 |
|
|
Release: %{release}%{?dist} |
13 |
|
|
License: GPL |
14 |
|
|
Group: Applications/Internet |
15 |
|
|
Source: %{name}-%{version}.tgz |
16 |
|
|
BuildArch: noarch |
17 |
|
|
BuildRequires: e-smith-devtools |
18 |
|
|
Requires: smeserver-release >= 7 |
19 |
|
|
Requires: httpd >= 2 |
20 |
|
|
Requires: mod_python |
21 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
22 |
|
|
|
23 |
|
|
%description |
24 |
|
|
Implementation of mod_python for SME Server 7. |
25 |
|
|
|
26 |
|
|
%changelog |
27 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
28 |
|
|
- Clean up spec so package can be built by koji/plague |
29 |
|
|
|
30 |
|
|
* Mon Mar 26 2007 Marco Hess <marco.hess@through-ip.com> |
31 |
|
|
- 0.1-0 |
32 |
|
|
- Original version adopted from smeserver-mod_dav |
33 |
|
|
|
34 |
|
|
%prep |
35 |
|
|
|
36 |
|
|
%setup |
37 |
|
|
|
38 |
|
|
%build |
39 |
|
|
DEFAULTS=root/etc/e-smith/db/configuration/defaults/modPython |
40 |
|
|
mkdir -p $DEFAULTS |
41 |
|
|
echo "service" > $DEFAULTS/type |
42 |
|
|
echo "enabled" > $DEFAULTS/status |
43 |
|
|
|
44 |
|
|
%install |
45 |
|
|
rm -rf $RPM_BUILD_ROOT |
46 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
47 |
|
|
rm -f %{name}-%{version}-filelist |
48 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
49 |
|
|
|
50 |
|
|
%clean |
51 |
|
|
rm -rf $RPM_BUILD_ROOT |
52 |
|
|
|
53 |
|
|
%post |
54 |
|
|
/etc/e-smith/events/actions/initialize-default-databases |
55 |
|
|
/etc/e-smith/events/actions/navigation-conf |
56 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
57 |
|
|
/etc/rc7.d/S86httpd-e-smith sigusr1 |
58 |
|
|
|
59 |
|
|
%postun |
60 |
|
|
/sbin/e-smith/db configuration delete modPython |
61 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
62 |
|
|
/etc/e-smith/events/actions/navigation-conf |
63 |
|
|
/etc/rc7.d/S86httpd-e-smith sigusr1 |
64 |
|
|
|
65 |
|
|
%files -f %{name}-%{version}-filelist |
66 |
|
|
%defattr(-,root,root) |