1 |
# $Id: smeserver-mod_python.spec,v 1.6 2013/06/01 13:04:24 unnilennium Exp $ |
2 |
# Authority: marcohess |
3 |
# Name: Marco Hess |
4 |
|
5 |
%define name smeserver-mod_python |
6 |
%define version 0.1 |
7 |
%define release 2 |
8 |
|
9 |
Summary: SME Server mod_python implementation |
10 |
Name: %{name} |
11 |
Version: %{version} |
12 |
Release: %{release}%{?dist} |
13 |
License: GPL |
14 |
Group: Applications/Internet |
15 |
Source: %{name}-%{version}.tgz |
16 |
BuildArch: noarch |
17 |
BuildRequires: e-smith-devtools |
18 |
Requires: smeserver-release >= 8 |
19 |
Requires: httpd >= 2 |
20 |
Requires: mod_python |
21 |
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
22 |
|
23 |
%description |
24 |
Implementation of mod_python for SME Server 8. |
25 |
|
26 |
%changelog |
27 |
* Sat Jun 01 2013 JP Pialasse <tests@pialasse.com} 0.1-2.sme |
28 |
- import to sme8 |
29 |
|
30 |
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
31 |
- Clean up spec so package can be built by koji/plague |
32 |
|
33 |
* Mon Mar 26 2007 Marco Hess <marco.hess@through-ip.com> |
34 |
- 0.1-0 |
35 |
- Original version adopted from smeserver-mod_dav |
36 |
|
37 |
%prep |
38 |
|
39 |
%setup |
40 |
|
41 |
%build |
42 |
DEFAULTS=root/etc/e-smith/db/configuration/defaults/modPython |
43 |
mkdir -p $DEFAULTS |
44 |
echo "service" > $DEFAULTS/type |
45 |
echo "enabled" > $DEFAULTS/status |
46 |
|
47 |
%install |
48 |
rm -rf $RPM_BUILD_ROOT |
49 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
50 |
rm -f %{name}-%{version}-filelist |
51 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
52 |
|
53 |
%clean |
54 |
rm -rf $RPM_BUILD_ROOT |
55 |
|
56 |
%post |
57 |
/etc/e-smith/events/actions/initialize-default-databases |
58 |
/etc/e-smith/events/actions/navigation-conf |
59 |
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
60 |
/etc/rc7.d/S86httpd-e-smith sigusr1 |
61 |
|
62 |
%postun |
63 |
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
64 |
/etc/e-smith/events/actions/navigation-conf |
65 |
/etc/rc7.d/S86httpd-e-smith sigusr1 |
66 |
|
67 |
%files -f %{name}-%{version}-filelist |
68 |
%defattr(-,root,root) |