1 |
stephdl |
1.3 |
# $Id: smeserver-mod_python.spec,v 1.2 2015/09/23 21:51:18 stephdl Exp $ |
2 |
stephdl |
1.1 |
# Authority: marcohess |
3 |
|
|
# Name: Marco Hess |
4 |
|
|
|
5 |
|
|
%define name smeserver-mod_python |
6 |
|
|
%define version 0.3 |
7 |
stephdl |
1.2 |
%define release 2 |
8 |
stephdl |
1.1 |
|
9 |
|
|
Summary: SME Server mod_python implementation |
10 |
|
|
Name: %{name} |
11 |
|
|
Version: %{version} |
12 |
|
|
Release: %{release}%{?dist} |
13 |
|
|
License: GPL |
14 |
|
|
Group: Applications/Internet |
15 |
stephdl |
1.3 |
Source: %{name}-%{version}.tar.gz |
16 |
stephdl |
1.1 |
BuildArch: noarch |
17 |
|
|
BuildRequires: e-smith-devtools |
18 |
stephdl |
1.2 |
Requires: smeserver-release >= 9 |
19 |
stephdl |
1.1 |
Requires: httpd >= 2 |
20 |
|
|
Requires: mod_python |
21 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
22 |
|
|
|
23 |
|
|
%description |
24 |
stephdl |
1.2 |
Implementation of mod_python for SME Server 9. |
25 |
stephdl |
1.1 |
|
26 |
|
|
%changelog |
27 |
stephdl |
1.2 |
* Wed Sep 23 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 0.3-2.sme |
28 |
stephdl |
1.1 |
- Initial release to contribs9 |
29 |
|
|
|
30 |
|
|
* Sat Jun 01 2013 JP Pialasse <tests@pialasse.com} 0.1-2.sme |
31 |
|
|
- import to sme8 |
32 |
|
|
|
33 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
34 |
|
|
- Clean up spec so package can be built by koji/plague |
35 |
|
|
|
36 |
|
|
* Mon Mar 26 2007 Marco Hess <marco.hess@through-ip.com> |
37 |
|
|
- 0.1-0 |
38 |
|
|
- Original version adopted from smeserver-mod_dav |
39 |
|
|
|
40 |
|
|
%prep |
41 |
|
|
|
42 |
|
|
%setup |
43 |
|
|
|
44 |
|
|
%build |
45 |
|
|
DEFAULTS=root/etc/e-smith/db/configuration/defaults/modPython |
46 |
|
|
mkdir -p $DEFAULTS |
47 |
|
|
echo "service" > $DEFAULTS/type |
48 |
|
|
echo "enabled" > $DEFAULTS/status |
49 |
|
|
|
50 |
|
|
%install |
51 |
|
|
rm -rf $RPM_BUILD_ROOT |
52 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
53 |
|
|
rm -f %{name}-%{version}-filelist |
54 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
55 |
|
|
|
56 |
|
|
%clean |
57 |
|
|
rm -rf $RPM_BUILD_ROOT |
58 |
|
|
|
59 |
|
|
%post |
60 |
|
|
/etc/e-smith/events/actions/initialize-default-databases |
61 |
|
|
/etc/e-smith/events/actions/navigation-conf |
62 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
63 |
|
|
/etc/rc7.d/S86httpd-e-smith sigusr1 |
64 |
|
|
|
65 |
|
|
%postun |
66 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
67 |
|
|
/etc/e-smith/events/actions/navigation-conf |
68 |
|
|
/etc/rc7.d/S86httpd-e-smith sigusr1 |
69 |
|
|
|
70 |
|
|
%files -f %{name}-%{version}-filelist |
71 |
|
|
%defattr(-,root,root) |