1 |
dungog |
1.4 |
# $Id: smeserver-moodle.spec,v 1.3 2008/04/02 15:03:58 slords Exp $ |
2 |
slords |
1.3 |
# Authority: dungog |
3 |
|
|
# Name: Stephen Noble |
4 |
|
|
|
5 |
slords |
1.1 |
%define name smeserver-moodle |
6 |
|
|
%define version 1.0 |
7 |
dungog |
1.5 |
%define release 6 |
8 |
slords |
1.1 |
Summary: smserver rpm to setup moodle, a course management system |
9 |
|
|
Name: %{name} |
10 |
|
|
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: GNU GPL version 2 |
13 |
|
|
URL: http://www.dungog.net/sme |
14 |
|
|
Group: SMEserver/addon |
15 |
|
|
Source: %{name}-%{version}.tar.gz |
16 |
|
|
Patch0: smeserver-moodle-1.0-null.patch |
17 |
|
|
Patch1: smeserver-moodle-1.0-20db.patch2 |
18 |
dungog |
1.4 |
Patch2: smeserver-moodle-1.0-clamscan.patch |
19 |
dungog |
1.5 |
Patch3: smeserver-moodle-1.0-191.patch |
20 |
slords |
1.1 |
BuildArchitectures: noarch |
21 |
|
|
BuildRequires: e-smith-devtools >= 1.13.1-03 |
22 |
|
|
BuildRoot: /var/tmp/%{name}-%{version} |
23 |
|
|
Requires: e-smith-release >= 7.0 |
24 |
dungog |
1.5 |
Requires: moodle >= 1.9 |
25 |
slords |
1.1 |
Requires: gd |
26 |
|
|
AutoReqProv: no |
27 |
|
|
|
28 |
|
|
%description |
29 |
|
|
smserver rpm to setup moodle, a course management system |
30 |
|
|
|
31 |
|
|
%changelog |
32 |
dungog |
1.5 |
* Mon Jun 2 2008 Stephen Noble <support@dungog.net> 1.0-6 |
33 |
|
|
- update config.php file to 1.9.1 |
34 |
|
|
|
35 |
dungog |
1.4 |
* Mon Jun 2 2008 Stephen Noble <support@dungog.net> 1.0-5 |
36 |
|
|
- allow clamscan [SME 4369] |
37 |
|
|
|
38 |
slords |
1.1 |
* Sun Sep 2 2007 Stephen Noble <support@dungog.net> 1.0-4 |
39 |
|
|
- 20db patch fixed |
40 |
|
|
|
41 |
|
|
* Sun Sep 2 2007 Stephen Noble <support@dungog.net> 1.0-3 |
42 |
|
|
- crontab redirect to null not nul |
43 |
|
|
- remove 20db patch |
44 |
|
|
|
45 |
|
|
* Sun Jul 29 2007 Stephen Noble <support@dungog.net> 1.0-2 |
46 |
|
|
- 20db template fixed |
47 |
|
|
|
48 |
|
|
* Fri Jul 06 2007 Stephen Noble <support@dungog.net> 1.0-1 |
49 |
|
|
- http alias, auto setup, template config.php |
50 |
|
|
|
51 |
|
|
* Mon Dec 11 2006 Stephen Noble <support@dungog.net> |
52 |
|
|
- rpm %post events reordered, to enable clean install |
53 |
|
|
- [0.9-2] |
54 |
|
|
|
55 |
|
|
* Fri Dec 1 2006 Stephen Noble <support@dungog.net> |
56 |
|
|
- initial release |
57 |
|
|
- [0.9-1] |
58 |
|
|
|
59 |
|
|
%prep |
60 |
|
|
%setup |
61 |
|
|
%patch0 -p1 |
62 |
|
|
%patch1 -p1 |
63 |
dungog |
1.4 |
%patch2 -p1 |
64 |
dungog |
1.5 |
%patch3 -p1 |
65 |
slords |
1.1 |
|
66 |
|
|
%build |
67 |
|
|
|
68 |
|
|
mkdir -p root/etc/e-smith/db/accounts/defaults/moodle |
69 |
|
|
echo "reserved" > root/etc/e-smith/db/accounts/defaults/moodle/type |
70 |
|
|
|
71 |
|
|
mkdir -p root/etc/e-smith/db/configuration/defaults/moodle |
72 |
|
|
echo "Online Learning" > root/etc/e-smith/db/configuration/defaults/moodle/Name |
73 |
|
|
echo "global-pw-remote" > root/etc/e-smith/db/configuration/defaults/moodle/PublicAccess |
74 |
|
|
echo "enabled" > root/etc/e-smith/db/configuration/defaults/moodle/status |
75 |
|
|
echo "moodle" > root/etc/e-smith/db/configuration/defaults/moodle/DbName |
76 |
|
|
echo "moodle" > root/etc/e-smith/db/configuration/defaults/moodle/DbUser |
77 |
|
|
|
78 |
|
|
mkdir -p root/etc/e-smith/templates.metadata/etc/e-smith/sql/init |
79 |
|
|
echo "PERMS=0750" > root/etc/e-smith/templates.metadata/etc/e-smith/sql/init/80moodle |
80 |
|
|
|
81 |
|
|
#only needed so it is removed afterwards |
82 |
|
|
mkdir -p root/opt/moodle/html |
83 |
|
|
touch root/opt/moodle/html/config.php |
84 |
|
|
|
85 |
|
|
%install |
86 |
|
|
rm -rf $RPM_BUILD_ROOT |
87 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
88 |
|
|
rm -f %{name}-%{version}-filelist |
89 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
90 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
91 |
|
|
|
92 |
|
|
%clean |
93 |
|
|
cd .. |
94 |
|
|
rm -rf %{name}-%{version} |
95 |
|
|
|
96 |
|
|
%pre |
97 |
|
|
%preun |
98 |
|
|
%post |
99 |
|
|
/etc/e-smith/events/actions/initialize-default-databases |
100 |
|
|
/sbin/e-smith/expand-template /etc/e-smith/sql/init/80moodle |
101 |
|
|
/etc/rc.d/init.d/mysql.init start |
102 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
103 |
|
|
/sbin/e-smith/expand-template /opt/moodle/html/config.php |
104 |
|
|
/usr/bin/sv h /service/httpd-e-smith |
105 |
|
|
/sbin/e-smith/expand-template /etc/crontab |
106 |
|
|
|
107 |
|
|
echo "" |
108 |
|
|
echo "see http://wiki.contribs.org/moodle" |
109 |
|
|
|
110 |
|
|
%postun |
111 |
|
|
#uninstall |
112 |
|
|
if [ $1 = 0 ] ; then |
113 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
114 |
|
|
/usr/bin/sv h /service/httpd-e-smith |
115 |
|
|
/sbin/e-smith/expand-template /etc/crontab |
116 |
|
|
fi |
117 |
|
|
|
118 |
|
|
%files -f %{name}-%{version}-filelist |
119 |
|
|
%defattr(-,root,root) |
120 |
|
|
|