1 |
Summary: MX Backup configuration panel for SME Server |
2 |
%define name smeserver-mxbackup |
3 |
Name: %{name} |
4 |
%define version 0.3 |
5 |
%define release 3 |
6 |
Version: %{version} |
7 |
Release: %{release} |
8 |
License: GPL |
9 |
Group: Networking/Daemons |
10 |
Source: %{name}-%{version}.tar.gz |
11 |
Patch0: smeserver-mxbackup-0.3-locale-2022-11-11.patch |
12 |
Patch1: smeserver-mxbackup-0.3-locale-2024-09-06.patch |
13 |
Packager: Pascal Schirrmann <schirrms@schirrms.net> |
14 |
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
15 |
BuildRequires: e-smith-devtools |
16 |
BuildArchitectures: noarch |
17 |
Requires: smeserver-release >= 10 |
18 |
Requires: e-smith-email >= 5.6.0 |
19 |
Requires: e-smith-formmagick >= 2.6.0 |
20 |
Requires: e-smith-base |
21 |
Requires: e-smith-qmail >= 2.6.0 |
22 |
AutoReqProv: no |
23 |
|
24 |
%description |
25 |
Adds a MX Backup Configuration panel to the SME server-manager. |
26 |
|
27 |
%changelog |
28 |
* Fri Sep 06 2024 Terry Fage <terry@fage.id.au> 0.3-3.sme |
29 |
- apply local 2024-09-06.patch |
30 |
|
31 |
* Fri Nov 11 2022 Jean-Philippe Pialasse <tests@pialasse.com> 0.3-2.sme |
32 |
- apply local 2022-11-11 patch |
33 |
|
34 |
* Wed Aug 31 2022 John Crisp <jcrisp@safeandsoundit.co.uk> 0.3-1.sme |
35 |
- First import to Koozali SME v10 [SME: 12162] |
36 |
|
37 |
* Tue Jan 28 2020 John Crisp <jcrisp@safeandsoundit.co.uk> 0.2-1.sme |
38 |
- Update createlinks file |
39 |
- Remove unnecessary apostrophe |
40 |
- Updated readme |
41 |
- Comment out debugging in pm file |
42 |
- Updating for v9 |
43 |
- Dropped the UTF-8 |
44 |
- Modify the vendor_perl directory |
45 |
|
46 |
* Sun Apr 20 2008 Pascal Schirrmann <schirrms@schirrms.net> |
47 |
- This is a fork of smeserver-mxbackup, with utf-8 charset. |
48 |
As long as the two versions will exist, the sequence number will stay the same. |
49 |
I just increment the version number for the tracker. |
50 |
[0.1.0-03] |
51 |
* Wed Apr 26 2006 Pascal Schirrmann <schirrms@schirrms.net> |
52 |
- Change default to host for any new creation |
53 |
[0.1.0-02] |
54 |
* Wed Apr 26 2006 Pascal Schirrmann <schirrms@schirrms.net> |
55 |
- Fast port to SME 7 : a qpsmtpd configuration file need |
56 |
to be altered to accept incoming mails for mx-backuped domains |
57 |
[0.1.0-01] |
58 |
* Tue May 11 2004 Pascal Schirrmann <schirrms@schirrms.net> |
59 |
- New : if the MX-Backup server use a 'smart host' it |
60 |
still use DNS for the 'MX-Backuped Domains' |
61 |
[0.1.0-00] |
62 |
* Thu Apr 22 2004 Pascal Schirrmann <schirrms@schirrms.net> |
63 |
- Unable to set a domain containing a Zero !!! |
64 |
[0.0.4-00] |
65 |
* Mon Mar 08 2004 Pascal Schirrmann <schirrms@schirrms.net> |
66 |
- This RPM can only work on SME 6.0 and later, adds a |
67 |
require in the 'spec' file |
68 |
[0.0.3-01] |
69 |
* Sun Mar 07 2004 Pascal Schirrmann <schirrms@schirrms.net> |
70 |
- Add some nice stuff, ligths and so on... |
71 |
Sounds are awaited for a far future release ;-) |
72 |
[0.0.3-00] |
73 |
* Sat Mar 06 2004 Pascal Schirrmann <schirrms@schirrms.net> |
74 |
- My database conception was not very 'SME-aware' |
75 |
majors change in the database storage modes. |
76 |
[0.0.2-00] |
77 |
* Wed Mar 03 2004 Pascal Schirrmann <schirrms@schirrms.net> |
78 |
- some cosmetics change on the package name to be nearer |
79 |
of contribs.org naming systems |
80 |
[0.0.1-01] |
81 |
* Fri Feb 27 2004 Pascal Schirrmann <schirrms@schirrms.net> |
82 |
- initial release |
83 |
[0.0.1-00] |
84 |
|
85 |
%prep |
86 |
%setup |
87 |
%patch0 -p1 |
88 |
%patch1 -p1 |
89 |
|
90 |
%build |
91 |
perl createlinks |
92 |
|
93 |
%install |
94 |
rm -rf $RPM_BUILD_ROOT |
95 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
96 |
rm -f e-smith-%{version}-filelist |
97 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
98 |
|
99 |
%clean |
100 |
cd .. |
101 |
rm -rf %{name}-%{version} |
102 |
|
103 |
%files -f %{name}-%{version}-filelist |
104 |
%defattr(-,root,root) |
105 |
|
106 |
%pre |
107 |
|
108 |
%post |
109 |
# SME 6 comes with a 'left panel cache' to improve the server panel display speed |
110 |
# But I haven't found a nice way to update this cache |
111 |
# So I chose to do this update here. |
112 |
if [ -x /etc/e-smith/events/actions/navigation-conf ] |
113 |
then |
114 |
echo "Rebuilding Web Server Manager Left Panel Cache ... Can take up to a minute." |
115 |
/etc/e-smith/events/actions/navigation-conf |
116 |
echo "Done." |
117 |
fi |
118 |
if [ -x /etc/e-smith/events/actions/initialize-default-databases ] |
119 |
then |
120 |
echo "Setting defaults values in SME configuration database, if needed. Don't change any existing configuration." |
121 |
/etc/e-smith/events/actions/initialize-default-databases |
122 |
echo "Done." |
123 |
fi |
124 |
# regenerate the rcpthosts file, in case of an upgrade |
125 |
# If this is a new install, this will change nothing, because |
126 |
# status = disabled |
127 |
echo "Regenerating the config file..." |
128 |
/sbin/e-smith/expand-template /var/qmail/control/rcpthosts |
129 |
/sbin/e-smith/expand-template /var/qmail/control/smtproutes |
130 |
if [ -e /var/service/qpsmtpd/config/goodrcptto ] |
131 |
then |
132 |
/sbin/e-smith/expand-template /var/service/qpsmtpd/config/goodrcptto |
133 |
fi |
134 |
# moving 'light' in correct place. |
135 |
# these lights cannot be installed by the RPM : in case someone |
136 |
# installs the same lights, there will be a conflict. |
137 |
/bin/mv -f /etc/e-smith/GreenLight.jpg /etc/e-smith/web/common/ |
138 |
/bin/mv -f /etc/e-smith/RedLight.jpg /etc/e-smith/web/common/ |
139 |
echo "Installation finished." |
140 |
|
141 |
%preun |
142 |
|
143 |
%postun |
144 |
# rollback the rcpthosts without mxbackup entries |
145 |
echo "Revert the system as a non MX Backup system." |
146 |
/sbin/e-smith/expand-template /var/qmail/control/rcpthosts |
147 |
/sbin/e-smith/expand-template /var/qmail/control/smtproutes |
148 |
if [ -e /var/service/qpsmtpd/config/goodrcptto ] |
149 |
then |
150 |
/sbin/e-smith/expand-template /var/service/qpsmtpd/config/goodrcptto |
151 |
fi |