1 |
Summary: smeserver specific mysql55 configuration and templates. |
2 |
%define name smeserver-mysql55 |
3 |
Name: %{name} |
4 |
%define version 1.0.0 |
5 |
%define release 7 |
6 |
Version: %{version} |
7 |
Release: %{release}%{?dist} |
8 |
License: GPL |
9 |
Group: Networking/Daemons |
10 |
Source: %{name}-%{version}.tar.gz |
11 |
Patch0: smeserver-mysql55-1.0.0-typo.patch |
12 |
Patch1: smeserver-mysql55-1.0.0-SME10095-phpmyadmin.patch |
13 |
Patch2: smeserver-mysql55-1.0.0-SME10099-prebackupdump.patch |
14 |
Patch3: smeserver-mysql55-1.0.0-SME1096.patch |
15 |
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
16 |
BuildArchitectures: noarch |
17 |
Requires: mysql55-mysql-server |
18 |
Requires: mysql55-mysql |
19 |
Requires: mysql55-runtime |
20 |
Requires: mysql55-mysql-libs |
21 |
Requires: mysql55 |
22 |
Requires: e-smith-base |
23 |
Requires: e-smith-lib >= 1.15.1-19 |
24 |
BuildRequires: e-smith-devtools >= 1.13.1-03 |
25 |
AutoReqProv: no |
26 |
|
27 |
%changelog |
28 |
* Wed Mar 08 2017 Jean-Philipe Pialasse <tests@pialasse.com> 1.0.0-7.sme |
29 |
- fix init55 not used by dedicated mysql.init [SME: 1096] |
30 |
|
31 |
* Sat Feb 18 2017 Jean-Philipe Pialasse <tests@pialasse.com> 1.0.0-6.sme |
32 |
- fix failure to dump mysql55 table on pre-backup event [SME: 1099] |
33 |
- add direct integration to phpmyadmin [SME: 10095] |
34 |
|
35 |
* Wed Nov 04 2015 JP Pialasse <tests@pialasse.com> 1.0.0-5.sme |
36 |
- fixed root pass link typo [SME: 8527] |
37 |
|
38 |
* Mon May 19 2014 JP Pialasse <tests@pialasse.com> 1.0.0-4.sme |
39 |
- initial release from e-smith-mysql 2.0.0-4 |
40 |
|
41 |
%description |
42 |
This package adds necessary startup and configuration items for |
43 |
mysql55. |
44 |
|
45 |
%prep |
46 |
%setup |
47 |
%patch0 -p1 |
48 |
%patch1 -p1 |
49 |
%patch2 -p1 |
50 |
%patch3 -p1 |
51 |
|
52 |
%build |
53 |
mkdir -p root/etc/e-smith/sql/init55 |
54 |
perl createlinks |
55 |
|
56 |
# add this for mysql.com rpm compatibility |
57 |
#mkdir -p root/var/run/mysql55-mysqld |
58 |
# we hould we rather link to the actual dir in opt , done in createlinks |
59 |
|
60 |
mkdir -p root/etc/rc.d/init.d/supervise |
61 |
ln -s ../daemontools root/etc/rc.d/init.d/supervise/mysql55-mysqld |
62 |
|
63 |
mkdir -p root/etc/rc.d/rc7.d |
64 |
ln -s /etc/rc.d/init.d/e-smith-service root/etc/rc.d/rc7.d/S50mysql55-mysqld |
65 |
ln -s /etc/rc.d/init.d/e-smith-service root/etc/rc.d/rc7.d/S99mysql55-mysql.init |
66 |
|
67 |
mkdir -p root/service |
68 |
ln -s /var/service/mysql55-mysqld root/service |
69 |
touch root/var/service/mysql55-mysqld/down |
70 |
|
71 |
mkdir -p root/var/log/mysql55-mysqld |
72 |
mkdir -p root/home/e-smith/db/mysql55 |
73 |
|
74 |
|
75 |
%install |
76 |
rm -rf $RPM_BUILD_ROOT |
77 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
78 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
79 |
--dir /var/run/mysql55-mysqld 'attr(0755,mysql,mysql)' \ |
80 |
--file /var/service/mysql55-mysqld/run 'attr(0755,root,root)' \ |
81 |
--file /var/service/mysql55-mysqld/control/t 'attr(0750,root,root)' \ |
82 |
--file /var/service/mysql55-mysqld/control/d 'attr(0750,root,root)' \ |
83 |
--file /var/service/mysql55-mysqld/control/i 'attr(0750,root,root)' \ |
84 |
--file /var/service/mysql55-mysqld/control/q 'attr(0750,root,root)' \ |
85 |
--file /var/service/mysql55-mysqld/log/run 'attr(0755,root,root)' \ |
86 |
--dir '/var/log/mysql55-mysqld' 'attr(2750,smelog,smelog)' \ |
87 |
--dir '/home/e-smith/db/mysql55' 'attr(0750,root,root)' \ |
88 |
> %{name}-%{version}-filelist |
89 |
echo "%doc COPYING" >> %{name}-%{version}-filelist |
90 |
|
91 |
%clean |
92 |
rm -rf $RPM_BUILD_ROOT |
93 |
|
94 |
%pre |
95 |
%preun |
96 |
|
97 |
%post |
98 |
## mysql.com compatibility |
99 |
#[ -e /etc/rc.d/init.d/mysql55-mysqld ] || ln -s ./mysql /etc/rc.d/init.d/mysql55-mysqld |
100 |
|
101 |
%postun |
102 |
#if [ "$1" == 0 ]; then |
103 |
# [ -L /etc/rc.d/init.d/mysql55-mysqld ] && rm /etc/rc.d/init.d/mysql55-mysqld || : |
104 |
#fi |
105 |
|
106 |
%files -f %{name}-%{version}-filelist |
107 |
%defattr(-,root,root) |