1 |
unnilennium |
1.1 |
Summary: smeserver specific mysql55 configuration and templates. |
2 |
|
|
%define name smeserver-mysql55 |
3 |
|
|
Name: %{name} |
4 |
unnilennium |
1.2 |
%define version 2.0.0 |
5 |
unnilennium |
1.6 |
%define release 4 |
6 |
unnilennium |
1.1 |
Version: %{version} |
7 |
|
|
Release: %{release}%{?dist} |
8 |
|
|
License: GPL |
9 |
|
|
Group: Networking/Daemons |
10 |
|
|
Source: %{name}-%{version}.tar.gz |
11 |
unnilennium |
1.5 |
Patch0: smeserver-mysql55-2.0.0-SME10094.patch |
12 |
unnilennium |
1.6 |
Patch1: smeserver-mysql55-2.0.0-SME10095-phpmyadmin.patch |
13 |
unnilennium |
1.1 |
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
14 |
|
|
BuildArchitectures: noarch |
15 |
|
|
Requires: mysql55-mysql-server |
16 |
|
|
Requires: mysql55-mysql |
17 |
|
|
Requires: mysql55-runtime |
18 |
|
|
Requires: mysql55-mysql-libs |
19 |
|
|
Requires: mysql55 |
20 |
|
|
Requires: e-smith-base |
21 |
|
|
Requires: e-smith-lib >= 1.15.1-19 |
22 |
|
|
BuildRequires: e-smith-devtools >= 1.13.1-03 |
23 |
|
|
AutoReqProv: no |
24 |
|
|
|
25 |
|
|
%changelog |
26 |
unnilennium |
1.6 |
* Thu Feb 16 2017 Jean-Philipe Pialasse <tests@pialasse.com> 2.0.0-4.sme |
27 |
|
|
- added template for phpmyadmin direct support [SME: 10095] |
28 |
|
|
- you can access directly to your mysql55 db with the phpmyadmin contrib |
29 |
|
|
|
30 |
unnilennium |
1.5 |
* Thu Feb 16 2017 Jean-Philipe Pialasse <tests@pialasse.com> 2.0.0-3.sme |
31 |
|
|
- fix incorrect startup script [SME: 10094] |
32 |
|
|
- MYSQL55_MYSQLD_SCLS_ENABLED is now MYSQL55_SCLS_ENABLED |
33 |
|
|
|
34 |
unnilennium |
1.4 |
* Wed Feb 15 2017 Jean-Philipe Pialasse <tests@pialasse.com> 2.0.0-2.sme |
35 |
unnilennium |
1.2 |
- first import to SME9 |
36 |
|
|
- mysql55 scl only available for x86_64 |
37 |
|
|
|
38 |
unnilennium |
1.1 |
* Wed Nov 04 2015 JP Pialasse <tests@pialasse.com> 1.0.0-5.sme |
39 |
|
|
- fixed root pass link typo [SME: 8527] |
40 |
|
|
|
41 |
|
|
* Mon May 19 2014 JP Pialasse <tests@pialasse.com> 1.0.0-4.sme |
42 |
|
|
- initial release from e-smith-mysql 2.0.0-4 |
43 |
|
|
|
44 |
|
|
%description |
45 |
|
|
This package adds necessary startup and configuration items for |
46 |
|
|
mysql55. |
47 |
|
|
|
48 |
|
|
%prep |
49 |
|
|
%setup |
50 |
unnilennium |
1.5 |
%patch0 -p1 |
51 |
unnilennium |
1.6 |
%patch1 -p1 |
52 |
unnilennium |
1.1 |
|
53 |
|
|
%build |
54 |
|
|
mkdir -p root/etc/e-smith/sql/init55 |
55 |
|
|
perl createlinks |
56 |
|
|
|
57 |
|
|
# add this for mysql.com rpm compatibility |
58 |
|
|
#mkdir -p root/var/run/mysql55-mysqld |
59 |
|
|
# we hould we rather link to the actual dir in opt , done in createlinks |
60 |
|
|
|
61 |
|
|
mkdir -p root/etc/rc.d/init.d/supervise |
62 |
|
|
ln -s ../daemontools root/etc/rc.d/init.d/supervise/mysql55-mysqld |
63 |
|
|
|
64 |
|
|
mkdir -p root/etc/rc.d/rc7.d |
65 |
|
|
ln -s /etc/rc.d/init.d/e-smith-service root/etc/rc.d/rc7.d/S50mysql55-mysqld |
66 |
|
|
ln -s /etc/rc.d/init.d/e-smith-service root/etc/rc.d/rc7.d/S99mysql55-mysql.init |
67 |
|
|
|
68 |
|
|
mkdir -p root/service |
69 |
|
|
ln -s /var/service/mysql55-mysqld root/service |
70 |
|
|
touch root/var/service/mysql55-mysqld/down |
71 |
|
|
|
72 |
|
|
mkdir -p root/var/log/mysql55-mysqld |
73 |
|
|
mkdir -p root/home/e-smith/db/mysql55 |
74 |
|
|
|
75 |
|
|
|
76 |
|
|
%install |
77 |
|
|
rm -rf $RPM_BUILD_ROOT |
78 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
79 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
80 |
|
|
--dir /var/run/mysql55-mysqld 'attr(0755,mysql,mysql)' \ |
81 |
|
|
--file /var/service/mysql55-mysqld/run 'attr(0755,root,root)' \ |
82 |
|
|
--file /var/service/mysql55-mysqld/control/t 'attr(0750,root,root)' \ |
83 |
|
|
--file /var/service/mysql55-mysqld/control/d 'attr(0750,root,root)' \ |
84 |
|
|
--file /var/service/mysql55-mysqld/control/i 'attr(0750,root,root)' \ |
85 |
|
|
--file /var/service/mysql55-mysqld/control/q 'attr(0750,root,root)' \ |
86 |
|
|
--file /var/service/mysql55-mysqld/log/run 'attr(0755,root,root)' \ |
87 |
|
|
--dir '/var/log/mysql55-mysqld' 'attr(2750,smelog,smelog)' \ |
88 |
|
|
--dir '/home/e-smith/db/mysql55' 'attr(0750,root,root)' \ |
89 |
|
|
> %{name}-%{version}-filelist |
90 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
91 |
|
|
|
92 |
|
|
%clean |
93 |
|
|
rm -rf $RPM_BUILD_ROOT |
94 |
|
|
|
95 |
|
|
%pre |
96 |
|
|
%preun |
97 |
|
|
|
98 |
|
|
%post |
99 |
|
|
## mysql.com compatibility |
100 |
|
|
#[ -e /etc/rc.d/init.d/mysql55-mysqld ] || ln -s ./mysql /etc/rc.d/init.d/mysql55-mysqld |
101 |
|
|
|
102 |
|
|
%postun |
103 |
|
|
#if [ "$1" == 0 ]; then |
104 |
|
|
# [ -L /etc/rc.d/init.d/mysql55-mysqld ] && rm /etc/rc.d/init.d/mysql55-mysqld || : |
105 |
|
|
#fi |
106 |
|
|
|
107 |
|
|
%files -f %{name}-%{version}-filelist |
108 |
|
|
%defattr(-,root,root) |