1 |
Summary: smeserver specific mysql57 configuration and templates. |
2 |
%define name smeserver-mysql57 |
3 |
Name: %{name} |
4 |
%define version 2.0.0 |
5 |
%define release 12 |
6 |
Version: %{version} |
7 |
Release: %{release}%{?dist} |
8 |
License: GPL |
9 |
Group: Networking/Daemons |
10 |
Source: %{name}-%{version}.tar.gz |
11 |
Patch0: smeserver-mysql57-2.0.0-SME10096.patch |
12 |
Patch1: smeserver-mysql57-2.0.0-SME10145-phmyadminFragment.patch |
13 |
Patch2: smeserver-mysql57-2.0.0-SME10146-aliases.patch |
14 |
Patch3: smeserver-mysql57-2.0.0-SME10147-rhpath.patch |
15 |
Patch4: smeserver-mysql57-2.0.0-SME10148.patch |
16 |
Patch5: smeserver-mysql57-2.0.0-SME10148-initializeDB.patch |
17 |
Patch6: smeserver-mysql57-2.0.0-SME10148-initializeDB2.patch |
18 |
Patch7: smeserver-mysql57-2.0.0-SME10197.patch |
19 |
Patch8: smeserver-mysql57-2.0.0-SME10202-prebackup.patch |
20 |
Patch9: smeserver-mysql57-2.0.0-SME10830-user.frm.patch |
21 |
|
22 |
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
23 |
BuildArchitectures: noarch |
24 |
Requires: rh-mysql57 |
25 |
Requires: e-smith-base |
26 |
Requires: e-smith-lib >= 1.15.1-19 |
27 |
|
28 |
BuildRequires: e-smith-devtools >= 1.13.1-03 |
29 |
AutoReqProv: no |
30 |
|
31 |
%changelog |
32 |
* Thu Nov 21 2019 Jean-Philipe Pialasse <tests@pialasse.com> 2.0.0-12.sme |
33 |
- fix reload dump when should not [SME: 10830] |
34 |
|
35 |
* Mon Apr 03 2017 Jean-Philipe Pialasse <tests@pialasse.com> 2.0.0-11.sme |
36 |
- fix pre-backup failure [SME: 10202] |
37 |
|
38 |
* Thu Mar 30 2017 Jean-Philipe Pialasse <tests@pialasse.com> 2.0.0-10.sme |
39 |
- fix initialize and load table [SME: 10197] |
40 |
|
41 |
* Wed Mar 15 2017 Jean-Philipe Pialasse <tests@pialasse.com> 2.0.0-9.sme |
42 |
- some more modification to allow initialization [SME: 10148] |
43 |
- error log was missing stoping initialization |
44 |
- tweaking log format for system time |
45 |
|
46 |
* Sun Mar 12 2017 Jean-Philipe Pialasse <tests@pialasse.com> 2.0.0-7.sme |
47 |
- update run file and template paths [SME: 10148] |
48 |
- r8: add link for configuration ln -s /etc/opt/rh/rh-mysql57 /opt/rh/rh-mysql57/root/etc |
49 |
- update run, set.password and my.cnf for rh-mysql57 |
50 |
|
51 |
* Sun Mar 12 2017 Jean-Philipe Pialasse <tests@pialasse.com> 2.0.0-6.sme |
52 |
- fix wrong path /opt/rh/mysql57/ [SME: 10147] |
53 |
|
54 |
* Sun Mar 12 2017 Jean-Philipe Pialasse <tests@pialasse.com> 2.0.0-5.sme |
55 |
- NFR new aliases for fast use: mysql57 mysqlshow57 mysqladmin57 mysqldump57 mysqlimport57 mysqlbinlog57 [SME: 10146] |
56 |
|
57 |
* Sun Mar 12 2017 Jean-Philipe Pialasse <tests@pialasse.com> 2.0.0-4.sme |
58 |
- fix conflict with mysql55 phpmyadmin fragment [SME: 10145] |
59 |
|
60 |
* Wed Mar 08 2017 Jean-Philipe Pialasse <tests@pialasse.com> 2.0.0-3.sme |
61 |
- fix init57 not used by dedicated mysql.init [SME: 10096] |
62 |
|
63 |
* Sun Feb 19 2017 Jean-Philipe Pialasse <tests@pialasse.com> 2.0.0-2.sme |
64 |
- fix requires rh-myql57 |
65 |
|
66 |
* Sun Feb 19 2017 Jean-Philipe Pialasse <tests@pialasse.com> 2.0.0-1.sme |
67 |
- first version forked from smeserver-mysql57-2.0.0-5 |
68 |
|
69 |
|
70 |
%description |
71 |
This package adds necessary startup and configuration items for |
72 |
mysql57. |
73 |
|
74 |
%prep |
75 |
%setup |
76 |
%patch0 -p1 |
77 |
%patch1 -p1 |
78 |
%patch2 -p1 |
79 |
%patch3 -p1 |
80 |
%patch4 -p1 |
81 |
%patch5 -p1 |
82 |
%patch6 -p1 |
83 |
%patch7 -p1 |
84 |
%patch8 -p1 |
85 |
%patch9 -p1 |
86 |
|
87 |
%build |
88 |
mkdir -p root/etc/e-smith/sql/init57 |
89 |
mkdir -p root/opt/rh/rh-mysql57/root |
90 |
perl createlinks |
91 |
|
92 |
# add this for mysql.com rpm compatibility |
93 |
#mkdir -p root/var/run/mysql57-mysqld |
94 |
# we hould we rather link to the actual dir in opt , done in createlinks |
95 |
|
96 |
mkdir -p root/etc/rc.d/init.d/supervise |
97 |
ln -s ../daemontools root/etc/rc.d/init.d/supervise/mysql57-mysqld |
98 |
|
99 |
mkdir -p root/etc/rc.d/rc7.d |
100 |
ln -s /etc/rc.d/init.d/e-smith-service root/etc/rc.d/rc7.d/S50mysql57-mysqld |
101 |
ln -s /etc/rc.d/init.d/e-smith-service root/etc/rc.d/rc7.d/S99mysql57-mysql.init |
102 |
|
103 |
mkdir -p root/service |
104 |
ln -s /var/service/mysql57-mysqld root/service |
105 |
touch root/var/service/mysql57-mysqld/down |
106 |
|
107 |
mkdir -p root/var/log/mysql57-mysqld |
108 |
mkdir -p root/home/e-smith/db/mysql57 |
109 |
|
110 |
|
111 |
%install |
112 |
rm -rf $RPM_BUILD_ROOT |
113 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
114 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
115 |
--dir /var/run/mysql57-mysqld 'attr(0757,mysql,mysql)' \ |
116 |
--file /var/service/mysql57-mysqld/run 'attr(0757,root,root)' \ |
117 |
--file /var/service/mysql57-mysqld/control/t 'attr(0750,root,root)' \ |
118 |
--file /var/service/mysql57-mysqld/control/d 'attr(0750,root,root)' \ |
119 |
--file /var/service/mysql57-mysqld/control/i 'attr(0750,root,root)' \ |
120 |
--file /var/service/mysql57-mysqld/control/q 'attr(0750,root,root)' \ |
121 |
--file /var/service/mysql57-mysqld/log/run 'attr(0757,root,root)' \ |
122 |
--dir '/var/log/mysql57-mysqld' 'attr(2750,smelog,smelog)' \ |
123 |
--dir '/home/e-smith/db/mysql57' 'attr(0750,root,root)' \ |
124 |
> %{name}-%{version}-filelist |
125 |
echo "%doc COPYING" >> %{name}-%{version}-filelist |
126 |
|
127 |
%clean |
128 |
rm -rf $RPM_BUILD_ROOT |
129 |
|
130 |
%pre |
131 |
%preun |
132 |
|
133 |
%post |
134 |
## mysql.com compatibility |
135 |
#[ -e /etc/rc.d/init.d/mysql57-mysqld ] || ln -s ./mysql /etc/rc.d/init.d/mysql57-mysqld |
136 |
|
137 |
%postun |
138 |
#if [ "$1" == 0 ]; then |
139 |
# [ -L /etc/rc.d/init.d/mysql57-mysqld ] && rm /etc/rc.d/init.d/mysql57-mysqld || : |
140 |
#fi |
141 |
|
142 |
%files -f %{name}-%{version}-filelist |
143 |
%defattr(-,root,root) |