1 |
jpp |
1.1 |
# $Id: smeserver-ntop.spec,v 1.24 2009/05/26 09:48:21 vip-ire Exp $ |
2 |
|
|
# Authority: vip-ire |
3 |
|
|
# Name: Daniel Berteaud |
4 |
|
|
|
5 |
|
|
Summary: Ntop integration in SME Server |
6 |
|
|
%define name smeserver-ntop |
7 |
|
|
Name: %{name} |
8 |
|
|
%define version 0.1.2 |
9 |
|
|
%define release 1 |
10 |
|
|
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: GPL |
13 |
|
|
Group: Applications/System |
14 |
|
|
Source: %{name}-%{version}.tar.gz |
15 |
|
|
|
16 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
17 |
|
|
BuildArch: noarch |
18 |
|
|
|
19 |
|
|
BuildRequires: e-smith-devtools |
20 |
|
|
|
21 |
|
|
Requires: ntop |
22 |
|
|
Requires: e-smith-base |
23 |
|
|
Requires: smeserver-webapps-common |
24 |
|
|
|
25 |
|
|
%description |
26 |
|
|
This package contains all the needed scripts and templates |
27 |
|
|
to run ntop on your SME Server |
28 |
|
|
|
29 |
|
|
%changelog |
30 |
|
|
* Thu Dec 4 2014 Daniel B. <daniel@firewall-services.com> 0.1.2-1 |
31 |
|
|
- Compat with ntop 5.0 on SME 9 |
32 |
|
|
|
33 |
|
|
* Tue Jan 15 2013 Daniel B. <daniel@firewall-services.com> 0.1.1-1 |
34 |
|
|
- Skip VPN interface for disabled daemon |
35 |
|
|
|
36 |
|
|
* Thu May 31 2012 Daniel B. <daniel@firewall-services.com> 0.1.0-1 |
37 |
|
|
- Move to GIT |
38 |
|
|
- Expand conf before startup |
39 |
|
|
|
40 |
|
|
* Tue Feb 21 2012 Daniel B. <daniel@firewall-services.com> 0.1-6 |
41 |
|
|
- Expand ntop conf in bootstrap-console-save |
42 |
|
|
|
43 |
|
|
* Wed Dec 07 2011 Daniel B. <daniel@firewall-services.com> 0.1-5 |
44 |
|
|
- templates cleanup |
45 |
|
|
- fix Decoders prop |
46 |
|
|
- create pcap dir |
47 |
|
|
- Add some more default options |
48 |
|
|
- Define displayed protocols instead of defaults ones |
49 |
|
|
- Make save-suspicious-packets optional |
50 |
|
|
|
51 |
|
|
* Thu Oct 20 2011 Daniel B. <daniel@firewall-services.com> 0.1-4 |
52 |
|
|
- Add VPN (openvpn-s2s) interfaces |
53 |
|
|
|
54 |
|
|
* Wed Oct 12 2011 Daniel B. <daniel@firewall-services.com> 0.1-3 |
55 |
|
|
- Don't merge traffic on different interfaces |
56 |
|
|
|
57 |
|
|
* Thu Feb 24 2011 Daniel B. <daniel@firewall-services.com> 0.1-2 |
58 |
|
|
- stop requiring mod_proxy_html, use a vhost for proxypass instead |
59 |
|
|
- remove link from the server-manager |
60 |
|
|
- Make it working with the EPEL version of ntop |
61 |
|
|
|
62 |
|
|
* Tue Nov 16 2010 Daniel B. <daniel@firewall-services.com> 0.1-1 |
63 |
|
|
- initiale release |
64 |
|
|
|
65 |
|
|
%prep |
66 |
|
|
|
67 |
|
|
%setup -q -n %{name}-%{version} |
68 |
|
|
|
69 |
|
|
%build |
70 |
|
|
perl createlinks |
71 |
|
|
%{__mkdir_p} root/var/log/ntop |
72 |
|
|
%{__mkdir_p} root/var/lib/ntop/pcap |
73 |
|
|
|
74 |
|
|
|
75 |
|
|
%install |
76 |
|
|
/bin/rm -rf $RPM_BUILD_ROOT |
77 |
|
|
(cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
78 |
|
|
/bin/rm -f %{name}-%{version}-filelist |
79 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
80 |
|
|
--file /var/service/ntop/run 'attr(0755,root,root)' \ |
81 |
|
|
--file /var/service/ntop/log/run 'attr(0755,root,root)' \ |
82 |
|
|
--dir /var/log/ntop 'attr(0750,smelog,smelog)' \ |
83 |
|
|
--dir /var/lib/ntop/pcap 'attr(0750,ntop,ntop)' \ |
84 |
|
|
> %{name}-%{version}-filelist |
85 |
|
|
echo "%doc CHANGELOG.git" >> %{name}-%{version}-filelist |
86 |
|
|
|
87 |
|
|
%files -f %{name}-%{version}-filelist |
88 |
|
|
%defattr(-,root,root) |
89 |
|
|
|
90 |
|
|
%clean |
91 |
|
|
rm -rf $RPM_BUILD_ROOT |
92 |
|
|
|
93 |
|
|
|
94 |
|
|
%post |
95 |
|
|
|
96 |
|
|
%preun |
97 |
|
|
|
98 |
|
|
true |
99 |
|
|
|