1 |
unnilennium |
1.1 |
# $Id: smeserver-oats.spec,v 1.5 2008/11/25 16:20:27 slords Exp $ |
2 |
|
|
# Authority: fetcher |
3 |
|
|
# Name: Craig D. Jensen |
4 |
|
|
|
5 |
|
|
Summary: oats Time/Project Management System for SME Server |
6 |
|
|
%define name smeserver-oats |
7 |
|
|
Name: %{name} |
8 |
|
|
%define version 0.0.1 |
9 |
|
|
%define release 2 |
10 |
|
|
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: GPL |
13 |
|
|
Group: SMEserver/addon |
14 |
|
|
Source: %{name}-%{version}.tar.gz |
15 |
|
|
Patch0: smeserver-oats-0.0.1-administrators.patch |
16 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
17 |
|
|
BuildArchitectures: noarch |
18 |
|
|
Requires: smeserver-release >= 7.0 |
19 |
|
|
Requires: oats |
20 |
|
|
BuildRequires: e-smith-devtools |
21 |
|
|
AutoReqProv: no |
22 |
|
|
%description |
23 |
|
|
%name is an implementation of oats (http://www.rustyparts.com/oats.php) |
24 |
|
|
on SME Server |
25 |
|
|
|
26 |
|
|
%changelog |
27 |
|
|
* Sat Feb 23 2008 Craig D. Jensen <craig.d.jensen@gmail.com> |
28 |
|
|
- Administrators array added to the defaults.php templates. This |
29 |
|
|
- adds the 'admin' link and associated config page to the interface. |
30 |
|
|
- [0.0.1-2] |
31 |
|
|
|
32 |
|
|
* Fri Feb 08 2008 Craig D. Jensen <craig.d.jensen@gmail.com> |
33 |
|
|
- Complete re-write to separate this with the package 'oats' |
34 |
|
|
- These two now install as do other SME Contribs. Initial Release. |
35 |
|
|
- [0.0.1-1] |
36 |
|
|
|
37 |
|
|
%prep |
38 |
|
|
|
39 |
|
|
%setup |
40 |
|
|
%patch0 -p1 |
41 |
|
|
|
42 |
|
|
%build |
43 |
|
|
#perl createlinks |
44 |
|
|
mkdir -p root/etc/e-smith/db/accounts/defaults/oats |
45 |
|
|
echo "reserved" > root/etc/e-smith/db/accounts/defaults/oats/type |
46 |
|
|
|
47 |
|
|
mkdir -p root/etc/e-smith/db/configuration/defaults/oats |
48 |
|
|
echo "service" > root/etc/e-smith/db/configuration/defaults/oats/type |
49 |
|
|
echo "Time Management System" > root/etc/e-smith/db/configuration/defaults/oats/Name |
50 |
|
|
echo "global" > root/etc/e-smith/db/configuration/defaults/oats/PublicAccess |
51 |
|
|
echo "enabled" > root/etc/e-smith/db/configuration/defaults/oats/status |
52 |
|
|
echo "oats" > root/etc/e-smith/db/configuration/defaults/oats/DbName |
53 |
|
|
echo "oats" > root/etc/e-smith/db/configuration/defaults/oats/DbUser |
54 |
|
|
|
55 |
|
|
mkdir -p root/etc/e-smith/templates.metadata/etc/e-smith/sql/init |
56 |
|
|
echo "PERMS=0750" > root/etc/e-smith/templates.metadata/etc/e-smith/sql/init/80oats |
57 |
|
|
|
58 |
|
|
%install |
59 |
|
|
rm -rf $RPM_BUILD_ROOT |
60 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
61 |
|
|
rm -f %{name}-%{version}-filelist |
62 |
|
|
/sbin/e-smith/genfilelist \ |
63 |
|
|
$RPM_BUILD_ROOT \ |
64 |
|
|
> %{name}-%{version}-filelist |
65 |
|
|
|
66 |
|
|
%files -f %{name}-%{version}-filelist |
67 |
|
|
|
68 |
|
|
%defattr(-,root,root) |
69 |
|
|
|
70 |
|
|
%clean |
71 |
|
|
rm -rf $RPM_BUILD_ROOT |
72 |
|
|
|
73 |
|
|
%pre |
74 |
|
|
|
75 |
|
|
%post |
76 |
|
|
/etc/e-smith/events/actions/initialize-default-databases |
77 |
|
|
/sbin/e-smith/expand-template /etc/e-smith/sql/init/80oats |
78 |
|
|
/etc/rc.d/init.d/mysql.init start |
79 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
80 |
|
|
/sbin/e-smith/expand-template /opt/oats/config/defaults.php |
81 |
|
|
/usr/bin/sv h /service/httpd-e-smith |
82 |
|
|
|
83 |
|
|
%preun |
84 |
|
|
|
85 |
|
|
%postun |
86 |
|
|
if [ $1 = 0 ] ; then |
87 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
88 |
|
|
/usr/bin/sv h /service/httpd-e-smith |
89 |
|
|
fi |
90 |
|
|
# Not good for yum multi-package installs ;-) so i removed the line below |
91 |
|
|
#echo "To remove the DB issue 'mysqladmin drop oats' then 'y' to confirm" |