1 |
stephdl |
1.1 |
# $Id: smeserver-ocsinventory.spec,v 1.7 2013/12/15 18:39:44 unnilennium Exp $ |
2 |
|
|
# Authority: vip-ire |
3 |
|
|
# Name: Daniel Berteaud |
4 |
|
|
|
5 |
|
|
Summary: Open Computer and Software Inventory Next Generation (SME Server integration) |
6 |
|
|
%define name smeserver-ocsinventory |
7 |
|
|
Name: %{name} |
8 |
|
|
%define version 0.3 |
9 |
stephdl |
1.2 |
%define release 2 |
10 |
stephdl |
1.1 |
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: GPL |
13 |
|
|
Group: Applications/Internet |
14 |
|
|
Source: %{name}-%{version}.tar.gz |
15 |
|
|
|
16 |
|
|
URL: http://sme.firewall-services.com |
17 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
18 |
|
|
BuildArchitectures: noarch |
19 |
|
|
BuildRequires: e-smith-devtools |
20 |
|
|
Requires: e-smith-release >= 9.0 |
21 |
|
|
Requires: ocsinventory-server |
22 |
|
|
Requires: ocsinventory-reports |
23 |
|
|
|
24 |
|
|
Conflicts: smeserver-inventory-tools |
25 |
|
|
|
26 |
|
|
%description |
27 |
|
|
Open Computer and Software Inventory Next Generation is an application |
28 |
|
|
designed to help a network or system administrator keep track of the |
29 |
|
|
computers configuration and software that are installed on the network. |
30 |
|
|
|
31 |
|
|
OCS Inventory is also able to detect all active devices on your network, |
32 |
|
|
such as switch, router, network printer and unattended devices. |
33 |
|
|
|
34 |
|
|
OCS Inventory NG includes package deployment feature on client computers |
35 |
|
|
|
36 |
|
|
%changelog |
37 |
|
|
* Thu Aug 06 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 0.3-2.sme |
38 |
|
|
- Initial release to sme9 |
39 |
|
|
|
40 |
|
|
* Sun Dec 15 2013 JP Pialasse <tests@pialasse.com> 0.1-14.sme |
41 |
|
|
- Can't exec "rpm" fix |
42 |
|
|
|
43 |
|
|
* Sat May 25 2013 JP Pialasse <tests@pialasse.com> 0.1-13.sme |
44 |
|
|
- reversing previous changes, wrong rpm |
45 |
|
|
|
46 |
|
|
* Sat May 25 2013 JP Pialasse <tests@pialasse.com> 0.1-12.sme |
47 |
|
|
- added requirement that were to be installed from wiki manually |
48 |
|
|
|
49 |
|
|
* Tue May 04 2010 Daniel B. <daniel@firewall-services.com> 0.1-11.sme |
50 |
|
|
- Check if cacert size is zero |
51 |
|
|
|
52 |
|
|
* Thu Jun 18 2009 Daniel B. <daniel@firewall-services.com> 0.1-10 |
53 |
|
|
- Fixe inventory access |
54 |
|
|
|
55 |
|
|
* Mon Jun 15 2009 Daniel B. <daniel@firewall-services.com> 0.1-9 |
56 |
|
|
- expand php.ini template during ocs-update event |
57 |
|
|
|
58 |
|
|
* Wed Mar 25 2009 Daniel B. <daniel@firewall-services.com> 0.1-8 |
59 |
|
|
- Should work with any perl version |
60 |
|
|
- Update cacert if it has changed |
61 |
|
|
|
62 |
|
|
* Thu Mar 19 2009 Daniel B. <daniel@firewall-services.com> 0.1-7 |
63 |
|
|
- Update paths to the new "download" directory /var/lib/ocsinventory-reports |
64 |
|
|
|
65 |
|
|
* Wed Mar 18 2009 Daniel B. <daniel@firewall-services.com> 0.1-6 |
66 |
|
|
- Correct openbasedir directive so package creation works |
67 |
|
|
|
68 |
|
|
* Mon Mar 16 2009 Daniel B. <daniel@firewall-services.com> 0.1-5 |
69 |
|
|
- Conflicts with smeserver-inventory-tools |
70 |
|
|
|
71 |
|
|
* Tue Dec 09 2008 Daniel B. <daniel@firewall-services.com> 0.1-4 |
72 |
|
|
- Add a link in the server-manager |
73 |
|
|
- expand mysql fragment during ocs-update event |
74 |
|
|
|
75 |
|
|
* Tue Oct 21 2008 Daniel B. <daniel@firewall-services.com> 0.1-3 |
76 |
|
|
- correct templates2expand for ocs-update event |
77 |
|
|
|
78 |
|
|
* Wed Oct 17 2008 Daniel B. <daniel@firewall-services.com> 0.1-2 |
79 |
|
|
- Compatibility with mod_perl 2 |
80 |
|
|
- Change config path |
81 |
|
|
|
82 |
|
|
* Thu Sep 10 2008 Daniel B. <daniel@firewall-services.com> 0.1-0 |
83 |
|
|
- Initial RPM |
84 |
|
|
|
85 |
|
|
|
86 |
|
|
%prep |
87 |
|
|
%setup |
88 |
|
|
|
89 |
|
|
%build |
90 |
|
|
/usr/bin/perl createlinks |
91 |
|
|
|
92 |
|
|
%install |
93 |
|
|
/bin/rm -rf $RPM_BUILD_ROOT |
94 |
|
|
(cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
95 |
|
|
rm -f %{name}-%{version}-filelist |
96 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
97 |
|
|
|
98 |
|
|
%files -f %{name}-%{version}-filelist |
99 |
|
|
%defattr(-, root, root, -) |
100 |
|
|
|
101 |
|
|
%clean |
102 |
|
|
rm -rf $RPM_BUILD_ROOT |
103 |
|
|
|
104 |
|
|
|