1 |
jcrisp |
1.1 |
%define name smeserver-open-vm-tools |
2 |
|
|
%define version 0.1 |
3 |
jcrisp |
1.3 |
%define release 3 |
4 |
jcrisp |
1.1 |
Summary: Plugin to enable add open-vm-tools support to Koozali SME |
5 |
|
|
Name: %{name} |
6 |
|
|
Version: %{version} |
7 |
|
|
Release: %{release}%{?dist} |
8 |
|
|
License: GNU GPL version 2 |
9 |
|
|
URL: http://libreswan.org/ |
10 |
|
|
Group: SMEserver/addon |
11 |
|
|
Source: %{name}-%{version}.tar.gz |
12 |
|
|
#Patch1: smeserver-open-vm-tools.patch |
13 |
|
|
|
14 |
|
|
BuildRoot: /var/tmp/%{name}-%{version} |
15 |
|
|
BuildArchitectures: noarch |
16 |
|
|
BuildRequires: e-smith-devtools |
17 |
|
|
Requires: e-smith-release >= 10.0 |
18 |
|
|
Requires: open-vm-tools |
19 |
|
|
AutoReqProv: no |
20 |
|
|
|
21 |
|
|
%description |
22 |
|
|
The qemu-guest-agent is a helper daemon, which is installed in the guest. |
23 |
|
|
It is used to exchange information between the host and guest, and to execute command in the guest. |
24 |
|
|
|
25 |
|
|
%changelog |
26 |
jcrisp |
1.3 |
* Thu Nov 25 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 0.1-3.sme |
27 |
|
|
- Really fix bogus date |
28 |
|
|
|
29 |
|
|
* Thu Nov 25 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 0.1-2.sme |
30 |
jcrisp |
1.2 |
- Fix bogus date |
31 |
|
|
|
32 |
jcrisp |
1.3 |
* Thu Nov 25 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 0.1-1.sme |
33 |
jcrisp |
1.1 |
- Initial import to Koozali SME 10 [SME: 11776] |
34 |
|
|
- Thanks to Michail Pappas for his work |
35 |
|
|
|
36 |
|
|
|
37 |
|
|
%prep |
38 |
|
|
%setup |
39 |
|
|
#%patch1 -p1 |
40 |
|
|
|
41 |
|
|
%build |
42 |
|
|
perl createlinks |
43 |
|
|
|
44 |
|
|
%install |
45 |
|
|
rm -rf $RPM_BUILD_ROOT |
46 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
47 |
|
|
rm -f %{name}-%{version}-filelist |
48 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
49 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
50 |
|
|
|
51 |
|
|
|
52 |
|
|
%clean |
53 |
|
|
cd .. |
54 |
|
|
rm -rf %{name}-%{version} |
55 |
|
|
|
56 |
|
|
%files -f %{name}-%{version}-filelist |
57 |
|
|
%defattr(-,root,root) |
58 |
|
|
|
59 |
|
|
%pre |
60 |
|
|
%preun |
61 |
|
|
%post |
62 |
|
|
|
63 |
|
|
echo "********************************************************************" |
64 |
|
|
echo "********************************************************************" |
65 |
|
|
echo "* *" |
66 |
|
|
echo "* See https://wiki.koozali.org/VMware_Tools" *" |
67 |
|
|
echo "* *" |
68 |
|
|
echo "* Please now run signal-event post-upgrade;signal-event reboot" *" |
69 |
|
|
echo "* *" |
70 |
|
|
echo "********************************************************************" |
71 |
|
|
echo "********************************************************************" |
72 |
|
|
|
73 |
|
|
|
74 |
|
|
%postun |