1 |
vip-ire |
1.31 |
# $Id: smeserver-openvpn-bridge.spec,v 1.30 2009/10/27 17:43:52 slords Exp $ |
2 |
slords |
1.2 |
# Authority: vip-ire |
3 |
|
|
# Name: Daniel Berteaud |
4 |
|
|
|
5 |
slords |
1.1 |
Summary: OpenVPN, a strong VPN solution build over SSL, pre-configured for bridge mode |
6 |
|
|
%define name smeserver-openvpn-bridge |
7 |
|
|
Name: %{name} |
8 |
|
|
%define version 2.0 |
9 |
vip-ire |
1.31 |
%define release 32 |
10 |
slords |
1.1 |
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: GPL |
13 |
|
|
Group: Networking/Remote access |
14 |
|
|
Source: %{name}-%{version}.tar.gz |
15 |
|
|
|
16 |
snetram |
1.11 |
Patch0: smeserver-openvpn-bridge-2.0-remove_dup_migrate.patch |
17 |
|
|
Patch1: smeserver-openvpn-bridge-2.0-pull.patch |
18 |
|
|
Patch2: smeserver-openvpn-bridge-2.0-config_required.patch |
19 |
|
|
Patch3: smeserver-openvpn-bridge-2.0-config_cleanup.patch |
20 |
|
|
Patch4: smeserver-openvpn-bridge-2.0-add_rule.patch |
21 |
|
|
Patch5: smeserver-openvpn-bridge-2.0-locale1.patch |
22 |
|
|
#atch6: smeserver-openvpn-bridge-2.0-openvpn_db.patch |
23 |
|
|
Patch7: smeserver-openvpn-bridge-2.0-check_certs.patch |
24 |
|
|
Patch8: smeserver-openvpn-bridge-2.0-check_bridge.patch |
25 |
|
|
Patch9: smeserver-openvpn-bridge-2.0-configure_crl_url.patch |
26 |
|
|
Patch10: smeserver-openvpn-bridge-2.0-check_certs.patch2 |
27 |
|
|
Patch11: smeserver-openvpn-bridge-2.0-create_openvpn_db.patch |
28 |
|
|
Patch12: smeserver-openvpn-bridge-2.0-local_fr_1.patch |
29 |
|
|
Patch13: smeserver-openvpn-bridge-2.0-fixtranslation.patch |
30 |
|
|
Patch14: smeserver-openvpn-bridge-2.0-removedups.patch |
31 |
|
|
Patch15: smeserver-openvpn-bridge-2.0-fixlangtag.patch |
32 |
|
|
Patch16: smeserver-openvpn-bridge-2.0-fix-en-us-locale.patch |
33 |
|
|
Patch17: smeserver-openvpn-bridge-2.0-fix-en-us-locale2.patch |
34 |
snetram |
1.12 |
Patch18: smeserver-openvpn-bridge-2.0-fix-en-us-locale3.patch |
35 |
slords |
1.14 |
Patch19: smeserver-openvpn-bridge-2.0-locale-2009-03-03.patch |
36 |
vip-ire |
1.16 |
Patch20: smeserver-openvpn-bridge-2.0-openvpn_2_1_compat.patch |
37 |
vip-ire |
1.17 |
Patch21: smeserver-openvpn-bridge-2.0-cipher_auto.patch |
38 |
vip-ire |
1.18 |
Patch22: smeserver-openvpn-bridge-2.0-remove_obsolete_init_scripts.patch |
39 |
vip-ire |
1.19 |
Patch23: smeserver-openvpn-bridge-2.0-fix_perms_on_pub_dir.patch |
40 |
slords |
1.20 |
Patch24: smeserver-openvpn-bridge-2.0-locale-2009-04-27.patch |
41 |
vip-ire |
1.21 |
Patch25: smeserver-openvpn-bridge-2.0-locale-2009-04-30.patch |
42 |
vip-ire |
1.22 |
Patch26: smeserver-openvpn-bridge-2.0-locale-2009-05-24.patch |
43 |
vip-ire |
1.23 |
Patch27: smeserver-openvpn-bridge-2.0-locale-2009-05-26.patch |
44 |
vip-ire |
1.25 |
Patch28: smeserver-openvpn-bridge-2.0-update_networks.patch |
45 |
vip-ire |
1.26 |
Patch29: smeserver-openvpn-bridge-2.0-locale-2009-07-22.patch |
46 |
slords |
1.27 |
Patch30: smeserver-openvpn-bridge-2.0-locale-2009-08-24.patch |
47 |
vip-ire |
1.28 |
Patch31: smeserver-openvpn-bridge-2.0-tls_client.patch |
48 |
|
|
Patch32: smeserver-openvpn-bridge-2.0-locale-2009-09-28.patch |
49 |
vip-ire |
1.29 |
Patch33: smeserver-openvpn-bridge-2.0-locale-2009-10-21.patch |
50 |
slords |
1.30 |
Patch34: smeserver-openvpn-bridge-2.0-locale-2009-10-27.patch |
51 |
vip-ire |
1.31 |
Patch35: smeserver-openvpn-bridge-2.0-update_crl.patch |
52 |
|
|
Patch36: smeserver-openvpn-bridge-2.0-locale-2009-11-17.patch |
53 |
slords |
1.1 |
|
54 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
55 |
|
|
BuildArchitectures: noarch |
56 |
vip-ire |
1.4 |
|
57 |
|
|
BuildRequires: e-smith-devtools |
58 |
|
|
|
59 |
slords |
1.1 |
Requires: e-smith-base |
60 |
|
|
Requires: openvpn |
61 |
vip-ire |
1.15 |
Requires: smeserver-bridge-interface |
62 |
slords |
1.1 |
Requires: perl(Net::OpenVPN::Manage) |
63 |
snetram |
1.11 |
Obsoletes: smeserver-openvpn-bridge-fws |
64 |
|
|
Obsoletes: smeserver-openvpn-bridge.fws |
65 |
slords |
1.1 |
|
66 |
|
|
%description |
67 |
|
|
This package contains all the needed scripts and templates |
68 |
|
|
to have a full working openvpn server running in bridge mode. |
69 |
|
|
|
70 |
|
|
%changelog |
71 |
vip-ire |
1.31 |
* Tue Nov 17 2009 Daniel B. <daniel@firewall-services.com> 2.0-32.sme |
72 |
|
|
- apply locale 2009-11-17 patch |
73 |
|
|
- Fix CRL update on event (openvpn-bridge-update) |
74 |
|
|
|
75 |
slords |
1.30 |
* Tue Oct 27 2009 SME Translation Server <translations@contribs.org> 2.0-31.sme |
76 |
|
|
- apply locale 2009-10-27 patch |
77 |
|
|
|
78 |
vip-ire |
1.31 |
* Wed Oct 21 2009 Daniel B. <daniel@firewall-services.com> 2.0-30.sme |
79 |
vip-ire |
1.29 |
- apply locale 2009-10-21 patch |
80 |
|
|
|
81 |
vip-ire |
1.28 |
* Tue Sep 29 2009 Daniel B. <daniel@firewall-services.com> 2.0-29.sme |
82 |
|
|
- Put tls-client directive in client config file even when additional TLS |
83 |
|
|
auth is disabled (required for the main TLS auth) [SME: 5495] |
84 |
|
|
- apply locale 2009-09-28 patch |
85 |
|
|
|
86 |
slords |
1.27 |
* Mon Aug 24 2009 SME Translation Server <translations@contribs.org> 2.0-28.sme |
87 |
|
|
- apply locale 2009-08-24 patch |
88 |
|
|
|
89 |
vip-ire |
1.26 |
* Wed Jul 22 2009 Daniel B. <daniel@firewall-services.com> 2.0-27.sme |
90 |
|
|
- apply locale 2009-07-22 patch |
91 |
|
|
|
92 |
vip-ire |
1.25 |
* Thu Jun 25 2009 Daniel B. <daniel@firewall-services.com> 2.0-26.sme |
93 |
|
|
- expand config and restart the service when local networks are added |
94 |
|
|
or removed so the new routes are pushed |
95 |
|
|
|
96 |
vip-ire |
1.24 |
* Tue May 26 2009 Daniel B. <daniel@firewall-services.com> 2.0-25.sme |
97 |
vip-ire |
1.26 |
- apply locale 2009-05-26 patch |
98 |
vip-ire |
1.23 |
|
99 |
vip-ire |
1.22 |
* Sun May 24 2009 Daniel B. <daniel@firewall-services.com> 2.0-24.sme |
100 |
|
|
- apply locale 2009-05-24 patch |
101 |
|
|
|
102 |
vip-ire |
1.21 |
* Thu Apr 30 2009 Daniel B. <daniel@firewall-services.com> 2.0-23.sme |
103 |
|
|
- apply local 2009-04-30 patch |
104 |
|
|
|
105 |
slords |
1.20 |
* Mon Apr 27 2009 SME Translation Server <translations@contribs.org> 2.0-22.sme |
106 |
|
|
- apply locale 2009-04-27 patch |
107 |
|
|
|
108 |
vip-ire |
1.19 |
* Tue Apr 14 2009 Daniel B. <daniel@firewall-services.com> [2.0-21] |
109 |
|
|
- Fixe permissions on public directory (pub and ccd) which must be readable |
110 |
|
|
by everyone (especially user nobody) |
111 |
|
|
|
112 |
vip-ire |
1.18 |
* Sun Apr 12 2009 Daniel B. <daniel@firewall-services.com> [2.0-20] |
113 |
|
|
- remove obsolete init scripts reset-openvpn and openvpn-bridge |
114 |
|
|
|
115 |
vip-ire |
1.17 |
* Wed Mar 18 2009 Daniel B. <daniel@firewall-services.com> [2.0-19] |
116 |
|
|
- Do not add cipher directive in client configuration file if set to 'auto' |
117 |
|
|
|
118 |
vip-ire |
1.16 |
* Wed Mar 11 2009 Daniel B. <daniel@firewall-services.com> [2.0-18] |
119 |
|
|
- Compatibility with openvpn 2.1 (detect plugin dir location) [SME: 5060] |
120 |
|
|
|
121 |
vip-ire |
1.15 |
* Mon Mar 09 2009 Daniel B. <daniel@firewall-services.com> [2.0-17] |
122 |
|
|
- Add smeserver-bridge-interface as dependency |
123 |
|
|
- Update spec description |
124 |
|
|
|
125 |
|
|
* Tue Mar 03 2009 SME Translation Server [2.0-16] |
126 |
slords |
1.14 |
- apply locale 2009-03-03 patch |
127 |
|
|
|
128 |
snetram |
1.11 |
* Tue Mar 03 2009 Jonathan Martens <smeserver-contribs@snetram.nl> [2.0-15] |
129 |
|
|
- Fix some more errors in the en-us locale |
130 |
|
|
- Remove tabs from SPEC file as some editors act weird with them, e.g. nano |
131 |
|
|
|
132 |
snetram |
1.9 |
* Tue Mar 03 2009 Jonathan Martens <smeserver-contribs@snetram.nl> [2.0-14] |
133 |
|
|
- Fix some grammar errors in the en-us locale |
134 |
|
|
|
135 |
snetram |
1.8 |
* Tue Mar 03 2009 Jonathan Martens <smeserver-contribs@snetram.nl> [2.0-13] |
136 |
|
|
- Fix a typo in the en-us locale |
137 |
|
|
|
138 |
slords |
1.7 |
* Tue Mar 03 2009 Shad L. Lords <slords@mail.com> [2.0-12] |
139 |
|
|
- Fix xml language tag to be correct |
140 |
|
|
|
141 |
slords |
1.6 |
* Tue Mar 03 2009 Shad L. Lords <slords@mail.com> [2.0-11] |
142 |
|
|
- Remove duplicate translations that break pootle |
143 |
|
|
|
144 |
|
|
* Tue Mar 03 2009 Shad L. Lords <slords@mail.com> [2.0-10] |
145 |
slords |
1.5 |
- Rename locale/en to locale/en-us to pootle works |
146 |
|
|
|
147 |
vip-ire |
1.3 |
* Tue Mar 03 2009 Daniel B. <daniel@firewall-services.com> [2.0-9] |
148 |
|
|
- Apply locale patch fr 1 |
149 |
vip-ire |
1.15 |
- Add e-smith-devtools as a build dependency |
150 |
vip-ire |
1.3 |
|
151 |
slords |
1.1 |
* Thu Jan 29 2009 Daniel B. <daniel@firewall-services.com> [2.0-8] |
152 |
|
|
- Fix an error with the creation of the db |
153 |
|
|
|
154 |
|
|
* Wed Jan 28 2009 Daniel B. <daniel@firewall-services.com> [2.0-7] |
155 |
|
|
- Cleanly create openvpn-bridge db |
156 |
|
|
|
157 |
|
|
* Fri Jan 16 2009 Daniel B. <daniel@firewall-services.com> [2.0-6] |
158 |
|
|
- Just warn if openvpn db is missing |
159 |
|
|
- Fix certificates check |
160 |
|
|
- Warn if bridge service isn't enabled |
161 |
|
|
- Configure the CRL update URL |
162 |
|
|
|
163 |
|
|
* Mon Jan 12 2009 Daniel B. <daniel@firewall-services.com> [2.0-5] |
164 |
|
|
- localization patch |
165 |
|
|
|
166 |
|
|
* Mon Dec 22 2008 Daniel B. <daniel@firewall-services.com> [2.0-4] |
167 |
|
|
- Add validate_common_name routine |
168 |
|
|
|
169 |
|
|
* Wed Dec 19 2008 Daniel B. <daniel@firewall-services.com> [2.0-3] |
170 |
|
|
- Added option configRequired (accept only certificate listed in the rules section) |
171 |
|
|
- Clean config templates |
172 |
|
|
|
173 |
|
|
* Tue Dec 16 2008 Daniel B. <daniel@firewall-services.com> [2.0-2] |
174 |
|
|
- Add missing pull directive in client config |
175 |
|
|
|
176 |
|
|
* Fri Dec 12 2008 Daniel B. <daniel@firewall-services.com> [2.0-1] |
177 |
|
|
- Remove useless migrate fragment (now handled by the bridge package) |
178 |
|
|
|
179 |
|
|
* Thu Dec 04 2008 Daniel B. <daniel@firewall-services.com> [2.0-0] |
180 |
|
|
- The bridge stuff is now in a separated rpm |
181 |
|
|
- Restarting the service doesn't cut the InternalInterface |
182 |
|
|
as the bridge isn't restarted |
183 |
|
|
- Correct (truely this time) the bug with dhcpd looping |
184 |
|
|
- Panel re-writen in FormMagick (much more simple now) |
185 |
|
|
- Removed the certificate manager, now handled by phpki |
186 |
|
|
- Real-time clients info using Net::OpenVPN::Manage |
187 |
|
|
- Routes to local networks are pushed to clients |
188 |
|
|
|
189 |
|
|
* Tue Feb 06 2007 Daniel Berteaud <daniel@firewall-services.com> |
190 |
|
|
- [1.1-1] |
191 |
|
|
- Bugs fixes (repported by Stephan Braunstein) |
192 |
|
|
- corrections in the en language |
193 |
|
|
|
194 |
|
|
* Tue Feb 06 2007 Daniel Berteaud <daniel@firewall-services.com> |
195 |
|
|
- [1.1-0] |
196 |
|
|
- panel enhancement |
197 |
|
|
- little correction in the local file |
198 |
|
|
|
199 |
|
|
* Fri Dec 11 2006 Daniel Berteaud <daniel@firewall-services.com> |
200 |
|
|
- [1.0-3] |
201 |
|
|
- correction of permissions on startup and shutdown scripts |
202 |
|
|
- little correction in the local file |
203 |
|
|
|
204 |
|
|
* Fri Dec 08 2006 Daniel Berteaud <daniel@firewall-services.com> |
205 |
|
|
- [1.0-2] |
206 |
|
|
- Added missing directory keys/bridge |
207 |
|
|
|
208 |
|
|
* Fri Dec 06 2006 Daniel Berteaud <daniel@firewall-services.com> |
209 |
|
|
- [1.0-1] |
210 |
|
|
- Removed useless parameters from the panel (tap, br and localInf) |
211 |
|
|
- Added a stop script (k20openvpn-bridge) |
212 |
|
|
- panel renamed to openvpn-bridge for futur compatibility |
213 |
|
|
|
214 |
|
|
%prep |
215 |
|
|
|
216 |
|
|
%setup -q -n %{name}-%{version} |
217 |
|
|
%patch0 -p1 |
218 |
|
|
%patch1 -p1 |
219 |
|
|
%patch2 -p1 |
220 |
|
|
%patch3 -p1 |
221 |
|
|
%patch4 -p1 |
222 |
|
|
%patch5 -p1 |
223 |
|
|
#%patch6 -p1 |
224 |
|
|
%patch7 -p1 |
225 |
|
|
%patch8 -p1 |
226 |
|
|
%patch9 -p1 |
227 |
|
|
%patch10 -p1 |
228 |
|
|
%patch11 -p1 |
229 |
vip-ire |
1.3 |
%patch12 -p1 |
230 |
slords |
1.5 |
%patch13 -p1 |
231 |
slords |
1.6 |
%patch14 -p1 |
232 |
slords |
1.7 |
%patch15 -p1 |
233 |
snetram |
1.8 |
%patch16 -p1 |
234 |
snetram |
1.9 |
%patch17 -p1 |
235 |
snetram |
1.13 |
%patch18 -p1 |
236 |
slords |
1.14 |
%patch19 -p1 |
237 |
vip-ire |
1.16 |
%patch20 -p1 |
238 |
vip-ire |
1.17 |
%patch21 -p1 |
239 |
vip-ire |
1.18 |
%patch22 -p1 |
240 |
vip-ire |
1.19 |
%patch23 -p1 |
241 |
slords |
1.20 |
%patch24 -p1 |
242 |
vip-ire |
1.21 |
%patch25 -p1 |
243 |
vip-ire |
1.22 |
%patch26 -p1 |
244 |
vip-ire |
1.23 |
%patch27 -p1 |
245 |
vip-ire |
1.25 |
%patch28 -p1 |
246 |
vip-ire |
1.26 |
%patch29 -p1 |
247 |
slords |
1.27 |
%patch30 -p1 |
248 |
vip-ire |
1.28 |
%patch31 -p1 |
249 |
|
|
%patch32 -p1 |
250 |
vip-ire |
1.29 |
%patch33 -p1 |
251 |
slords |
1.30 |
%patch34 -p1 |
252 |
vip-ire |
1.31 |
%patch35 -p1 |
253 |
|
|
%patch36 -p1 |
254 |
slords |
1.1 |
|
255 |
|
|
%build |
256 |
|
|
perl createlinks |
257 |
|
|
|
258 |
|
|
%{__mkdir_p} root/etc/openvpn/bridge/ccd |
259 |
|
|
%{__mkdir_p} root/etc/openvpn/bridge/priv |
260 |
|
|
%{__mkdir_p} root/etc/openvpn/bridge/pub |
261 |
|
|
%{__mkdir_p} root/var/log/openvpn-bridge |
262 |
|
|
|
263 |
|
|
%install |
264 |
|
|
/bin/rm -rf $RPM_BUILD_ROOT |
265 |
|
|
(cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
266 |
|
|
/bin/rm -f %{name}-%{version}-filelist |
267 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
268 |
snetram |
1.11 |
--file /var/service/openvpn-bridge/run 'attr(0755,root,root)' \ |
269 |
|
|
--file /var/service/openvpn-bridge/log/run 'attr(0755,root,root)' \ |
270 |
|
|
--dir /var/log/openvpn-bridge 'attr(0750,smelog,smelog)' \ |
271 |
vip-ire |
1.19 |
--dir /etc/openvpn/bridge/pub 'attr(0755,root,root)' \ |
272 |
|
|
--dir /etc/openvpn/bridge/priv 'attr(0750,root,root)' \ |
273 |
|
|
--dir /etc/openvpn/bridge/ccd 'attr(0755,root,root)' \ |
274 |
snetram |
1.11 |
--file /usr/bin/ovpn-bridge-update-crl 'attr(0750,root,root)' \ |
275 |
|
|
> %{name}-%{version}-filelist |
276 |
slords |
1.1 |
|
277 |
|
|
%files -f %{name}-%{version}-filelist |
278 |
|
|
%defattr(-,root,root) |
279 |
|
|
|
280 |
|
|
%clean |
281 |
|
|
rm -rf $RPM_BUILD_ROOT |
282 |
|
|
|
283 |
|
|
|
284 |
|
|
%post |
285 |
|
|
|
286 |
|
|
%preun |
287 |
|
|
if [ $1 -eq 0 ] ; then |
288 |
snetram |
1.11 |
/sbin/e-smith/db configuration setprop openvpn-bridge status disabled |
289 |
|
|
sv d /service/openvpn-bridge |
290 |
slords |
1.1 |
fi |
291 |
|
|
|
292 |
|
|
true |