1 |
brianr |
1.1 |
# Authority: vip-ire |
2 |
|
|
# Name: Daniel Berteaud |
3 |
|
|
|
4 |
|
|
Summary: OpenVPN, a strong VPN solution build over SSL, pre-configured for routed mode |
5 |
|
|
Name: smeserver-openvpn-routed |
6 |
|
|
%define version 0.1.6 |
7 |
brianr |
1.2 |
%define release 2 |
8 |
brianr |
1.1 |
Version: %{version} |
9 |
|
|
Release: %{release}%{?dist} |
10 |
|
|
License: GPL |
11 |
|
|
Group: Networking/Remote access |
12 |
|
|
Source: %{name}-%{version}.tar.gz |
13 |
|
|
|
14 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
15 |
|
|
BuildArchitectures: noarch |
16 |
|
|
|
17 |
|
|
BuildRequires: e-smith-devtools |
18 |
|
|
|
19 |
|
|
Requires: e-smith-base |
20 |
|
|
Requires: openvpn |
21 |
|
|
#Requires: perl(Net::OpenVPN::Manage) |
22 |
brianr |
1.2 |
Patch0:smeserver-openvpn-routed-0.1.6-Add-in-systemd-startup.patch |
23 |
brianr |
1.1 |
|
24 |
|
|
%description |
25 |
|
|
This package contains all the needed scripts and templates |
26 |
|
|
to have a full working openvpn server running in routed mode. |
27 |
|
|
|
28 |
|
|
|
29 |
|
|
%changelog |
30 |
brianr |
1.2 |
* Thu Feb 04 2021 Brian Read <brianr@bjsystems.co.uk> 0.1.6-2.sme |
31 |
|
|
- Initial import to SME10 [SME: 11336] |
32 |
|
|
- Add-in-systemd-startup |
33 |
|
|
|
34 |
|
|
|
35 |
brianr |
1.1 |
* Mon Apr 10 2017 Daniel Berteaud <daniel@firewall-services.com> 0.1.6-1 |
36 |
|
|
- Update pam plugin path [SME: 10220] |
37 |
|
|
|
38 |
|
|
* Mon Feb 8 2016 Daniel Berteaud <daniel@firewall-services.com> 0.1.5-1 |
39 |
|
|
- Create /etc/openvpn/routed/dev/urandom [SME: 9238] |
40 |
|
|
|
41 |
|
|
* Tue Sep 29 2015 Daniel Berteaud <daniel@firewall-services.com> 0.1.4-1 |
42 |
|
|
- Make crl verification optional |
43 |
|
|
- Set a default Network if none is set |
44 |
|
|
- restrict permission on the management-pass.txt file |
45 |
|
|
|
46 |
|
|
* Wed Dec 3 2014 Daniel Berteaud <daniel@firewall-services.com> 0.1.3-1 |
47 |
|
|
- Correctly push route to local network when not redirecting gw |
48 |
|
|
|
49 |
|
|
* Mon Jun 23 2014 Daniel Berteaud <daniel@firewall-services.com> 0.1.2-1 |
50 |
|
|
- Fix plugin path on x86_64 |
51 |
|
|
|
52 |
|
|
* Wed Aug 21 2013 Daniel Berteaud <daniel@firewall-services.com> 0.1.1-1 |
53 |
|
|
- Use full path to the up script |
54 |
|
|
|
55 |
|
|
* Tue Jun 11 2013 Daniel Berteaud <daniel@firewall-services.com> 0.1.0-1 |
56 |
|
|
- initial release |
57 |
|
|
|
58 |
|
|
%prep |
59 |
|
|
%setup -q -n %{name}-%{version} |
60 |
brianr |
1.2 |
%patch0 -p1 |
61 |
brianr |
1.1 |
|
62 |
|
|
%build |
63 |
|
|
perl createlinks |
64 |
|
|
|
65 |
|
|
%{__mkdir_p} root/etc/openvpn/routed/ccd |
66 |
|
|
%{__mkdir_p} root/etc/openvpn/routed/priv |
67 |
|
|
%{__mkdir_p} root/etc/openvpn/routed/pub |
68 |
|
|
%{__mkdir_p} root/etc/openvpn/routed/tmp |
69 |
|
|
%{__mkdir_p} root/etc/openvpn/routed/dev |
70 |
|
|
%{__mkdir_p} root/var/log/openvpn-routed |
71 |
|
|
|
72 |
|
|
%install |
73 |
|
|
/bin/rm -rf $RPM_BUILD_ROOT |
74 |
|
|
(cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
75 |
brianr |
1.2 |
/bin/chmod +x $RPM_BUILD_ROOT/usr/sbin/systemd/openvpn-routed |
76 |
brianr |
1.1 |
/bin/rm -f %{name}-%{version}-filelist |
77 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
78 |
|
|
--file /var/service/openvpn-routed/run 'attr(0755,root,root)' \ |
79 |
|
|
--file /var/service/openvpn-routed/log/run 'attr(0755,root,root)' \ |
80 |
|
|
--dir /var/log/openvpn-routed 'attr(0750,smelog,smelog)' \ |
81 |
|
|
--dir /etc/openvpn/routed/pub 'attr(0755,root,root)' \ |
82 |
|
|
--dir /etc/openvpn/routed/priv 'attr(0750,root,root)' \ |
83 |
|
|
--dir /etc/openvpn/routed/ccd 'attr(0755,root,root)' \ |
84 |
|
|
--dir /etc/openvpn/routed/tmp 'attr(0770,root,openvpn)' \ |
85 |
|
|
--file /usr/bin/ovpn-routed-update-crl 'attr(0750,root,root)' \ |
86 |
|
|
--file /etc/openvpn/routed/bin/up 'attr(755,root,root)' \ |
87 |
|
|
> %{name}-%{version}-filelist |
88 |
|
|
|
89 |
|
|
%files -f %{name}-%{version}-filelist |
90 |
|
|
%defattr(-,root,root) |
91 |
|
|
|
92 |
|
|
%clean |
93 |
|
|
rm -rf $RPM_BUILD_ROOT |
94 |
|
|
|
95 |
|
|
%post |
96 |
|
|
if [ \! -c /etc/openvpn/routed/dev/urandom ]; then |
97 |
|
|
mknod -m 0444 /etc/openvpn/routed/dev/urandom c 1 9 |
98 |
|
|
fi |
99 |
|
|
|
100 |
|
|
%preun |
101 |
|
|
|