1 |
jcrisp |
1.1 |
# Authority: vip-ire |
2 |
|
|
# Name: Daniel Berteaud |
3 |
|
|
|
4 |
|
|
Summary: OpenVPN, a strong VPN solution build over SSL, pre-configured for routed mode |
5 |
|
|
Name: smeserver-openvpn-routed |
6 |
|
|
%define version 0.1.6 |
7 |
|
|
%define release 1 |
8 |
|
|
Version: %{version} |
9 |
|
|
Release: %{release}%{?dist} |
10 |
|
|
License: GPL |
11 |
|
|
Group: Networking/Remote access |
12 |
|
|
Source: %{name}-%{version}.tar.gz |
13 |
|
|
|
14 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
15 |
|
|
BuildArchitectures: noarch |
16 |
|
|
|
17 |
|
|
BuildRequires: e-smith-devtools |
18 |
|
|
|
19 |
|
|
Requires: e-smith-base |
20 |
|
|
Requires: openvpn |
21 |
|
|
#Requires: perl(Net::OpenVPN::Manage) |
22 |
|
|
|
23 |
|
|
%description |
24 |
|
|
This package contains all the needed scripts and templates |
25 |
|
|
to have a full working openvpn server running in routed mode. |
26 |
|
|
|
27 |
|
|
|
28 |
|
|
%changelog |
29 |
|
|
* Mon Apr 10 2017 Daniel Berteaud <daniel@firewall-services.com> 0.1.6-1 |
30 |
|
|
- Update pam plugin path [SME: 10220] |
31 |
|
|
|
32 |
|
|
* Mon Feb 8 2016 Daniel Berteaud <daniel@firewall-services.com> 0.1.5-1 |
33 |
|
|
- Create /etc/openvpn/routed/dev/urandom [SME: 9238] |
34 |
|
|
|
35 |
|
|
* Tue Sep 29 2015 Daniel Berteaud <daniel@firewall-services.com> 0.1.4-1 |
36 |
|
|
- Make crl verification optional |
37 |
|
|
- Set a default Network if none is set |
38 |
|
|
- restrict permission on the management-pass.txt file |
39 |
|
|
|
40 |
|
|
* Wed Dec 3 2014 Daniel Berteaud <daniel@firewall-services.com> 0.1.3-1 |
41 |
|
|
- Correctly push route to local network when not redirecting gw |
42 |
|
|
|
43 |
|
|
* Mon Jun 23 2014 Daniel Berteaud <daniel@firewall-services.com> 0.1.2-1 |
44 |
|
|
- Fix plugin path on x86_64 |
45 |
|
|
|
46 |
|
|
* Wed Aug 21 2013 Daniel Berteaud <daniel@firewall-services.com> 0.1.1-1 |
47 |
|
|
- Use full path to the up script |
48 |
|
|
|
49 |
|
|
* Tue Jun 11 2013 Daniel Berteaud <daniel@firewall-services.com> 0.1.0-1 |
50 |
|
|
- initial release |
51 |
|
|
|
52 |
|
|
%prep |
53 |
|
|
%setup -q -n %{name}-%{version} |
54 |
|
|
|
55 |
|
|
%build |
56 |
|
|
perl createlinks |
57 |
|
|
|
58 |
|
|
%{__mkdir_p} root/etc/openvpn/routed/ccd |
59 |
|
|
%{__mkdir_p} root/etc/openvpn/routed/priv |
60 |
|
|
%{__mkdir_p} root/etc/openvpn/routed/pub |
61 |
|
|
%{__mkdir_p} root/etc/openvpn/routed/tmp |
62 |
|
|
%{__mkdir_p} root/etc/openvpn/routed/dev |
63 |
|
|
%{__mkdir_p} root/var/log/openvpn-routed |
64 |
|
|
|
65 |
|
|
%install |
66 |
|
|
/bin/rm -rf $RPM_BUILD_ROOT |
67 |
|
|
(cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
68 |
|
|
/bin/rm -f %{name}-%{version}-filelist |
69 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
70 |
|
|
--file /var/service/openvpn-routed/run 'attr(0755,root,root)' \ |
71 |
|
|
--file /var/service/openvpn-routed/log/run 'attr(0755,root,root)' \ |
72 |
|
|
--dir /var/log/openvpn-routed 'attr(0750,smelog,smelog)' \ |
73 |
|
|
--dir /etc/openvpn/routed/pub 'attr(0755,root,root)' \ |
74 |
|
|
--dir /etc/openvpn/routed/priv 'attr(0750,root,root)' \ |
75 |
|
|
--dir /etc/openvpn/routed/ccd 'attr(0755,root,root)' \ |
76 |
|
|
--dir /etc/openvpn/routed/tmp 'attr(0770,root,openvpn)' \ |
77 |
|
|
--file /usr/bin/ovpn-routed-update-crl 'attr(0750,root,root)' \ |
78 |
|
|
--file /etc/openvpn/routed/bin/up 'attr(755,root,root)' \ |
79 |
|
|
> %{name}-%{version}-filelist |
80 |
|
|
|
81 |
|
|
%files -f %{name}-%{version}-filelist |
82 |
|
|
%defattr(-,root,root) |
83 |
|
|
|
84 |
|
|
%clean |
85 |
|
|
rm -rf $RPM_BUILD_ROOT |
86 |
|
|
|
87 |
|
|
%post |
88 |
|
|
if [ \! -c /etc/openvpn/routed/dev/urandom ]; then |
89 |
|
|
mknod -m 0444 /etc/openvpn/routed/dev/urandom c 1 9 |
90 |
|
|
fi |
91 |
|
|
|
92 |
|
|
%preun |
93 |
|
|
|