1 |
slords |
1.1 |
Summary: smserver rpm to setup photos digital photo manager |
2 |
|
|
%define name smeserver-photos |
3 |
|
|
Name: %{name} |
4 |
|
|
%define version 0.1 |
5 |
|
|
%define release 2 |
6 |
|
|
Version: %{version} |
7 |
|
|
Release: %{release}%{?dist} |
8 |
|
|
License: GPL |
9 |
|
|
URL: http://acenet-tech.org/sme |
10 |
|
|
Group: SME Server/addon |
11 |
|
|
Source: %{name}-%{version}.tar.gz |
12 |
|
|
BuildArchitectures: noarch |
13 |
|
|
BuildRoot: /var/tmp/%{name}-%{version} |
14 |
|
|
Requires: e-smith-release >= 7.0 |
15 |
|
|
Requires: photos |
16 |
|
|
BuildRequires: e-smith-devtools |
17 |
|
|
AutoReqProv: no |
18 |
|
|
|
19 |
|
|
%description |
20 |
|
|
smserver rpm to integrate photos digital photo manager into SME |
21 |
|
|
|
22 |
|
|
%changelog |
23 |
|
|
* Fri Mar 02 2007 Craig D. Jensen <craig.d.jensen@gmail.com> |
24 |
|
|
- Name change to reflect SME rpm builds. Added GPG signature |
25 |
|
|
|
26 |
|
|
* Mon Dec 18 2006 Craig D. Jensen <craig.d.jensen@gmail.com> |
27 |
|
|
- initial release |
28 |
|
|
- [4.1-1] |
29 |
|
|
|
30 |
|
|
%prep |
31 |
|
|
%setup |
32 |
|
|
|
33 |
|
|
%build |
34 |
|
|
#perl createlinks |
35 |
|
|
mkdir -p root/etc/e-smith/db/accounts/defaults/photos |
36 |
|
|
echo "reserved" > root/etc/e-smith/db/accounts/defaults/photos/type |
37 |
|
|
|
38 |
|
|
mkdir -p root/etc/e-smith/db/configuration/defaults/photos |
39 |
|
|
echo "Digital Photo Manager" > root/etc/e-smith/db/configuration/defaults/photos/Name |
40 |
|
|
echo "global-pw-remote" > root/etc/e-smith/db/configuration/defaults/photos/PublicAccess |
41 |
|
|
echo "photomanager" > root/etc/e-smith/db/configuration/defaults/photos/URL |
42 |
|
|
|
43 |
|
|
%install |
44 |
|
|
rm -rf $RPM_BUILD_ROOT |
45 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
46 |
|
|
rm -f %{name}-%{version}-filelist |
47 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
48 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
49 |
|
|
|
50 |
|
|
%clean |
51 |
|
|
cd .. |
52 |
|
|
rm -rf %{name}-%{version} |
53 |
|
|
|
54 |
|
|
%pre |
55 |
|
|
|
56 |
|
|
%preun |
57 |
|
|
|
58 |
|
|
%post |
59 |
|
|
/etc/e-smith/events/actions/initialize-default-databases |
60 |
|
|
/sbin/e-smith/expand-template /etc/e-smith/sql/init/80photos.sql |
61 |
|
|
/etc/rc.d/init.d/mysql.init start |
62 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
63 |
|
|
/usr/local/bin/svc -h /service/httpd-e-smith |
64 |
|
|
|
65 |
|
|
echo "" |
66 |
|
|
echo "Go to:" |
67 |
|
|
echo "acenet-tech.org/sme/smecontrib.php" |
68 |
|
|
echo "current settings 'config show photos'..." |
69 |
|
|
/sbin/e-smith/config show photos |
70 |
|
|
|
71 |
|
|
%postun |
72 |
|
|
#uninstall |
73 |
|
|
if [ $1 = 0 ] ; then |
74 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
75 |
|
|
/usr/local/bin/svc -h /service/httpd-e-smith |
76 |
|
|
fi |
77 |
|
|
|
78 |
|
|
%files -f %{name}-%{version}-filelist |
79 |
|
|
%defattr(-,root,root) |
80 |
|
|
|