1 |
# $Id: smeserver-photos.spec,v 1.2 2008/04/02 15:03:59 slords Exp $ |
2 |
# Authority: fetcher |
3 |
# Name: Craig D. Jensen |
4 |
|
5 |
Summary: smserver rpm to setup photos digital photo manager |
6 |
%define name smeserver-photos |
7 |
Name: %{name} |
8 |
%define version 0.1 |
9 |
%define release 2 |
10 |
Version: %{version} |
11 |
Release: %{release}%{?dist} |
12 |
License: GPL |
13 |
URL: http://acenet-tech.org/sme |
14 |
Group: SME Server/addon |
15 |
Source: %{name}-%{version}.tar.gz |
16 |
BuildArchitectures: noarch |
17 |
BuildRoot: /var/tmp/%{name}-%{version} |
18 |
Requires: e-smith-release >= 7.0 |
19 |
Requires: photos |
20 |
BuildRequires: e-smith-devtools |
21 |
AutoReqProv: no |
22 |
|
23 |
%description |
24 |
smserver rpm to integrate photos digital photo manager into SME |
25 |
|
26 |
%changelog |
27 |
* Fri Mar 02 2007 Craig D. Jensen <craig.d.jensen@gmail.com> |
28 |
- Name change to reflect SME rpm builds. Added GPG signature |
29 |
|
30 |
* Mon Dec 18 2006 Craig D. Jensen <craig.d.jensen@gmail.com> |
31 |
- initial release |
32 |
- [4.1-1] |
33 |
|
34 |
%prep |
35 |
%setup |
36 |
|
37 |
%build |
38 |
#perl createlinks |
39 |
mkdir -p root/etc/e-smith/db/accounts/defaults/photos |
40 |
echo "reserved" > root/etc/e-smith/db/accounts/defaults/photos/type |
41 |
|
42 |
mkdir -p root/etc/e-smith/db/configuration/defaults/photos |
43 |
echo "Digital Photo Manager" > root/etc/e-smith/db/configuration/defaults/photos/Name |
44 |
echo "global-pw-remote" > root/etc/e-smith/db/configuration/defaults/photos/PublicAccess |
45 |
echo "photomanager" > root/etc/e-smith/db/configuration/defaults/photos/URL |
46 |
|
47 |
%install |
48 |
rm -rf $RPM_BUILD_ROOT |
49 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
50 |
rm -f %{name}-%{version}-filelist |
51 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
52 |
echo "%doc COPYING" >> %{name}-%{version}-filelist |
53 |
|
54 |
%clean |
55 |
cd .. |
56 |
rm -rf %{name}-%{version} |
57 |
|
58 |
%pre |
59 |
|
60 |
%preun |
61 |
|
62 |
%post |
63 |
/etc/e-smith/events/actions/initialize-default-databases |
64 |
/sbin/e-smith/expand-template /etc/e-smith/sql/init/80photos.sql |
65 |
/etc/rc.d/init.d/mysql.init start |
66 |
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
67 |
/usr/local/bin/svc -h /service/httpd-e-smith |
68 |
|
69 |
echo "" |
70 |
echo "Go to:" |
71 |
echo "acenet-tech.org/sme/smecontrib.php" |
72 |
echo "current settings 'config show photos'..." |
73 |
/sbin/e-smith/config show photos |
74 |
|
75 |
%postun |
76 |
#uninstall |
77 |
if [ $1 = 0 ] ; then |
78 |
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
79 |
/usr/local/bin/svc -h /service/httpd-e-smith |
80 |
fi |
81 |
|
82 |
%files -f %{name}-%{version}-filelist |
83 |
%defattr(-,root,root) |
84 |
|