1 |
stephdl |
1.1 |
Summary: SME server php REMI scl |
2 |
|
|
%define name smeserver-php-scl |
3 |
|
|
Name: %{name} |
4 |
|
|
%define version 0.4 |
5 |
stephdl |
1.3 |
%define release 5 |
6 |
stephdl |
1.1 |
Version: %{version} |
7 |
|
|
Release: %{release}%{?dist} |
8 |
|
|
License: GPL |
9 |
|
|
Group: Administration |
10 |
|
|
Source: %{name}-%{version}.tar.gz |
11 |
|
|
BuildRoot: /var/tmp/e-smith-buildroot |
12 |
|
|
BuildRequires: e-smith-devtools |
13 |
|
|
BuildArchitectures: x86_64 |
14 |
|
|
Requires: e-smith-release >= 9.0 |
15 |
|
|
Requires: scl-utils |
16 |
|
|
Requires: php54 , php54-php , php54-php-bcmath , php54-php-gd , php54-php-imap , php54-php-ldap , php54-php-enchant |
17 |
|
|
Requires: php54-php-mbstring , php54-php-pdo , php54-php-tidy , php54-php-mysqlnd php54-php-pecl-zip , php54-php-xml |
18 |
|
|
Requires: php54-php-soap , |
19 |
|
|
Requires: php55 , php55-php , php55-php-bcmath , php55-php-gd , php55-php-imap , php55-php-ldap , php55-php-enchant |
20 |
|
|
Requires: php55-php-mbstring , php55-php-pdo , php55-php-tidy , php55-php-mysqlnd , php55-php-xml , php55-php-soap |
21 |
|
|
Requires: php55-php-pecl-zip |
22 |
|
|
Requires: php56 , php56-php , php56-php-bcmath , php56-php-gd , php56-php-imap , php56-php-ldap , php56-php-enchant |
23 |
|
|
Requires: php56-php-mbstring , php56-php-pdo , php56-php-tidy , php56-php-mysqlnd , php56-php-xml , php56-php-soap |
24 |
|
|
Requires: php56-php-pecl-zip |
25 |
|
|
AutoReqProv: no |
26 |
stephdl |
1.3 |
Patch0: smeserver-php-scl-0.4.bz9021.addlocales.patch |
27 |
stephdl |
1.1 |
|
28 |
|
|
%changelog |
29 |
stephdl |
1.3 |
* Wed Sep 2 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 0.4-5.sme |
30 |
|
|
- added smeserver-php-scl-0.4.bz9021.addlocales.patch |
31 |
|
|
|
32 |
|
|
* Wed Jun 17 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 0.4-4.sme |
33 |
|
|
- Initial release to sme9contribs |
34 |
|
|
|
35 |
stephdl |
1.1 |
* Fri Feb 20 2015 Stephane de Labrusse <stephdl@de-labrusse.fr> 0.4-3 |
36 |
|
|
- Corrected a typo '~' in /opt/remi/php55/root/etc/php.ini |
37 |
|
|
|
38 |
|
|
* Fri Feb 20 2015 Stephane de Labrusse <stephdl@de-labrusse.fr> 0.4-2 |
39 |
|
|
- Added a Panel to select the php version in PHP-mod |
40 |
|
|
|
41 |
|
|
* Sat Feb 07 2015 Stephane de Labrusse <stephdl@de-labrusse.fr> 0.4-1 |
42 |
|
|
- Switch to remi repository {php54,php55,php56} |
43 |
|
|
- Added a Panel for ibay php version |
44 |
|
|
|
45 |
|
|
* Sun Nov 9 2014 Stephane de Labrusse <stephdl@de-labrusse.fr> 0.3-3 |
46 |
|
|
- Added a db to load the php54-mod in apache |
47 |
|
|
- New php settings in php.ini |
48 |
|
|
- Added default db values |
49 |
|
|
|
50 |
|
|
* Fri Nov 7 2014 Stephane de Labrusse <stephdl@de-labrusse.fr> 0.2-1 |
51 |
|
|
- Added php55 |
52 |
|
|
|
53 |
|
|
* Fri Nov 7 2014 Stephane de Labrusse <stephdl@de-labrusse.fr> 0.1-1 |
54 |
|
|
- Initial release to sme9 |
55 |
|
|
|
56 |
|
|
%description |
57 |
|
|
Allow to use different versions of php whith a cgi script. |
58 |
|
|
|
59 |
|
|
%prep |
60 |
|
|
%setup |
61 |
stephdl |
1.3 |
%patch0 -p1 |
62 |
stephdl |
1.1 |
|
63 |
|
|
%build |
64 |
|
|
perl createlinks |
65 |
|
|
|
66 |
|
|
%install |
67 |
|
|
rm -rf $RPM_BUILD_ROOT |
68 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
69 |
|
|
rm -f %{name}-%{version}-filelist |
70 |
|
|
/sbin/e-smith/genfilelist \ |
71 |
|
|
--file /usr/bin/phpscl/php54_REMI 'attr(0770,root,www)' \ |
72 |
|
|
--file /usr/bin/phpscl/php55_REMI 'attr(0770,root,www)' \ |
73 |
|
|
--file /usr/bin/phpscl/php56_REMI 'attr(0770,root,www)' \ |
74 |
|
|
$RPM_BUILD_ROOT > %{name}-%{version}-filelist |
75 |
|
|
|
76 |
|
|
|
77 |
|
|
%clean |
78 |
|
|
rm -rf $RPM_BUILD_ROOT |
79 |
|
|
|
80 |
|
|
%pre |
81 |
|
|
|
82 |
|
|
%preun |
83 |
|
|
|
84 |
|
|
%post |
85 |
|
|
|
86 |
|
|
%postun |
87 |
|
|
|
88 |
|
|
%files -f %{name}-%{version}-filelist |
89 |
|
|
%defattr(-,root,root) |
90 |
|
|
|