/[smecontribs]/rpms/smeserver-phpki-ng/contribs10/smeserver-phpki-ng.spec
ViewVC logotype

Annotation of /rpms/smeserver-phpki-ng/contribs10/smeserver-phpki-ng.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Tue Nov 24 16:28:22 2020 UTC (3 years, 6 months ago) by jcrisp
Branch: MAIN
CVS Tags: smeserver-phpki-ng-0_3-1_el7_sme
Initial import

1 jcrisp 1.1 # $Id: smeserver-phpki.spec,v 1.6 2017/05/03 21:08:27 unnilennium Exp $
2     # Authority: vip-ire
3     # Name: Daniel Berteaud
4    
5     Name: smeserver-phpki-ng
6     Version: 0.3
7     Release: 1%{?dist}
8     Summary: php integration into SME server
9    
10     Group: Applications/System
11     License: GPL
12     URL: http://phpki.sourceforge.net/
13     Source: %{name}-%{version}.tar.xz
14     #Patch0: smeserver-phpki-0.2-fix_redirect_with_user-manager_and_sso.patch
15     #Patch1: smeserver-phpki-0.2.bz10267.updatetktauth.patch
16    
17     BuildRoot: %{_tmppath}/%{name}-%{version}
18     BuildArch: noarch
19    
20     BuildRequires: e-smith-devtools
21    
22     Requires: mod_auth_tkt
23     Requires: e-smith-base
24     Requires: phpki-ng
25     Requires: php-process
26     Requires: e-smith-manager >= 2.6.0-22
27     Obsoletes: smeserver-phpki
28    
29     %description
30     PHPki is an Open Source Web application for managing a multi-agency PKI for HIPAA compliance.
31     With it, you may create and centrally manage X.509 certificates for use with S/MIME enabled
32     e-mail clients, SSL servers, and VPN applications.
33     This package contains specific configuration for SME server
34    
35    
36     %changelog
37     * Fri Apr 03 2020 John Crisp <jcrisp@safeandsoundit.co.uk> 0.3-1.sme
38     - New release for phpki-ng-0.84 based on phpki-0.83
39    
40     * Wed May 03 2017 Jean-Philipe Pialasse <tests@pialasse.com> 0.2-3.sme
41     - update TKT auth parameter for SME 9.2 update [SME: 10267]
42    
43     * Mon Nov 18 2013 Daniel B. <daniel@firewall-services.com> - 0.2-2.sme
44     - Fix a redirect issue with user-manager and LemonLDAP::NG as SSO
45    
46     * Mon Nov 11 2013 Daniel B. <daniel@firewall-services.com> - 0.2-1.sme
47     - Rebuild for SME9
48     - Do not disable httpd-pki service on uninstall
49    
50     * Fri May 24 2013 JP Pialasse <tests@pialasse.com> - 0.1-6.sme
51     - added php-process as dependency [SME: 7439]
52    
53     * Thu Oct 13 2011 Daniel B. <daniel@firewall-services.com> - 0.1-5.sme
54     - Change session path [SME: 6661]
55    
56     * Wed Jul 20 2011 Daniel B. <daniel@firewall-services.com> - 0.1-5.sme
57     - Protect by location (so we can set another location protected by LemonLDAP::NG)
58    
59     * Mon Feb 23 2009 Daniel B. <daniel@firewall-services.com> [0.1-4]
60     - Fix logrotate issue (send a sigusr1 signal to httpd-pki)
61    
62     * Mon Dec 15 2008 Daniel B. <daniel@firewall-services.com> [0.1-3]
63     - Move server-manager panel to "security" section
64    
65     * Wed Dec 10 2008 Daniel B. <daniel@firewall-services.com> [0.1-2]
66     - expand-templates in bootstrap-console-save instead of post-upgrade
67     - Disable authentication for the public part (so CRL can be updated automatically)
68     - Change the name of the menue in server-manager to certificate Management
69    
70     * Tue Dec 02 2008 Daniel B. <daniel@firewall-services.com> [0.1-1]
71     - Restrict access to /phpki/ca for admin, ask for a valid user for /phpki
72     - expand-templates on signal events conf-userpanels and domain-modify
73    
74     * Thu Nov 27 2008 Daniel B. <daniel@firewall-services.com> [0.1-0]
75     - initial release
76    
77    
78     %prep
79     %setup -q -n %{name}-%{version}
80     #%patch0 -p1
81     #%patch1 -p1
82    
83     %build
84     perl createlinks
85    
86     %install
87    
88     %{__mkdir_p} $RPM_BUILD_ROOT/var/service/httpd-pki/supervise
89     %{__mkdir_p} $RPM_BUILD_ROOT/var/service/httpd-pki/log/supervise
90     %{__mkdir_p} $RPM_BUILD_ROOT/var/log/httpd-pki
91     %{__mkdir_p} $RPM_BUILD_ROOT/var/lib/php/pki-session
92    
93    
94     (cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT)
95     /bin/rm -f %{name}-%{version}-filelist
96     /sbin/e-smith/genfilelist $RPM_BUILD_ROOT \
97     --dir /var/service/httpd-pki 'attr(01755,root,root)' \
98     --file /var/service/httpd-pki/run 'attr(0700,root,root)' \
99     --dir /var/service/httpd-pki/supervise 'attr(0700,root,root)' \
100     --dir /var/service/httpd-pki/log 'attr(0755,root,root)' \
101     --file /var/service/httpd-pki/log/run 'attr(0755,root,root)' \
102     --dir /var/service/httpd-pki/log/supervise 'attr(0700,root,root)' \
103     --dir /var/log/httpd-pki 'attr(0750,smelog,smelog)' \
104     --dir /var/lib/php/pki-session 'attr(0770,root,phpki)' \
105     > %{name}-%{version}-filelist
106    
107    
108     %clean
109     rm -rf $RPM_BUILD_ROOT
110    
111     %files -f %{name}-%{version}-filelist
112     %defattr(-,root,root)
113    
114     %pre
115     #/sbin/e-smith/create-system-user phpki 455 'Phpki User' /opt/phpki /bin/false >& /dev/null || :
116    
117     %preun
118    
119    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed