1 |
slords |
1.1 |
Summary: PhpLdapAdmin for SME server |
2 |
|
|
%define name smeserver-phpldapadmin |
3 |
|
|
Name: %{name} |
4 |
|
|
%define version 0.9.8.3 |
5 |
|
|
%define release 1 |
6 |
|
|
Version: %{version} |
7 |
|
|
Release: %{release} |
8 |
|
|
Copyright: Freely distributable |
9 |
|
|
Group: Apache |
10 |
|
|
Source: %{name}-%{version}.tar.gz |
11 |
|
|
#Patch0: %{name}-%{version}.patch.yyyymmddnn |
12 |
|
|
Packager: Michel Van hees <michel@vanhees.cc> |
13 |
|
|
BuildRoot: /var/tmp/e-smith-buildroot |
14 |
|
|
BuildRequires: e-smith-devtools |
15 |
|
|
BuildArchitectures: noarch |
16 |
|
|
Requires: smeserver-release >= 7 |
17 |
|
|
AutoReqProv: no |
18 |
|
|
|
19 |
|
|
%changelog |
20 |
|
|
* Thu Jun 26 2007 Michel Van hees <michel@vanhees.cc> |
21 |
|
|
- Restart contrib from scratch |
22 |
|
|
- Use of phpldapadmin 0.9.8.3 |
23 |
|
|
|
24 |
|
|
%description |
25 |
|
|
SME server - phpmyadmin multiuser for smeserver |
26 |
|
|
|
27 |
|
|
%prep |
28 |
|
|
%setup |
29 |
|
|
#%patch0 -p1 |
30 |
|
|
#%patch1 -p1 |
31 |
|
|
|
32 |
|
|
%build |
33 |
|
|
perl createlinks |
34 |
|
|
|
35 |
|
|
%install |
36 |
|
|
rm -rf $RPM_BUILD_ROOT |
37 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
38 |
|
|
rm -f %{name}-%{version}-filelist |
39 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
40 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
41 |
|
|
|
42 |
|
|
%clean |
43 |
|
|
rm -rf $RPM_BUILD_ROOT |
44 |
|
|
|
45 |
|
|
%pre |
46 |
|
|
|
47 |
|
|
%preun |
48 |
|
|
|
49 |
|
|
%post |
50 |
|
|
/sbin/e-smith/db configuration set phpldapadmin service |
51 |
|
|
/sbin/e-smith/db configuration setprop phpldapadmin access private |
52 |
|
|
|
53 |
|
|
/sbin/e-smith/expand-template /opt/phpldapadmin/config/config.php |
54 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
55 |
|
|
service httpd-e-smith sigusr1 |
56 |
|
|
|
57 |
|
|
|
58 |
|
|
case "${LANG:0:2}" in |
59 |
|
|
fr) |
60 |
|
|
echo "" |
61 |
|
|
echo "Vous pouvez maintenant acceder à phpldapadmin via un browser web de la maniere suivante https://nom_server/phpldapadmin" |
62 |
|
|
echo "Vous pouvez vous connecter avec le login admin et le mot de passe du système" |
63 |
|
|
echo "" |
64 |
|
|
echo "Attention !!!!!" |
65 |
|
|
echo "phpldapadmin est limité en accès au réseau interne, donc pas depuis internet" |
66 |
|
|
echo "Vous pouvez changer cette option avec les commandes :" |
67 |
|
|
echo "db configuration setprop phpldapadmin access public" |
68 |
|
|
echo "signal-events console-save" |
69 |
|
|
echo "" |
70 |
|
|
;; |
71 |
|
|
*) |
72 |
|
|
echo "" |
73 |
|
|
echo "Now you can access phpldapadmin though your browser at https://server_name/phpldapadmin" |
74 |
|
|
echo "You can connect using system admin login and password" |
75 |
|
|
echo "" |
76 |
|
|
echo "BEWARE !!!" |
77 |
|
|
echo "phpldapadmin is now limited to internal network, so it couldn't be access from internet" |
78 |
|
|
echo "You can change this with the following command :" |
79 |
|
|
echo "db configuration setprop phpldapadmin access public" |
80 |
|
|
echo "signal-events console-save" |
81 |
|
|
echo "" |
82 |
|
|
;; |
83 |
|
|
esac |
84 |
|
|
|
85 |
|
|
%postun |
86 |
|
|
/sbin/e-smith/db configuration delete phpldapadmin |
87 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
88 |
|
|
service httpd-e-smith sigusr1 |
89 |
|
|
|
90 |
|
|
%files -f %{name}-%{version}-filelist |
91 |
|
|
%defattr(-,root,root) |