1 |
# $Id: smeserver-phpldapadmin.spec,v 1.2 2008/04/02 15:03:59 slords Exp $ |
2 |
# Authority: nocvs |
3 |
# Name: Michel Van hees |
4 |
|
5 |
Summary: PhpLdapAdmin for SME server |
6 |
%define name smeserver-phpldapadmin |
7 |
Name: %{name} |
8 |
%define version 0.9.8.3 |
9 |
%define release 1 |
10 |
Version: %{version} |
11 |
Release: %{release}%{?dist} |
12 |
License: Freely distributable |
13 |
Group: Apache |
14 |
Source: %{name}-%{version}.tar.gz |
15 |
#Patch0: %{name}-%{version}.patch.yyyymmddnn |
16 |
BuildRoot: /var/tmp/e-smith-buildroot |
17 |
BuildRequires: e-smith-devtools |
18 |
BuildArchitectures: noarch |
19 |
Requires: smeserver-release >= 7 |
20 |
AutoReqProv: no |
21 |
|
22 |
%changelog |
23 |
* Thu Jun 26 2007 Michel Van hees <michel@vanhees.cc> |
24 |
- Restart contrib from scratch |
25 |
- Use of phpldapadmin 0.9.8.3 |
26 |
|
27 |
%description |
28 |
SME server - phpmyadmin multiuser for smeserver |
29 |
|
30 |
%prep |
31 |
%setup |
32 |
#%patch0 -p1 |
33 |
#%patch1 -p1 |
34 |
|
35 |
%build |
36 |
perl createlinks |
37 |
|
38 |
%install |
39 |
rm -rf $RPM_BUILD_ROOT |
40 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
41 |
rm -f %{name}-%{version}-filelist |
42 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
43 |
echo "%doc COPYING" >> %{name}-%{version}-filelist |
44 |
|
45 |
%clean |
46 |
rm -rf $RPM_BUILD_ROOT |
47 |
|
48 |
%pre |
49 |
|
50 |
%preun |
51 |
|
52 |
%post |
53 |
/sbin/e-smith/db configuration set phpldapadmin service |
54 |
/sbin/e-smith/db configuration setprop phpldapadmin access private |
55 |
|
56 |
/sbin/e-smith/expand-template /opt/phpldapadmin/config/config.php |
57 |
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
58 |
service httpd-e-smith sigusr1 |
59 |
|
60 |
|
61 |
case "${LANG:0:2}" in |
62 |
fr) |
63 |
echo "" |
64 |
echo "Vous pouvez maintenant acceder à phpldapadmin via un browser web de la maniere suivante https://nom_server/phpldapadmin" |
65 |
echo "Vous pouvez vous connecter avec le login admin et le mot de passe du système" |
66 |
echo "" |
67 |
echo "Attention !!!!!" |
68 |
echo "phpldapadmin est limité en accès au réseau interne, donc pas depuis internet" |
69 |
echo "Vous pouvez changer cette option avec les commandes :" |
70 |
echo "db configuration setprop phpldapadmin access public" |
71 |
echo "signal-events console-save" |
72 |
echo "" |
73 |
;; |
74 |
*) |
75 |
echo "" |
76 |
echo "Now you can access phpldapadmin though your browser at https://server_name/phpldapadmin" |
77 |
echo "You can connect using system admin login and password" |
78 |
echo "" |
79 |
echo "BEWARE !!!" |
80 |
echo "phpldapadmin is now limited to internal network, so it couldn't be access from internet" |
81 |
echo "You can change this with the following command :" |
82 |
echo "db configuration setprop phpldapadmin access public" |
83 |
echo "signal-events console-save" |
84 |
echo "" |
85 |
;; |
86 |
esac |
87 |
|
88 |
%postun |
89 |
/sbin/e-smith/db configuration delete phpldapadmin |
90 |
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
91 |
service httpd-e-smith sigusr1 |
92 |
|
93 |
%files -f %{name}-%{version}-filelist |
94 |
%defattr(-,root,root) |