1 |
# $Id: smeserver-phpmyadmin.spec,v 1.7 2013/06/20 21:37:12 unnilennium Exp $ |
2 |
# Authority: darrellmay |
3 |
# Name: Darrell May |
4 |
|
5 |
Summary: phpMyAdmin for SME Server |
6 |
%define name smeserver-phpmyadmin |
7 |
Name: %{name} |
8 |
%define version 3.5.2.2 |
9 |
%define release 6 |
10 |
Version: %{version} |
11 |
Release: %{release}%{?dist} |
12 |
License: GPL |
13 |
Group: Mitel/addon |
14 |
Source: %{name}-%{version}.tar.gz |
15 |
Patch0: smeserver-phpmyadmin-3.5.2.2-configext.patch |
16 |
Patch1: smeserver-phpmyadmin-3.5.2.2-patch1.patch |
17 |
URL: http://www.phpmyadmin.net/ |
18 |
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
19 |
BuildArchitectures: noarch |
20 |
Requires: e-smith-base |
21 |
Requires: phpMyAdmin3 >= 3.5.2.2 |
22 |
Obsoletes: phpmyadmin |
23 |
BuildRequires: e-smith-devtools >= 1.13.1-03 |
24 |
Obsoletes: e-smith-phpmyadmin |
25 |
Obsoletes: smeserver-phpmyadmin <= 3.5.2.2-1 |
26 |
Obsoletes: smeserver-phpmyadmin-multiuser |
27 |
|
28 |
%description |
29 |
Implementation of phpMyAdmin for SME Server. |
30 |
Access with admin username/password via: https://yourdomain/phpmyadmin. |
31 |
|
32 |
%changelog |
33 |
* Sat Jun 22 2013 JP Pialasse <tests@pialasse.com> 3.5.2.2-6 |
34 |
- Obsolete multiuser [SME: 7685] |
35 |
|
36 |
* Tue Jun 18 2013 JP Pialasse <tests@pialasse.com> 3.5.2.2-5 |
37 |
- added full 3.5 configuration to avoid errors [SME: 7153] [SME: 7194] |
38 |
- incorporated multiuser contrib in this package [SME: 7628 7627 ] |
39 |
- increased security [SME: 5007] |
40 |
- configext.patch |
41 |
- release bump to 4 to fix spec file |
42 |
- patch1 to fix config.inc.php syntax error |
43 |
|
44 |
* Thu Aug 06 2012 JP Pialasse aka Unnilennium <tests@pialasse.com> 3.5.2.2-2 |
45 |
- first version for SME 8 |
46 |
- adaptation for phpMyAdmin3 3.5.2.2 |
47 |
|
48 |
* Thu May 15 2008 Jonathan Martens <smeserver-contribs@snetram.nl> 2.11.1.2-3 |
49 |
- Protect sensible data and prevent access error by setting |
50 |
proper permissions to config.inc.php template [SME: 4343] |
51 |
|
52 |
* Wed May 14 2008 Jonathan Martens <smeserver-contribs@snetram.nl> |
53 |
- Converted RPM to be an integrational RPM [SME: 4298]: |
54 |
- Convert and move templates to RPMForge (Dag) install location [SME: 4339] |
55 |
- Automatically expand phpmyadmin configuation file (config.php.inc) [SME: 4340] |
56 |
- Remove PHPMyAdmin core [SME: 4341] |
57 |
|
58 |
* Mon Apr 21 2008 Shad L. Lords <slords@mail.com> |
59 |
- Prep for import into buildsys |
60 |
- Clean up spec |
61 |
|
62 |
* Fri Oct 19 2007 Darrell May <dmay@myezserver.com> |
63 |
- accounts and configuration db phpmyadmin defaults added |
64 |
- default access restricted to private (private|public) |
65 |
- phpMyAdmin 2.11.1.2 |
66 |
- [ 2.11.1.2-0] |
67 |
* Fri Mar 09 2007 Darrell May <dmay@myezserver.com> |
68 |
- phpMyAdmin 2.10.0.2 |
69 |
- [ 2.10.0.2-0] |
70 |
* Thu Oct 12 2006 Darrell May <dmay@myezserver.com> |
71 |
- phpMyAdmin 2.9.0.2 |
72 |
- [ 2.9.0.2-0] |
73 |
* Thu Dec 15 2005 Darrell May <dmay@myezserver.com> |
74 |
- phpMyAdmin 2.6.4-pl4 |
75 |
- [ 2.6.4-pl4] |
76 |
* Fri Apr 22 2005 Darrell May <dmay@myezserver.com> |
77 |
- added support for SME 7.x |
78 |
- [ 2.6.2-2] |
79 |
* Mon Apr 18 2005 Darrell May <dmay@myezserver.com> |
80 |
- Release 2.6.2 of phpMyAdmin |
81 |
- change rpm name to smeserver-phpmyadmin |
82 |
- change install dir to /opt/phpmyadmin |
83 |
- [ 2.6.2-1] |
84 |
|
85 |
%prep |
86 |
%setup |
87 |
%patch0 -p1 |
88 |
%patch1 -p1 |
89 |
#%patch2 -p1 |
90 |
|
91 |
%build |
92 |
perl createlinks |
93 |
|
94 |
%install |
95 |
/bin/rm -rf $RPM_BUILD_ROOT |
96 |
(cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
97 |
/bin/rm -f %{name}-%{version}-filelist |
98 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
99 |
|
100 |
%files -f %{name}-%{version}-filelist |
101 |
%defattr(-,root,root) |
102 |
|
103 |
%clean |
104 |
rm -rf $RPM_BUILD_ROOT |
105 |
|