1 |
jpp |
1.1 |
%define name smeserver-phpvirtualbox |
2 |
|
|
%define version 5.0.0 |
3 |
|
|
%define release 1 |
4 |
|
|
%define rpmver 5.0.0 |
5 |
|
|
Summary: smserver rpm to install phpvirtualbox |
6 |
|
|
Name: %{name} |
7 |
|
|
Version: %{version} |
8 |
|
|
Release: %{release}%{?dist} |
9 |
|
|
Source: %{name}-%{version}.tar.gz |
10 |
|
|
License: GNU GPL version 2 |
11 |
|
|
URL: http://mirror.de-labrusse.fr |
12 |
|
|
Group: SMEserver/addon |
13 |
|
|
BuildRoot: %{_tmppath}/%{name}-buildroot |
14 |
|
|
Prefix: %{_prefix} |
15 |
|
|
#Patch0: smeserver-phpvirtualbox-force-https.patch |
16 |
|
|
#Patch1: smeserver-phpvirtualbox-unix-group.patch |
17 |
|
|
#Patch2: smeserver-phpvirtualbox-4.3.0-remove-webauth.patch |
18 |
|
|
#Patch3: smeserver-phpvirtualbox-4.3.0-add_webauth_migrate_fragment.patch |
19 |
|
|
BuildArchitectures: noarch |
20 |
|
|
BuildRequires: e-smith-devtools |
21 |
|
|
Requires: e-smith-release >= 8.0 |
22 |
|
|
Requires: php-soap |
23 |
|
|
Requires: phpvirtualbox-5.0 |
24 |
|
|
|
25 |
|
|
AutoReqProv: no |
26 |
|
|
%description |
27 |
|
|
smserver rpm to install phpvirtualbox : An open source, AJAX implementation of the VirtualBox user interface written in PHP. As a |
28 |
|
|
modern web interface, it allows you to access and control remote VirtualBox instances. phpVirtualBox is designed to allow users to |
29 |
|
|
administer VirtualBox in a headless environment - mirroring the VirtualBox GUI through its web interface. |
30 |
|
|
|
31 |
|
|
%changelog |
32 |
|
|
* Thu Aug 06 2015 stephane de labrusse <stephdl@de-labrusse.fr> 5.0.0-1 |
33 |
|
|
- require to phpvirtualbox-5.0 |
34 |
|
|
|
35 |
|
|
* Sun May 18 2014 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.1-3 |
36 |
|
|
- first release to sme9 |
37 |
|
|
- unixgroup removed from the contribs |
38 |
|
|
- fix ssl redirection |
39 |
|
|
|
40 |
|
|
* Wed Mar 19 2014 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.1-1 |
41 |
|
|
- due to the bug correction of phpvirtualbox, this version give back the web authentication with migrate fragment update |
42 |
|
|
* Wed Jan 08 2014 JP Pialasse <tests@pialasse.com> 4.3.0-10.sme |
43 |
|
|
- changing requires to phpvirtualbox = 4.3 |
44 |
|
|
* Mon Dec 30 2013 JP Pialasse <tests@pialasse.com> 4.3.0-9.sme |
45 |
|
|
- renaming to import into buildsys |
46 |
|
|
* Fri Dec 13 2013 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.0-8 |
47 |
|
|
- remove the web authentication for the buildin phpvirtualbox authentication |
48 |
|
|
* Sun Nov 10 2013 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.0-7 |
49 |
|
|
- removing dependance to smeserver-virtualbox-4.3 |
50 |
|
|
* Tue Nov 05 2013 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.0-6 |
51 |
|
|
- change name to match the phpvirtualbox version |
52 |
|
|
* Wed Oct 23 2013 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.0-5 |
53 |
|
|
- Clean 92phpvirtualbox to force only the localnetwork |
54 |
|
|
- Add the plugin unixgroup (from pwauth) to allow unix groups to reach the apache server. |
55 |
|
|
- you can see http://code.google.com/p/pwauth/ for more informations |
56 |
|
|
* Sun Oct 20 2013 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.0-4 |
57 |
|
|
- Force https protocol for phpvirtualbox |
58 |
|
|
* Sat Oct 19 2013 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.0-3 |
59 |
|
|
- Initial release |
60 |
|
|
|
61 |
|
|
%prep |
62 |
|
|
%setup |
63 |
|
|
#%patch0 -p1 |
64 |
|
|
#%patch1 -p1 |
65 |
|
|
#%patch2 -p1 |
66 |
|
|
#%patch3 -p1 |
67 |
|
|
%build |
68 |
|
|
#perl createlinks |
69 |
|
|
|
70 |
|
|
%install |
71 |
|
|
rm -rf $RPM_BUILD_ROOT |
72 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
73 |
|
|
rm -f %{name}-%{version}-filelist |
74 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
75 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
76 |
|
|
|
77 |
|
|
%clean |
78 |
|
|
cd .. |
79 |
|
|
rm -rf %{name}-%{version} |
80 |
|
|
|
81 |
|
|
%pre |
82 |
|
|
|
83 |
|
|
%preun |
84 |
|
|
|
85 |
|
|
%post |
86 |
|
|
|
87 |
|
|
echo "==============================================================" |
88 |
|
|
echo " Please do not forget to install the extension pack " |
89 |
|
|
echo " You need it to activate the virtualbox RDP server" |
90 |
|
|
echo " And many features, see this page to manage it by CL" |
91 |
|
|
echo " " |
92 |
|
|
echo " https://www.virtualbox.org/manual/ch08.html#vboxmanage-extpack" |
93 |
|
|
echo " " |
94 |
|
|
echo " The download page : https://www.virtualbox.org/wiki/Downloads" |
95 |
|
|
echo "==============================================================" |
96 |
|
|
|
97 |
|
|
|
98 |
|
|
%postun |
99 |
|
|
#uninstall |
100 |
|
|
if [ $1 = 0 ] ; then |
101 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
102 |
|
|
/usr/local/bin/svc -h /service/httpd-e-smith |
103 |
|
|
fi |
104 |
|
|
%files -f %{name}-%{version}-filelist |
105 |
|
|
%defattr(-,root,root) |
106 |
|
|
|