1 |
jpp |
1.1 |
%define name smeserver-phpvirtualbox |
2 |
trevorb |
1.2 |
%define version 5.2.1 |
3 |
jpp |
1.1 |
%define release 1 |
4 |
trevorb |
1.2 |
%define rpmver 5.2.1 |
5 |
jpp |
1.1 |
Summary: smserver rpm to install phpvirtualbox |
6 |
|
|
Name: %{name} |
7 |
|
|
Version: %{version} |
8 |
|
|
Release: %{release}%{?dist} |
9 |
|
|
Source: %{name}-%{version}.tar.gz |
10 |
|
|
License: GNU GPL version 2 |
11 |
|
|
URL: http://mirror.de-labrusse.fr |
12 |
|
|
Group: SMEserver/addon |
13 |
|
|
BuildRoot: %{_tmppath}/%{name}-buildroot |
14 |
|
|
Prefix: %{_prefix} |
15 |
|
|
BuildArchitectures: noarch |
16 |
|
|
BuildRequires: e-smith-devtools |
17 |
trevorb |
1.2 |
Requires: e-smith-release >= 10.0 |
18 |
jpp |
1.1 |
Requires: php-soap |
19 |
trevorb |
1.2 |
Requires: phpvirtualbox = 5.2.1 |
20 |
|
|
Requires: smeserver-virtualbox = 5.2 |
21 |
jpp |
1.1 |
|
22 |
|
|
AutoReqProv: no |
23 |
|
|
%description |
24 |
|
|
smserver rpm to install phpvirtualbox : An open source, AJAX implementation of the VirtualBox user interface written in PHP. As a |
25 |
|
|
modern web interface, it allows you to access and control remote VirtualBox instances. phpVirtualBox is designed to allow users to |
26 |
|
|
administer VirtualBox in a headless environment - mirroring the VirtualBox GUI through its web interface. |
27 |
trevorb |
1.2 |
phpvirtualbox version MUST align with VirtualBox version (i.e. VirtualBox-6.1 requires phpvirtualbox-6.1) |
28 |
jpp |
1.1 |
|
29 |
|
|
%changelog |
30 |
trevorb |
1.2 |
* Tue Oct 11 2022 Trevor Batley <trevor@batley.id.au> 5.2-1 |
31 |
|
|
- Initial import to sme10 |
32 |
|
|
- requires phpvirtualbox 5.2.1, smeserver-virtualbox 5.2 |
33 |
|
|
- upgrade to httpd 2.4 |
34 |
|
|
- use php74-php-fpm |
35 |
|
|
- bundle up patches and release new tarball |
36 |
|
|
|
37 |
jpp |
1.1 |
* Thu Aug 06 2015 stephane de labrusse <stephdl@de-labrusse.fr> 5.0.0-1 |
38 |
|
|
- require to phpvirtualbox-5.0 |
39 |
|
|
|
40 |
|
|
* Sun May 18 2014 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.1-3 |
41 |
|
|
- first release to sme9 |
42 |
|
|
- unixgroup removed from the contribs |
43 |
|
|
- fix ssl redirection |
44 |
|
|
|
45 |
|
|
* Wed Mar 19 2014 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.1-1 |
46 |
|
|
- due to the bug correction of phpvirtualbox, this version give back the web authentication with migrate fragment update |
47 |
|
|
* Wed Jan 08 2014 JP Pialasse <tests@pialasse.com> 4.3.0-10.sme |
48 |
|
|
- changing requires to phpvirtualbox = 4.3 |
49 |
|
|
* Mon Dec 30 2013 JP Pialasse <tests@pialasse.com> 4.3.0-9.sme |
50 |
|
|
- renaming to import into buildsys |
51 |
|
|
* Fri Dec 13 2013 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.0-8 |
52 |
|
|
- remove the web authentication for the buildin phpvirtualbox authentication |
53 |
|
|
* Sun Nov 10 2013 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.0-7 |
54 |
|
|
- removing dependance to smeserver-virtualbox-4.3 |
55 |
|
|
* Tue Nov 05 2013 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.0-6 |
56 |
|
|
- change name to match the phpvirtualbox version |
57 |
|
|
* Wed Oct 23 2013 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.0-5 |
58 |
|
|
- Clean 92phpvirtualbox to force only the localnetwork |
59 |
|
|
- Add the plugin unixgroup (from pwauth) to allow unix groups to reach the apache server. |
60 |
|
|
- you can see http://code.google.com/p/pwauth/ for more informations |
61 |
|
|
* Sun Oct 20 2013 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.0-4 |
62 |
|
|
- Force https protocol for phpvirtualbox |
63 |
|
|
* Sat Oct 19 2013 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.0-3 |
64 |
|
|
- Initial release |
65 |
|
|
|
66 |
|
|
%prep |
67 |
|
|
%setup |
68 |
|
|
%build |
69 |
trevorb |
1.2 |
perl createlinks |
70 |
jpp |
1.1 |
|
71 |
|
|
%install |
72 |
|
|
rm -rf $RPM_BUILD_ROOT |
73 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
74 |
|
|
rm -f %{name}-%{version}-filelist |
75 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
76 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
77 |
|
|
|
78 |
|
|
%clean |
79 |
|
|
cd .. |
80 |
|
|
rm -rf %{name}-%{version} |
81 |
|
|
|
82 |
|
|
%pre |
83 |
|
|
|
84 |
|
|
%preun |
85 |
|
|
|
86 |
|
|
%post |
87 |
|
|
|
88 |
|
|
echo "==============================================================" |
89 |
|
|
echo " Please do not forget to install the extension pack " |
90 |
|
|
echo " You need it to activate the virtualbox RDP server" |
91 |
|
|
echo " And many features, see this page to manage it by CL" |
92 |
|
|
echo " " |
93 |
|
|
echo " https://www.virtualbox.org/manual/ch08.html#vboxmanage-extpack" |
94 |
|
|
echo " " |
95 |
|
|
echo " The download page : https://www.virtualbox.org/wiki/Downloads" |
96 |
|
|
echo "==============================================================" |
97 |
|
|
|
98 |
|
|
|
99 |
|
|
%postun |
100 |
|
|
#uninstall |
101 |
|
|
if [ $1 = 0 ] ; then |
102 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
103 |
trevorb |
1.2 |
/sbin/e-smith/systemctl restart httpd-e-smith |
104 |
jpp |
1.1 |
fi |
105 |
|
|
%files -f %{name}-%{version}-filelist |
106 |
|
|
%defattr(-,root,root) |
107 |
|
|
|