/[smecontribs]/rpms/smeserver-phpvirtualbox/contribs10/smeserver-phpvirtualbox.spec
ViewVC logotype

Annotation of /rpms/smeserver-phpvirtualbox/contribs10/smeserver-phpvirtualbox.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.3 - (hide annotations) (download)
Wed Oct 19 02:13:57 2022 UTC (19 months, 2 weeks ago) by trevorb
Branch: MAIN
CVS Tags: smeserver-phpvirtualbox-5_2_1-2_el7_sme
Changes since 1.2: +7 -2 lines
move vbox dir

1 jpp 1.1 %define name smeserver-phpvirtualbox
2 trevorb 1.2 %define version 5.2.1
3 trevorb 1.3 %define release 2
4 trevorb 1.2 %define rpmver 5.2.1
5 jpp 1.1 Summary: smserver rpm to install phpvirtualbox
6     Name: %{name}
7     Version: %{version}
8     Release: %{release}%{?dist}
9     Source: %{name}-%{version}.tar.gz
10     License: GNU GPL version 2
11     URL: http://mirror.de-labrusse.fr
12     Group: SMEserver/addon
13     BuildRoot: %{_tmppath}/%{name}-buildroot
14     Prefix: %{_prefix}
15     BuildArchitectures: noarch
16     BuildRequires: e-smith-devtools
17 trevorb 1.2 Requires: e-smith-release >= 10.0
18 jpp 1.1 Requires: php-soap
19 trevorb 1.2 Requires: phpvirtualbox = 5.2.1
20     Requires: smeserver-virtualbox = 5.2
21 trevorb 1.3 Patch0: smeserver-phpvirtualbox-5.2.1-move_vbox_dir.patch
22 jpp 1.1
23     AutoReqProv: no
24     %description
25     smserver rpm to install phpvirtualbox : An open source, AJAX implementation of the VirtualBox user interface written in PHP. As a
26     modern web interface, it allows you to access and control remote VirtualBox instances. phpVirtualBox is designed to allow users to
27     administer VirtualBox in a headless environment - mirroring the VirtualBox GUI through its web interface.
28 trevorb 1.2 phpvirtualbox version MUST align with VirtualBox version (i.e. VirtualBox-6.1 requires phpvirtualbox-6.1)
29 jpp 1.1
30     %changelog
31 trevorb 1.3 * Wed Oct 19 2022 Trevor Batley <trevor@batley.id.au> 5.2.1-2
32     - vbox user home directory moved
33    
34     * Tue Oct 11 2022 Trevor Batley <trevor@batley.id.au> 5.2.1-1
35 trevorb 1.2 - Initial import to sme10
36     - requires phpvirtualbox 5.2.1, smeserver-virtualbox 5.2
37     - upgrade to httpd 2.4
38     - use php74-php-fpm
39     - bundle up patches and release new tarball
40    
41 jpp 1.1 * Thu Aug 06 2015 stephane de labrusse <stephdl@de-labrusse.fr> 5.0.0-1
42     - require to phpvirtualbox-5.0
43    
44     * Sun May 18 2014 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.1-3
45     - first release to sme9
46     - unixgroup removed from the contribs
47     - fix ssl redirection
48    
49     * Wed Mar 19 2014 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.1-1
50     - due to the bug correction of phpvirtualbox, this version give back the web authentication with migrate fragment update
51     * Wed Jan 08 2014 JP Pialasse <tests@pialasse.com> 4.3.0-10.sme
52     - changing requires to phpvirtualbox = 4.3
53     * Mon Dec 30 2013 JP Pialasse <tests@pialasse.com> 4.3.0-9.sme
54     - renaming to import into buildsys
55     * Fri Dec 13 2013 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.0-8
56     - remove the web authentication for the buildin phpvirtualbox authentication
57     * Sun Nov 10 2013 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.0-7
58     - removing dependance to smeserver-virtualbox-4.3
59     * Tue Nov 05 2013 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.0-6
60     - change name to match the phpvirtualbox version
61     * Wed Oct 23 2013 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.0-5
62     - Clean 92phpvirtualbox to force only the localnetwork
63     - Add the plugin unixgroup (from pwauth) to allow unix groups to reach the apache server.
64     - you can see http://code.google.com/p/pwauth/ for more informations
65     * Sun Oct 20 2013 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.0-4
66     - Force https protocol for phpvirtualbox
67     * Sat Oct 19 2013 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.0-3
68     - Initial release
69    
70     %prep
71     %setup
72 trevorb 1.3 %patch0 -p1
73 jpp 1.1 %build
74 trevorb 1.2 perl createlinks
75 jpp 1.1
76     %install
77     rm -rf $RPM_BUILD_ROOT
78     (cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
79     rm -f %{name}-%{version}-filelist
80     /sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist
81     echo "%doc COPYING" >> %{name}-%{version}-filelist
82    
83     %clean
84     cd ..
85     rm -rf %{name}-%{version}
86    
87     %pre
88    
89     %preun
90    
91     %post
92    
93     echo "=============================================================="
94     echo " Please do not forget to install the extension pack "
95     echo " You need it to activate the virtualbox RDP server"
96     echo " And many features, see this page to manage it by CL"
97     echo " "
98     echo " https://www.virtualbox.org/manual/ch08.html#vboxmanage-extpack"
99     echo " "
100     echo " The download page : https://www.virtualbox.org/wiki/Downloads"
101     echo "=============================================================="
102    
103    
104     %postun
105     #uninstall
106     if [ $1 = 0 ] ; then
107     /sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf
108 trevorb 1.2 /sbin/e-smith/systemctl restart httpd-e-smith
109 jpp 1.1 fi
110     %files -f %{name}-%{version}-filelist
111     %defattr(-,root,root)
112    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed