1 |
unnilennium |
1.1 |
%define name smeserver-phpvirtualbox |
2 |
|
|
%define version 4.3.0 |
3 |
unnilennium |
1.2 |
%define release 10 |
4 |
unnilennium |
1.1 |
%define rpmver 4.3.0 |
5 |
|
|
Summary: smserver rpm to install phpvirtualbox |
6 |
|
|
Name: %{name} |
7 |
|
|
Version: %{version} |
8 |
|
|
Release: %{release}%{?dist} |
9 |
|
|
Source: %{name}-%{version}.tar.gz |
10 |
|
|
License: GNU GPL version 2 |
11 |
|
|
URL: http://mirror.de-labrusse.fr |
12 |
|
|
Group: SMEserver/addon |
13 |
|
|
BuildRoot: %{_tmppath}/%{name}-buildroot |
14 |
|
|
Prefix: %{_prefix} |
15 |
|
|
BuildArchitectures: noarch |
16 |
|
|
BuildRequires: e-smith-devtools |
17 |
|
|
Requires: e-smith-release >= 8.0 |
18 |
|
|
Requires: php-soap |
19 |
unnilennium |
1.2 |
Requires: phpvirtualbox >= 4.3.0 |
20 |
|
|
Requires: phpvirtualbox < 4.4 |
21 |
unnilennium |
1.1 |
|
22 |
|
|
AutoReqProv: no |
23 |
|
|
Patch0: smeserver-phpvirtualbox-force-https.patch |
24 |
|
|
Patch1: smeserver-phpvirtualbox-unix-group.patch |
25 |
|
|
Patch2: smeserver-phpvirtualbox-4.3.0-remove-webauth.patch |
26 |
|
|
%description |
27 |
|
|
smserver rpm to install phpvirtualbox : An open source, AJAX implementation of the VirtualBox user interface written in PHP. As a |
28 |
|
|
modern web interface, it allows you to access and control remote VirtualBox instances. phpVirtualBox is designed to allow users to |
29 |
|
|
administer VirtualBox in a headless environment - mirroring the VirtualBox GUI through its web interface. |
30 |
|
|
|
31 |
|
|
%changelog |
32 |
unnilennium |
1.2 |
* Wed Jan 08 2014 JP Pialasse <tests@pialasse.com> 4.3.0-10.sme |
33 |
|
|
- changing requires to phpvirtualbox = 4.3 |
34 |
unnilennium |
1.1 |
* Mon Dec 30 2013 JP Pialasse <tests@pialasse.com> 4.3.0-9.sme |
35 |
unnilennium |
1.2 |
- renaming to import into buildsys |
36 |
unnilennium |
1.1 |
* Fri Dec 13 2013 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.8 |
37 |
|
|
- remove the web authentication for the buildin phpvirtualbox authentication |
38 |
|
|
* Sun Nov 10 2013 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.7 |
39 |
|
|
- removing dependance to smeserver-virtualbox-4.3 |
40 |
|
|
* Tue Nov 05 2013 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.6 |
41 |
|
|
- change name to match the phpvirtualbox version |
42 |
|
|
* Wed Oct 23 2013 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.5 |
43 |
|
|
- Clean 92phpvirtualbox to force only the localnetwork |
44 |
|
|
- Add the plugin unixgroup (from pwauth) to allow unix groups to reach the apache server. |
45 |
|
|
- you can see http://code.google.com/p/pwauth/ for more informations |
46 |
|
|
* Sun Oct 20 2013 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.4 |
47 |
|
|
- Force https protocol for phpvirtualbox |
48 |
|
|
* Sat Oct 19 2013 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.3 |
49 |
|
|
- Initial release |
50 |
|
|
|
51 |
|
|
%prep |
52 |
|
|
%setup |
53 |
|
|
%patch0 -p1 |
54 |
|
|
%patch1 -p1 |
55 |
|
|
%patch2 -p1 |
56 |
|
|
%build |
57 |
|
|
#perl createlinks |
58 |
|
|
|
59 |
|
|
%install |
60 |
|
|
rm -rf $RPM_BUILD_ROOT |
61 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
62 |
|
|
rm -f %{name}-%{version}-filelist |
63 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
64 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
65 |
|
|
|
66 |
|
|
%clean |
67 |
|
|
cd .. |
68 |
|
|
rm -rf %{name}-%{version} |
69 |
|
|
|
70 |
|
|
%pre |
71 |
|
|
|
72 |
|
|
%preun |
73 |
|
|
|
74 |
|
|
%post |
75 |
|
|
/bin/chmod 750 /usr/lib/httpd/modules/unixgroup |
76 |
|
|
/bin/chown root:www /usr/lib/httpd/modules/unixgroup |
77 |
|
|
|
78 |
|
|
echo "==============================================================" |
79 |
|
|
echo " Please do not forget to install the extension pack " |
80 |
|
|
echo " You need it to activate the virtualbox RDP server" |
81 |
|
|
echo " And many features, see this page to manage it by CL" |
82 |
|
|
echo " " |
83 |
|
|
echo " https://www.virtualbox.org/manual/ch08.html#vboxmanage-extpack" |
84 |
|
|
echo " " |
85 |
|
|
echo " The download page : https://www.virtualbox.org/wiki/Downloads" |
86 |
|
|
echo "==============================================================" |
87 |
|
|
|
88 |
|
|
|
89 |
|
|
%postun |
90 |
|
|
#uninstall |
91 |
|
|
if [ $1 = 0 ] ; then |
92 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
93 |
|
|
/usr/local/bin/svc -h /service/httpd-e-smith |
94 |
|
|
fi |
95 |
|
|
%files -f %{name}-%{version}-filelist |
96 |
|
|
%defattr(-,root,root) |
97 |
|
|
|