1 |
# $Id: smeserver-phpwebftp-4.0.spec,v 1.2 2016/08/03 06:09:25 unnilennium Exp $ |
2 |
# Authority: gnujpl |
3 |
# Name: Jean-Paul Leclère |
4 |
|
5 |
%define name smeserver-phpwebftp |
6 |
%define version 4.0 |
7 |
%define release 11 |
8 |
|
9 |
Summary: Web FTP access via HTTPS for SME. |
10 |
Name: %{name} |
11 |
Version: %{version} |
12 |
Release: %{release}%{?dist} |
13 |
License: GPL |
14 |
Group: Applications/WebFTP |
15 |
Source: %{name}-%{version}.tar.gz |
16 |
Patch0:smeserver-phpwebftp-4.0-patchftpmode.patch |
17 |
Patch1: smeserver-phpwebftp-4.0-patch1.patch |
18 |
Patch2: smeserver-phpwebftp-4.0.bz7175.pointusername.patch |
19 |
Patch3: smeserver-phpwebftp-4.0.bz9528.XSSvulnerability.patch |
20 |
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
21 |
BuildArchitectures: noarch |
22 |
Requires: e-smith-apache |
23 |
BuildRequires: e-smith-devtools |
24 |
Obsoletes: eos-webftp |
25 |
AutoReqProv: no |
26 |
|
27 |
%description |
28 |
smeserver-phpwebftp adds an ftp panel available to users via SSL web access. |
29 |
|
30 |
%changelog |
31 |
* Wed Aug 03 2016 Jean-Philipe Pialasse <tests@pialasse.com> 4.0-11.sme |
32 |
- fix XSS security issue in phpwebftp [SME: 9528] |
33 |
- https://sourceforge.net/p/phpwebftp/bugs/17/ |
34 |
- add utf8 in meta to fix bad display in French |
35 |
|
36 |
* Wed Aug 03 2016 Jean-Philipe Pialasse <tests@pialasse.com> 4.0-10.sme |
37 |
- fix does not support files owned by user or group with point [SME: 7175] |
38 |
- SF:https://sourceforge.net/p/phpwebftp/bugs/15/ |
39 |
|
40 |
* Wed Aug 03 2016 Jean-Philipe Pialasse <tests@pialasse.com> 4.0-9.sme |
41 |
- initial import to SME9 |
42 |
|
43 |
* Sun Nov 24 2013 JP Pialasse <tests@pialasse.com> 4.0-8.sme |
44 |
- new patch for [SME: 7973] |
45 |
- tmp folder set to 0770 to fix the download error |
46 |
|
47 |
* Mon Nov 4 2013 JP Pialasse <tests@pialasse.com> 4.0-6.sme |
48 |
- wrong binary ascii switch [SME: 7973] |
49 |
|
50 |
* Sun Mar 3 2013 JP Pialasse <tests@pialasse.com> 4.0-5 |
51 |
- import into sme 8 tree |
52 |
|
53 |
* Sun Jun 8 2008 Jean-Paul Leclere <jean-paul@lleclere.org> |
54 |
- [4.0-4] |
55 |
- remove pyo and pyc files in files list |
56 |
|
57 |
* Sat Jun 7 2008 Jean-Paul Leclere <jean-paul@lleclere.org> |
58 |
- [4.0-3] |
59 |
- correct /home/httpd/html/webftp/tmp owner in spec file |
60 |
|
61 |
* Sat May 4 2008 Jean-Paul Leclere <jean-paul@lleclere.org> |
62 |
- [4.0-2] |
63 |
- Bump Copyright to License in spec |
64 |
|
65 |
* Thu May 1 2008 Jean-Paul Leclere <jean-paul@lleclere.org> |
66 |
- [4.0-1] |
67 |
- Bump to smeserver-phpwebftp for SME 7.3 |
68 |
- upgrade phpwebftp to 4.0 |
69 |
|
70 |
* Sat May 21 2005 Jean-Paul Leclere <jean-paul@lleclere.org> |
71 |
- [2.7-4] |
72 |
- Correctif sur position Virtualhost pour utilisation directive Global |
73 |
|
74 |
* Sun Apr 17 2005 Jean-Paul Leclere <jean-paul@lleclere.org> |
75 |
- [2.7-3] |
76 |
- Correctif sur directive SSLRequireSSL |
77 |
|
78 |
* Sun Jan 23 2005 Jean-Paul Leclere <jean-paul@lleclere.org> |
79 |
- [2.7-2] |
80 |
- Correct tmp directory rights |
81 |
- add ForceFTPVirtualLocalhost for FTP even if TLS |
82 |
|
83 |
* Sun Jan 9 2005 Jean-Paul Leclere <jean-paul@lleclere.org> |
84 |
- [2.7-1] |
85 |
- Initial release |
86 |
|
87 |
|
88 |
%prep |
89 |
%setup |
90 |
|
91 |
%patch0 -p1 |
92 |
%patch1 -p1 |
93 |
%patch2 -p1 |
94 |
%patch3 -p1 |
95 |
|
96 |
%pre |
97 |
|
98 |
%post |
99 |
|
100 |
%build |
101 |
./createlinks |
102 |
|
103 |
%install |
104 |
rm -rf $RPM_BUILD_ROOT |
105 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
106 |
rm -f e-smith-%{version}-filelist |
107 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
108 |
--dir '/home/httpd/html/webftp/tmp' 'attr(0770,www,www)' \ |
109 |
> %{name}-%{version}-filelist |
110 |
|
111 |
/usr/lib/rpm/brp-python-bytecompile |
112 |
%preun |
113 |
|
114 |
%postun |
115 |
|
116 |
%clean |
117 |
rm -rf $RPM_BUILD_ROOT |
118 |
|
119 |
%files -f %{name}-%{version}-filelist |
120 |
|
121 |
%defattr(-,root,www) |