1 |
unnilennium |
1.2 |
# $Id: smeserver-popfile.spec,v 1.1 2013/03/03 21:50:54 unnilennium Exp $ |
2 |
unnilennium |
1.1 |
# Authority: cool34000 |
3 |
|
|
# Name: Sylvain Gomez |
4 |
|
|
|
5 |
|
|
%define name smeserver-popfile |
6 |
|
|
%define version 0.21.2 |
7 |
unnilennium |
1.2 |
%define release 2 |
8 |
unnilennium |
1.1 |
%define rpmver 4.0.4 |
9 |
|
|
|
10 |
|
|
Summary: POPFile is a POP3 proxy |
11 |
|
|
Name: %{name} |
12 |
|
|
Version: %{version} |
13 |
|
|
Release: %{release}%{?dist} |
14 |
|
|
License: GPL |
15 |
|
|
Group: Mail/Classification |
16 |
|
|
Source: %{name}-%{version}.tar.gz |
17 |
|
|
URL: http://popfile.sourceforge.net/ |
18 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
19 |
|
|
BuildArchitectures: noarch |
20 |
|
|
BuildRequires: e-smith-devtools |
21 |
|
|
Requires: e-smith-base, e-smith-release >= 7, perl-DBD-SQLite >= 1.13-1 |
22 |
|
|
|
23 |
|
|
%description |
24 |
|
|
This RPM is an unofficial addon for the SME Server 7.x. |
25 |
|
|
The target audience is the Linux/E-smith administrator |
26 |
|
|
who wants to add a POP3 Proxy to filter and classify mails. |
27 |
|
|
After installation open your webbrowser at |
28 |
|
|
http://your_e-smith-server_adress:7676 |
29 |
|
|
|
30 |
|
|
|
31 |
|
|
|
32 |
|
|
%changelog |
33 |
unnilennium |
1.2 |
* Thu Jun 27 2013 JP Pialasse <tests@pialasse.com> 0.21.2-2.sme |
34 |
|
|
- fix unreachable when updating |
35 |
|
|
|
36 |
unnilennium |
1.1 |
* Mon Jun 5 2007 Sylvain Gomez <sylvaingomez@free.fr> |
37 |
|
|
- 0.21.2-1 |
38 |
|
|
- Original version |
39 |
|
|
|
40 |
|
|
%prep |
41 |
|
|
rm -rf $RPM_BUILD_ROOT |
42 |
|
|
|
43 |
|
|
%setup |
44 |
|
|
|
45 |
|
|
%build |
46 |
|
|
|
47 |
|
|
%install |
48 |
|
|
/bin/rm -rf $RPM_BUILD_ROOT |
49 |
|
|
(/usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
50 |
|
|
/bin/rm -f %{name}-%{version}-filelist |
51 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
52 |
|
|
|
53 |
|
|
%files -f %{name}-%{version}-filelist |
54 |
|
|
|
55 |
|
|
%defattr(-,root,root) |
56 |
|
|
|
57 |
|
|
%clean |
58 |
|
|
rm -rf $RPM_BUILD_ROOT |
59 |
|
|
|
60 |
|
|
%pre |
61 |
|
|
|
62 |
|
|
%post |
63 |
|
|
# Variables |
64 |
|
|
SRVNAME=$(/sbin/e-smith/db configuration get SystemName) |
65 |
|
|
|
66 |
|
|
# Creating and starting service |
67 |
|
|
ln -f -s /etc/rc.d/init.d/e-smith-service /etc/rc7.d/S98popfile |
68 |
|
|
/sbin/e-smith/db configuration set popfile service status enabled |
69 |
|
|
/sbin/e-smith/signal-event remoteaccess-update |
70 |
|
|
service popfile start |
71 |
|
|
|
72 |
|
|
echo " " |
73 |
|
|
echo "-------------------------------------------------------------------------------" |
74 |
|
|
echo "POPFile Installation finished." |
75 |
|
|
echo "Please go to http://$SRVNAME:7676 and protect access with a password!" |
76 |
|
|
echo " " |
77 |
|
|
echo "To use POPFile, you must configure your mail clients to use the new POP3 proxy." |
78 |
|
|
echo "Configuration to be modified is:" |
79 |
|
|
echo " - POP3 server: $SRVNAME" |
80 |
|
|
echo " - Login : $SRVNAME:your-sme-login" |
81 |
|
|
echo " - POP3 Port : 1100" |
82 |
|
|
echo "-------------------------------------------------------------------------------" |
83 |
|
|
|
84 |
|
|
%preun |
85 |
|
|
# Deleting and unregistering service |
86 |
unnilennium |
1.2 |
if [ $1 = 0 ] ; then |
87 |
unnilennium |
1.1 |
service popfile stop |
88 |
|
|
sleep 3 |
89 |
|
|
rm -f /etc/rc7.d/S98popfile |
90 |
|
|
rm -f /etc/rc.d/init.d/popfile |
91 |
|
|
/sbin/e-smith/config delete popfile |
92 |
|
|
/sbin/e-smith/signal-event remoteaccess-update |
93 |
|
|
|
94 |
|
|
# Removing install directory |
95 |
|
|
rm -rf /opt/popfile |
96 |
unnilennium |
1.2 |
fi |
97 |
unnilennium |
1.1 |
|
98 |
|
|
%postun |