1 |
michel |
1.1 |
Summary: e-smith specific postgresql configuration and templates. |
2 |
|
|
%define name smeserver-postgresql |
3 |
|
|
Name: %{name} |
4 |
|
|
%define version 0.2.0 |
5 |
|
|
%define pg_ver 13 |
6 |
|
|
%define release 1 |
7 |
|
|
Version: %{version} |
8 |
|
|
Release: %{release}%{?dist} |
9 |
|
|
License: GPL |
10 |
|
|
Group: Networking/Daemons |
11 |
|
|
Source: %{name}-%{version}.tar.gz |
12 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
13 |
|
|
BuildArch: noarch |
14 |
|
|
BuildRequires: e-smith-devtools >= 2.6.0-10 |
15 |
|
|
Requires: e-smith-base >= 5.8.1 |
16 |
|
|
Requires: e-smith-lib >= 2.6.0-14 |
17 |
|
|
Requires: postgresql%{pg_ver} |
18 |
|
|
Requires: postgresql%{pg_ver}-server |
19 |
|
|
Requires: postgresql%{pg_ver}-libs |
20 |
|
|
Requires: postgresql%{pg_ver}-contrib |
21 |
|
|
AutoReqProv: no |
22 |
|
|
|
23 |
|
|
%description |
24 |
|
|
This package adds necessary startup and configuration items for |
25 |
|
|
postgresql. |
26 |
|
|
|
27 |
|
|
%prep |
28 |
|
|
%setup |
29 |
|
|
|
30 |
|
|
%build |
31 |
|
|
mkdir -p root/etc/e-smith/pgsql/init |
32 |
|
|
perl createlinks |
33 |
|
|
|
34 |
|
|
mkdir -p root/var/log/postgresql |
35 |
|
|
mkdir -p root/home/e-smith/db/pgsql |
36 |
|
|
mkdir -p root/etc/e-smith/pgsql/init |
37 |
|
|
#ln -s root/var/lib/pgsql/%{pg_ver} root/var/lib/pgsql/cur |
38 |
|
|
|
39 |
|
|
%install |
40 |
|
|
rm -rf $RPM_BUILD_ROOT |
41 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
42 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
43 |
|
|
--file /sbin/e-smith/systemd/postgresql-initialize 'attr(0554,root,root)' \ |
44 |
|
|
--dir '/var/log/postgresql' 'attr(2750,postgres,postgres)' \ |
45 |
|
|
--dir '/home/e-smith/db/pgsql' 'attr(0750,root,root)' \ |
46 |
|
|
> %{name}-%{version}-filelist |
47 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
48 |
|
|
|
49 |
|
|
%clean |
50 |
|
|
rm -rf $RPM_BUILD_ROOT |
51 |
|
|
|
52 |
|
|
%files -f %{name}-%{version}-filelist |
53 |
|
|
%defattr(-,root,root) |
54 |
|
|
|
55 |
|
|
%changelog |
56 |
|
|
* Wed Nov 17 2021 Michel Begue <mab974@gmail.com> 0.2.0-1 |
57 |
|
|
- First import to Sme 10 (postgresql13) |
58 |
|
|
|
59 |
|
|
* Tue Sep 11 2007 Charlie Brady <charlieb@e-smith.com> 0.0.1-24 |
60 |
|
|
- Add support for localhost/private/public access settings to |
61 |
|
|
determine which network interfaces to bind to. |
62 |
|
|
|
63 |
|
|
* Thu May 24 2007 Charlie Brady <charlieb@e-smith.com> 0.0.1-23 |
64 |
|
|
- Determine correct format for network access specs in postgresql.conf |
65 |
|
|
at template expansion time (postgresql 7 and 8 need different |
66 |
|
|
directives). |
67 |
|
|
|
68 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
69 |
|
|
- Clean up spec so package can be built by koji/plague |
70 |
|
|
|
71 |
|
|
* Tue Feb 06 2007 Charlie Brady <charlieb@e-smith.com> 0.0.1-22 |
72 |
|
|
- Escape braces in full restore template. |
73 |
|
|
|
74 |
|
|
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
75 |
|
|
- Update to new release naming. No functional changes. |
76 |
|
|
- Make Packager generic |
77 |
|
|
|
78 |
|
|
* Fri Dec 01 2006 Charlie Brady <charlie_brady@mitel.com> 0.0.1-21 |
79 |
|
|
- Tighten permissions of dump file so that it is never world |
80 |
|
|
readable. |
81 |
|
|
- Fix restore scriptlet so that it exits silently if there is no |
82 |
|
|
dump to restore from. |
83 |
|
|
- Fix taint problem with restore script. |
84 |
|
|
- Fix services2adjust symlink names so that postgresl is stopped |
85 |
|
|
prior to restore, and restarted during timezone change. |
86 |
|
|
|
87 |
|
|
* Wed Oct 18 2006 Charlie Brady <charlie_brady@mitel.com> 0.0.1-20 |
88 |
|
|
- Expand template for 00_restore_backup pgsql.init script during |
89 |
|
|
pre-restore event, so that the dump is restored following next |
90 |
|
|
reboot. |
91 |
|
|
|
92 |
|
|
* Tue Oct 17 2006 Charlie Brady <charlie_brady@mitel.com> 0.0.1-19 |
93 |
|
|
- Fix permissions problem with restore from backup. |
94 |
|
|
|
95 |
|
|
* Mon Sep 25 2006 Charlie Brady <charlie_brady@mitel.com> 0.0.1-18 |
96 |
|
|
- Ensure that pre-backup event does not fail if postgresql is disabled. |
97 |
|
|
- Apply sigterm patch - included in -17 source, but not applied in build. |
98 |
|
|
|
99 |
|
|
* Thu Sep 21 2006 Charlie Brady <charlie_brady@mitel.com> 0.0.1-17 |
100 |
|
|
- Add control/t script so that SIGINT is used to terminate postgresql |
101 |
|
|
(so that existing connections cannot keep the server up indefinitely). |
102 |
|
|
|
103 |
|
|
* Thu Sep 14 2006 Charlie Brady <charlie_brady@mitel.com> 0.0.1-16 |
104 |
|
|
- Fix run script so that conf templates are not run until after |
105 |
|
|
initdb. |
106 |
|
|
|
107 |
|
|
* Thu Sep 7 2006 Charlie Brady <charlie_brady@mitel.com> 0.0.1-15 |
108 |
|
|
- Fix permissions of run files (typo). |
109 |
|
|
|
110 |
|
|
* Tue Aug 29 2006 Charlie Brady <charlie_brady@mitel.com> 0.0.1-14 |
111 |
|
|
- Fix comparison operator in tcpip template fragment. |
112 |
|
|
|
113 |
|
|
* Tue Aug 29 2006 Charlie Brady <charlie_brady@mitel.com> 0.0.1-13 |
114 |
|
|
- Fix ownership of config files (typo). |
115 |
|
|
|
116 |
|
|
* Tue Aug 29 2006 Charlie Brady <charlie_brady@mitel.com> 0.0.1-12 |
117 |
|
|
- Run all pgsql.init scripts is user 'postgres'. |
118 |
|
|
|
119 |
|
|
* Thu Aug 24 2006 Charlie Brady <charlie_brady@mitel.com> 0.0.1-11 |
120 |
|
|
- Require passwords for local socket and loopback socket connections |
121 |
|
|
except for 'postgres' user connecting via Unix domain socket. |
122 |
|
|
|
123 |
|
|
* Mon Aug 21 2006 Charlie Brady <charlie_brady@mitel.com> 0.0.1-10 |
124 |
|
|
- Add option to accept connections on tcpip socket. |
125 |
|
|
|
126 |
|
|
* Fri Aug 04 2006 Charlie Brady <charlie_brady@mitel.com> 0.0.1-09 |
127 |
|
|
- Fix permissions on log/run file, and fix name of pgsql/init |
128 |
|
|
directory. |
129 |
|
|
|
130 |
|
|
* Wed Jun 28 2006 Charlie Brady <charlieb@e-smith.com> |
131 |
|
|
- [0.0.1-08] |
132 |
|
|
- Deal more correctly with pgsql.init startup race condition. |
133 |
|
|
|
134 |
|
|
* Wed Jun 28 2006 Charlie Brady <charlieb@e-smith.com> |
135 |
|
|
- [0.0.1-07] |
136 |
|
|
- Add full database restore feature. |
137 |
|
|
|
138 |
|
|
* Wed Jun 28 2006 Charlie Brady <charlieb@e-smith.com> |
139 |
|
|
- [0.0.1-06] |
140 |
|
|
- Move config templates to the correct place. |
141 |
|
|
- Fix delete-db action to remove empty subdirectories of |
142 |
|
|
/var/lib/pgsql/data. |
143 |
|
|
|
144 |
|
|
* Wed Jun 28 2006 Charlie Brady <charlieb@e-smith.com> |
145 |
|
|
- [0.0.1-05] |
146 |
|
|
- Use chpst rather than setuidgid in run script. |
147 |
|
|
|
148 |
|
|
* Wed Jun 28 2006 Charlie Brady <charlieb@e-smith.com> |
149 |
|
|
- [0.0.1-04] |
150 |
|
|
- Add minimal templated configuration files. |
151 |
|
|
|
152 |
|
|
* Wed Jun 28 2006 Charlie Brady <charlieb@e-smith.com> |
153 |
|
|
- [0.0.1-03] |
154 |
|
|
- Fix broken pqsql.init. |
155 |
|
|
|
156 |
|
|
* Wed Jun 28 2006 Charlie Brady <charlieb@e-smith.com> |
157 |
|
|
- [0.0.1-02] |
158 |
|
|
- Add missing /etc/e-smith/pgsql/init directory |
159 |
|
|
|
160 |
|
|
* Wed May 24 2006 Charlie Brady <charlieb@e-smith.com> |
161 |
|
|
- [0.0.1-01] |
162 |
|
|
- initial release |