1 |
michel |
1.1 |
Summary: e-smith specific postgresql configuration and templates. |
2 |
|
|
%define name smeserver-postgresql |
3 |
|
|
Name: %{name} |
4 |
|
|
%define version 0.2.0 |
5 |
|
|
%define pg_ver 13 |
6 |
jpp |
1.4 |
%define release 4 |
7 |
michel |
1.1 |
Version: %{version} |
8 |
|
|
Release: %{release}%{?dist} |
9 |
|
|
License: GPL |
10 |
|
|
Group: Networking/Daemons |
11 |
|
|
Source: %{name}-%{version}.tar.gz |
12 |
jpp |
1.2 |
Patch0: smeserver-postgresql-0.2.0-preset.patch |
13 |
jpp |
1.3 |
Patch1: smeserver-postgresql-0.2.0-bz12264-backup.patch |
14 |
jpp |
1.4 |
Patch2: smeserver-postgresql-0.2.0-bz12290.patch |
15 |
jpp |
1.2 |
|
16 |
michel |
1.1 |
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
17 |
|
|
BuildArch: noarch |
18 |
|
|
BuildRequires: e-smith-devtools >= 2.6.0-10 |
19 |
|
|
Requires: e-smith-base >= 5.8.1 |
20 |
|
|
Requires: e-smith-lib >= 2.6.0-14 |
21 |
|
|
Requires: postgresql%{pg_ver} |
22 |
|
|
Requires: postgresql%{pg_ver}-server |
23 |
|
|
Requires: postgresql%{pg_ver}-libs |
24 |
|
|
Requires: postgresql%{pg_ver}-contrib |
25 |
|
|
AutoReqProv: no |
26 |
|
|
|
27 |
|
|
%description |
28 |
|
|
This package adds necessary startup and configuration items for |
29 |
|
|
postgresql. |
30 |
|
|
|
31 |
|
|
%prep |
32 |
|
|
%setup |
33 |
jpp |
1.2 |
%patch0 -p1 |
34 |
jpp |
1.3 |
%patch1 -p1 |
35 |
jpp |
1.4 |
%patch2 -p1 |
36 |
michel |
1.1 |
|
37 |
|
|
%build |
38 |
|
|
mkdir -p root/etc/e-smith/pgsql/init |
39 |
|
|
perl createlinks |
40 |
|
|
|
41 |
|
|
mkdir -p root/var/log/postgresql |
42 |
|
|
mkdir -p root/home/e-smith/db/pgsql |
43 |
|
|
mkdir -p root/etc/e-smith/pgsql/init |
44 |
|
|
#ln -s root/var/lib/pgsql/%{pg_ver} root/var/lib/pgsql/cur |
45 |
|
|
|
46 |
|
|
%install |
47 |
|
|
rm -rf $RPM_BUILD_ROOT |
48 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
49 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
50 |
|
|
--file /sbin/e-smith/systemd/postgresql-initialize 'attr(0554,root,root)' \ |
51 |
|
|
--dir '/var/log/postgresql' 'attr(2750,postgres,postgres)' \ |
52 |
|
|
--dir '/home/e-smith/db/pgsql' 'attr(0750,root,root)' \ |
53 |
|
|
> %{name}-%{version}-filelist |
54 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
55 |
|
|
|
56 |
|
|
%clean |
57 |
|
|
rm -rf $RPM_BUILD_ROOT |
58 |
|
|
|
59 |
|
|
%files -f %{name}-%{version}-filelist |
60 |
|
|
%defattr(-,root,root) |
61 |
|
|
|
62 |
|
|
%changelog |
63 |
jpp |
1.4 |
* Mon Dec 26 2022 Jean-Philippe Pialasse <tests@pialasse.com> 0.2.0-4.sme |
64 |
|
|
- fix failing pgsql.init service preventing restore [SME: 12290] |
65 |
|
|
|
66 |
jpp |
1.3 |
* Mon Dec 12 2022 Jean-Philippe Pialasse <tests@pialasse.com> 0.2.0-3.sme |
67 |
|
|
- fix pre-backup event fails error 256 [SME: 12264] |
68 |
|
|
|
69 |
jpp |
1.2 |
* Fri Dec 02 2022 Jean-Philippe Pialasse <tests@pialasse.com> 0.2.0-2.sme |
70 |
|
|
- fix preset OUT missing |
71 |
|
|
|
72 |
michel |
1.1 |
* Wed Nov 17 2021 Michel Begue <mab974@gmail.com> 0.2.0-1 |
73 |
|
|
- First import to Sme 10 (postgresql13) |
74 |
|
|
|
75 |
|
|
* Tue Sep 11 2007 Charlie Brady <charlieb@e-smith.com> 0.0.1-24 |
76 |
|
|
- Add support for localhost/private/public access settings to |
77 |
|
|
determine which network interfaces to bind to. |
78 |
|
|
|
79 |
|
|
* Thu May 24 2007 Charlie Brady <charlieb@e-smith.com> 0.0.1-23 |
80 |
|
|
- Determine correct format for network access specs in postgresql.conf |
81 |
|
|
at template expansion time (postgresql 7 and 8 need different |
82 |
|
|
directives). |
83 |
|
|
|
84 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
85 |
|
|
- Clean up spec so package can be built by koji/plague |
86 |
|
|
|
87 |
|
|
* Tue Feb 06 2007 Charlie Brady <charlieb@e-smith.com> 0.0.1-22 |
88 |
|
|
- Escape braces in full restore template. |
89 |
|
|
|
90 |
|
|
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
91 |
|
|
- Update to new release naming. No functional changes. |
92 |
|
|
- Make Packager generic |
93 |
|
|
|
94 |
|
|
* Fri Dec 01 2006 Charlie Brady <charlie_brady@mitel.com> 0.0.1-21 |
95 |
|
|
- Tighten permissions of dump file so that it is never world |
96 |
|
|
readable. |
97 |
|
|
- Fix restore scriptlet so that it exits silently if there is no |
98 |
|
|
dump to restore from. |
99 |
|
|
- Fix taint problem with restore script. |
100 |
|
|
- Fix services2adjust symlink names so that postgresl is stopped |
101 |
|
|
prior to restore, and restarted during timezone change. |
102 |
|
|
|
103 |
|
|
* Wed Oct 18 2006 Charlie Brady <charlie_brady@mitel.com> 0.0.1-20 |
104 |
|
|
- Expand template for 00_restore_backup pgsql.init script during |
105 |
|
|
pre-restore event, so that the dump is restored following next |
106 |
|
|
reboot. |
107 |
|
|
|
108 |
|
|
* Tue Oct 17 2006 Charlie Brady <charlie_brady@mitel.com> 0.0.1-19 |
109 |
|
|
- Fix permissions problem with restore from backup. |
110 |
|
|
|
111 |
|
|
* Mon Sep 25 2006 Charlie Brady <charlie_brady@mitel.com> 0.0.1-18 |
112 |
|
|
- Ensure that pre-backup event does not fail if postgresql is disabled. |
113 |
|
|
- Apply sigterm patch - included in -17 source, but not applied in build. |
114 |
|
|
|
115 |
|
|
* Thu Sep 21 2006 Charlie Brady <charlie_brady@mitel.com> 0.0.1-17 |
116 |
|
|
- Add control/t script so that SIGINT is used to terminate postgresql |
117 |
|
|
(so that existing connections cannot keep the server up indefinitely). |
118 |
|
|
|
119 |
|
|
* Thu Sep 14 2006 Charlie Brady <charlie_brady@mitel.com> 0.0.1-16 |
120 |
|
|
- Fix run script so that conf templates are not run until after |
121 |
|
|
initdb. |
122 |
|
|
|
123 |
|
|
* Thu Sep 7 2006 Charlie Brady <charlie_brady@mitel.com> 0.0.1-15 |
124 |
|
|
- Fix permissions of run files (typo). |
125 |
|
|
|
126 |
|
|
* Tue Aug 29 2006 Charlie Brady <charlie_brady@mitel.com> 0.0.1-14 |
127 |
|
|
- Fix comparison operator in tcpip template fragment. |
128 |
|
|
|
129 |
|
|
* Tue Aug 29 2006 Charlie Brady <charlie_brady@mitel.com> 0.0.1-13 |
130 |
|
|
- Fix ownership of config files (typo). |
131 |
|
|
|
132 |
|
|
* Tue Aug 29 2006 Charlie Brady <charlie_brady@mitel.com> 0.0.1-12 |
133 |
|
|
- Run all pgsql.init scripts is user 'postgres'. |
134 |
|
|
|
135 |
|
|
* Thu Aug 24 2006 Charlie Brady <charlie_brady@mitel.com> 0.0.1-11 |
136 |
|
|
- Require passwords for local socket and loopback socket connections |
137 |
|
|
except for 'postgres' user connecting via Unix domain socket. |
138 |
|
|
|
139 |
|
|
* Mon Aug 21 2006 Charlie Brady <charlie_brady@mitel.com> 0.0.1-10 |
140 |
|
|
- Add option to accept connections on tcpip socket. |
141 |
|
|
|
142 |
|
|
* Fri Aug 04 2006 Charlie Brady <charlie_brady@mitel.com> 0.0.1-09 |
143 |
|
|
- Fix permissions on log/run file, and fix name of pgsql/init |
144 |
|
|
directory. |
145 |
|
|
|
146 |
|
|
* Wed Jun 28 2006 Charlie Brady <charlieb@e-smith.com> |
147 |
|
|
- [0.0.1-08] |
148 |
|
|
- Deal more correctly with pgsql.init startup race condition. |
149 |
|
|
|
150 |
|
|
* Wed Jun 28 2006 Charlie Brady <charlieb@e-smith.com> |
151 |
|
|
- [0.0.1-07] |
152 |
|
|
- Add full database restore feature. |
153 |
|
|
|
154 |
|
|
* Wed Jun 28 2006 Charlie Brady <charlieb@e-smith.com> |
155 |
|
|
- [0.0.1-06] |
156 |
|
|
- Move config templates to the correct place. |
157 |
|
|
- Fix delete-db action to remove empty subdirectories of |
158 |
|
|
/var/lib/pgsql/data. |
159 |
|
|
|
160 |
|
|
* Wed Jun 28 2006 Charlie Brady <charlieb@e-smith.com> |
161 |
|
|
- [0.0.1-05] |
162 |
|
|
- Use chpst rather than setuidgid in run script. |
163 |
|
|
|
164 |
|
|
* Wed Jun 28 2006 Charlie Brady <charlieb@e-smith.com> |
165 |
|
|
- [0.0.1-04] |
166 |
|
|
- Add minimal templated configuration files. |
167 |
|
|
|
168 |
|
|
* Wed Jun 28 2006 Charlie Brady <charlieb@e-smith.com> |
169 |
|
|
- [0.0.1-03] |
170 |
|
|
- Fix broken pqsql.init. |
171 |
|
|
|
172 |
|
|
* Wed Jun 28 2006 Charlie Brady <charlieb@e-smith.com> |
173 |
|
|
- [0.0.1-02] |
174 |
|
|
- Add missing /etc/e-smith/pgsql/init directory |
175 |
|
|
|
176 |
|
|
* Wed May 24 2006 Charlie Brady <charlieb@e-smith.com> |
177 |
|
|
- [0.0.1-01] |
178 |
|
|
- initial release |