1 |
# $Id: smeserver-print-monitor.spec,v 1.5 2022/08/01 03:59:11 jpp Exp $ |
2 |
# Authority: dungog |
3 |
# Name: Stephen Noble |
4 |
|
5 |
%define name smeserver-print-monitor |
6 |
%define version 0.0.7 |
7 |
%define release 8 |
8 |
Summary: SME Server print monitor |
9 |
Name: %{name} |
10 |
Version: %{version} |
11 |
Release: %{release}%{?dist} |
12 |
License: Freely distributable |
13 |
Group: Apache/php/caching |
14 |
Source: %{name}-%{version}.tar.gz |
15 |
Patch0: smeserver-print-monitor-0.0.7-auth.patch |
16 |
Patch1: smeserver-print-monitor-0.0.7-Add-Update-event-to-createlinks.patch |
17 |
Patch2: smeserver-print-monitor-0.0.7-bz12058-httpd24.patch |
18 |
|
19 |
BuildRoot: /var/tmp/e-smith-buildroot |
20 |
BuildRequires: e-smith-devtools |
21 |
BuildArchitectures: noarch |
22 |
Requires: smeserver-release >= 10 |
23 |
Requires: e-smith-apache >= 2.6.0-19 |
24 |
Obsoletes: smeserver-lprng-monitor |
25 |
AutoReqProv: no |
26 |
|
27 |
%changelog |
28 |
* Sun Jul 31 2022 Jean-Philippe Pialasse <tests@pialasse.com> 0.0.7-8.sme |
29 |
- update to httpd 2.4 access syntax [SME: 12058] |
30 |
removed compat sections, adding Requirement for e-smith-apache >= 2.6.0-19 |
31 |
|
32 |
* Sun Jul 24 2022 Jean-Philippe Pialasse <tests@pialasse.com> 0.0.7-6.sme |
33 |
- update to httpd 2.4 access syntax [SME: 12058] |
34 |
|
35 |
* Sun Mar 28 2021 Brian Read <brianr@bjsystems.co.uk> 0.0.7-5.sme |
36 |
- Add Update event to createlinks [SME: 11067] |
37 |
|
38 |
* Sun Mar 28 2021 BogusDateBot |
39 |
- Eliminated rpmbuild "bogus date" warnings due to inconsistent weekday, |
40 |
by assuming the date is correct and changing the weekday. |
41 |
|
42 |
* Thu Oct 29 2020 Brian Read <brianr@bjsystems.co.uk> 0.0.7-4.sme |
43 |
- Initial import to SME10 [SME: 11067] |
44 |
|
45 |
* Mon Jun 13 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.0.7-3.sme |
46 |
- Add Update event to createlinks missing AuthBasicProvider external |
47 |
- thank you to Anne aka Ecureuil for providing the fix and testing. |
48 |
|
49 |
* Fri Sep 18 2009 Stephen Noble <support@dungog.net> 0.0.7-1.sme |
50 |
- build for sme contribs |
51 |
- rename smeserver-lprng-monitor |
52 |
|
53 |
%description |
54 |
Print monitoring for SME Server |
55 |
|
56 |
%prep |
57 |
%setup |
58 |
%patch0 -p1 |
59 |
%patch1 -p1 |
60 |
%patch2 -p1 |
61 |
|
62 |
%build |
63 |
perl createlinks |
64 |
|
65 |
%install |
66 |
rm -rf $RPM_BUILD_ROOT |
67 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
68 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
69 |
--file '/usr/local/lprng/info/lpinfo.ph' 'attr(755,root,root)' \ |
70 |
--file '/usr/local/lprng/bin/lpinfo' 'attr(755,root,root)' \ |
71 |
--file '/var/www/html/LPRng/admin/cgi-bin/lpinfo_lpc_suid' 'attr(4755,root,root)' \ |
72 |
--file '/var/www/html/LPRng/admin/cgi-bin/lpinfo_lpq_nt' 'attr(4755,root,root)' \ |
73 |
--file '/var/www/html/LPRng/admin/cgi-bin/lpinfo_lprm_suid' 'attr(4755,root,root)' \ |
74 |
--file '/var/www/html/LPRng/admin/cgi-bin/suid.ph' 'attr(4755,root,root)' \ |
75 |
--file '/var/www/html/LPRng/cgi-bin/lpinfo' 'attr(755,root,root)' \ |
76 |
--file '/var/www/html/LPRng/cgi-bin/lpinfo_lprm' 'attr(755,root,root)' \ |
77 |
> %{name}-%{version}-filelist |
78 |
echo "%doc " >> %{name}-%{version}-filelist |
79 |
|
80 |
%clean |
81 |
rm -rf $RPM_BUILD_ROOT |
82 |
|
83 |
%files -f %{name}-%{version}-filelist |
84 |
%defattr(-,root,root) |